Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: cannot get Java to load for IE 32 bit


05 Apr 2009   #1

64 bit Windows 7
 
 
cannot get Java to load for IE 32 bit

Java will not load for the 32 bit browser ...anybody else have this problem?? Subsequently, Firefox and Safari won't load either

help


My System SpecsSystem Spec
.

05 Apr 2009   #2

Win 7
 
 

Did you install the 64 bit java by mistake?
My System SpecsSystem Spec
05 Apr 2009   #3

64 bit Windows 7
 
 
Java and IE 32 bit

Quote   Quote: Originally Posted by YupYup View Post
Did you install the 64 bit java by mistake?
no, I intended ti install 64 bit Java but I also need 32 bit Java
My System SpecsSystem Spec
.


02 Nov 2009   #4

Windows 7
 
 

I have been having problems with Java as well. The problem I am having is for some reason when I try to do anything associated with java, even run the test they give you after you install java to see if it's working, all of my browsers close. I'm using firefox, but there are problems when I try to use IE also. I don't think it was windows 7 that did it because when I first downloaded it, it was working fine.. but now its broken or something...
My System SpecsSystem Spec
20 Jun 2011   #5

Windows 7 Enterprise x64
 
 
A possible fix?

Hi All,

Sorry for dragging up a new post, but I have had a similar experience and wanted to help anyone else who has had this infuriating problem.

My 32-bit install wouldn't work at all. I would double-click on the installer file, the 'spinner' would show the computer was doing something then nothing would happen. I tried redownloading, didnt work. I tried running JavaRA to remove and registry entries or BHO's that were causing a problem. Didn't work.

So I did a process monitor (thanks sysinternals) to try to find why the installer wasn't working and made a nice discovery. No idea why it wouldn't install, but ... I found the files are extracted from the downloaded binary and are expanded into a directory. And because the installer dies before running the files, it leaves them there.

So I just ran this file (I was updating jre1.6.0_26 as you can tell):

%USERPROFILE%\AppData\LocalLow\Sun\Java\jre1.6.0_26\jre1.6.0_26.msi

And the installer started working! It all installed fine!

Of course change the Java JRE version to what versuion you are using. Hope this helps. It did in my case.

Cheers

Terry
My System SpecsSystem Spec
21 Jun 2011   #6

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums Terry. Thanks for sharing. Hopefully it will help someone. A Guy
My System SpecsSystem Spec
31 Jul 2011   #7

Windows 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by tezzatheman View Post
Hi All,

Sorry for dragging up a new post, but I have had a similar experience and wanted to help anyone else who has had this infuriating problem.

My 32-bit install wouldn't work at all. I would double-click on the installer file, the 'spinner' would show the computer was doing something then nothing would happen. I tried redownloading, didnt work. I tried running JavaRA to remove and registry entries or BHO's that were causing a problem. Didn't work.

So I did a process monitor (thanks sysinternals) to try to find why the installer wasn't working and made a nice discovery. No idea why it wouldn't install, but ... I found the files are extracted from the downloaded binary and are expanded into a directory. And because the installer dies before running the files, it leaves them there.

So I just ran this file (I was updating jre1.6.0_26 as you can tell):

%USERPROFILE%\AppData\LocalLow\Sun\Java\jre1.6.0_26\jre1.6.0_26.msi

And the installer started working! It all installed fine!

Of course change the Java JRE version to what versuion you are using. Hope this helps. It did in my case.

Cheers

Terry
Terry, you're the best! Thanks. I must've lost my rep privileges else I'd give you some. (weird, I'm logged in and, after reading my post, the only one I can rep is myself but only in this thread - everywhere else is fine ... )

Regardless, a huge thumbs up! Again, thanks!
My System SpecsSystem Spec
31 Jul 2011   #8

Windows 7 Ultimate x64 SP1
 
 

Rep isn't available to posts older than 28 days, so the rep icons don't show up on the posts, and it isn't possible to rep yourself.
My System SpecsSystem Spec
31 Jul 2011   #9

Windows 7 Ultimate x64 SP1
 
 

Thanks, Airbot. I didn't try to rep myself, it's just that the icon shows up. Hadn't noticed that before - I always thought the icon was missing on one's own posts. Mea Culpa, I've been gone awhile ...
My System SpecsSystem Spec
Reply

 cannot get Java to load for IE 32 bit




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:57 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33