Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: IE8 (and other browsers) not working after update

02 Mar 2010   #1

Windows 7
IE8 (and other browsers) not working after update

This problem seemed to coincide with a critical Windows 7 update around 15th Feb but could have been related to installing Webroot internet security around the 27th Feb. Basically when starting IE8 it just hangs completely. Tried running Chrome then installed Firefox and all do the same thing.
Skype and Outlook are both working fine.
Troubleshooting and diagnostics dont seem to be able to find a problem.
Tried to system restore but cant because it says I need to disable the antivirus - done that and it still wont restore. I could uninstall Webroot then try to restore to pre-update time but would appreciate any advise thanks.
Note - had a few problems getting on to IE8 after the critical update but now IE8 wont run at all, ever.

Seem to have fixed by downloading a shortcut for IE without add-ons. Disabled the Norton ad-on and seems to be running OK now

My System SpecsSystem Spec
02 Mar 2010   #2

Windows 7 Professional x64


I would uninstall Webroot and try the system restore. Certainly sounds as if Webroot is causing the problem.
My System SpecsSystem Spec

 IE8 (and other browsers) not working after update

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Internet working everywhere but the browsers!?
Hey! I am, as you can tell by the title, experiencing some internet issues with my web browsers. Here's the deal: Every program that uses internet works just fine, though there might be a slight delay connecting at first, but they're working (ex. Skype, Origin, Windows Mail App). However, the...
Network & Sharing
Browsers not working properly on windows 7
I have two problems. when I use internet explorer, it constantly flickers, especialy during videos. When I use google chrome it doesn't flicker but youtube freezes up
Browsers & Mail
Browsers Not Working Behind New Router
I've never used a router before as I had the sole computer in the house. My daugter just got a new laptop so I bought and installed a D-Link DIR-825. I've set the time and I've installed the latest firmware. Since installing the router, my browsers (IE and Mozilla Firefox) have been acting up....
Network & Sharing
All browsers apart from IE now working
Hi, I am a web developer, and so need access to a large number of web browsers. About a week ago Chrome stopped working with the error Error 10 (net::ERR_ACCESS_DENIED): Unknown error. I reinstalled with no success. I then had work which required firefox and opera. I downloaded and installed...
Browsers & Mail
32 bit browsers not working 64 bit fine ???
I am Having problems after doing a full clean install of windows 7 64 bit on my pc about two weeks ago I was pleased to see that everything seemed to be working well but over time the nagging faults have started to creep in it has started to restart itself just after the log in screen and also to...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:12.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App