Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: have to type a character 2x to make it appear

08 Mar 2010   #1

Windows 7
have to type a character 2x to make it appear

This is on an HP netbook with Win7. If I want to type, e.g. Rene's cat
then typing the apostrophe does NOT work; nothing shows for the apostrophe until I type the "s" following it.
If I type ONE apostrophe and wait "some seconds (10 maybe?) and THEN type the apostrophe AGAIN, both of them appear.

Do you think there is a setting or pref someplace that should be changed?

I think the same thing happens with her quotation (") marks.

My System SpecsSystem Spec
08 Mar 2010   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install


Unique problem, but I will give it a shot.

Control Panel>keyboard
Adjust the repeat and/or delay settings. Experiment, it may help.

My repeat factory setting (which I still have) is set for the fastest.
Delay is about 3/4 way to the right.
My System SpecsSystem Spec
09 Mar 2010   #3

Windows 7 Professional x64

Almost sounds like you're typing ` and not ' with a non-US keyboard setting.
My System SpecsSystem Spec

09 Mar 2010   #4

Win7 Home Premium 64x

Check your language bar settings and make sure you are using English>Keyboard>US
if you are using foriegn keyboard setups or english>international then your typing the ` and then e will give you

i was on same line as DarkRystar....

I have just tested it on my keyboard and got the same thing with the 's ..try it...

Stickmaker's problem "apostrophe not showing" is happening on my XP system. I don't know what setting to change, but I didn't see one in the control panel. <--In this post, none of the ' or '' showed up until either a space was typed or a letter was typed.
My System SpecsSystem Spec
09 Mar 2010   #5

Windows 7

THANKS to all of you; it was set for Canadian English (as it should be 'cause we are in CANADA) but we had to change it to US English. Hmmmmmm; does not sound kosher, but it works. Thanks again.
My System SpecsSystem Spec
09 Mar 2010   #6

Microsoft Community Contributor Award Recipient


This is my response to a similar post couple months ago. The thread might explain the issue to you.

My System SpecsSystem Spec

 have to type a character 2x to make it appear

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Is default email account type deteremined by type of device?
I set up an Outlook account on a new-to-me laptop. I had been unable to download email for several months, since I didn't have a computer. I had been saving the emails I wanted to keep and had planned on downloading them into my new computer. After setting up the account, it appeared the system...
Microsoft Office
How to make unallocated space to basic type disk
any body can help how to solve this? iwant to make unallocated space to basic disk. but a problem is occuring
General Discussion
how to deal with photo files Type 1 and Type 2
I found a few pix in my files that I want to edit with Photoshop. I can't open them in PS because they are Type 1 or Type 2. When I try to open them, PS says they are .jpg.1 or. jpg.2. How do I get rid of the .1 and .2 so they become normal JPG photo files? I can look at them with Windows...
Music, Pictures & Video
Character Problem
Hello, I am doing video editing and I am using more than one computer. Mostly Ultimate and Home Premium. When I arrange the video on Ultimate, sometimes I am sending it to Home Premium to encode but then if I am using non-English (usually French) characters (for example ), it is changing to...
Music, Pictures & Video
wanted to make sure this type of cpu is compat with my mobo...
Hey, I was just wondering (well.. double checking) if my old AMD Athlon 64 3200+ would be compatible inside this Asus M4A785-M mobo. I've looked up exactly what CPU's it works with but I thought I'd drop by here and ask you all because... well... I'd much rather get the opinions and advice from...
Hardware & Devices
Slow deletes (character by character)
This probably has nothing to do with Windows 7, but I thought someone on this forum would know. When in a text editor like on this forum or on Microsoft word and when I delete and hold it down it will be really slow. Characters would only delete every half a second no matter what. Anyone...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:16.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App