Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer 8 Painfully Slow after Vista Upgrade

09 Jun 2010   #1
lpaul626

Windows 7
 
 
Internet Explorer 8 Painfully Slow after Vista Upgrade

Hi Everyone-

First post for me. A few days ago, I upgraded from Vista Home version on my Dell Inspiron laptop to Windows 7. Since doing the upgrade, Internet Explorer is painfully slow loading websites. I use a Linksys Wireless router with which my laptop previouslly ran well prior to the upgrade. I've also tried the LAN connection with the same results.

Connectivity seems to be fine and I've run the diagnostic which found no problems. I've also disabled all add-ons.

Thoughts?

Thanks in advance-


My System SpecsSystem Spec
.

09 Jun 2010   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Welcome

To help me diagnose, try another browser. FF and Chrome are good choices.
Take this speed test, too

http://speedtest.net/index.php

What are the results?
My System SpecsSystem Spec
09 Jun 2010   #3
lpaul626

Windows 7
 
 

Thanks! I will try it tonight when I'm home and report back.
My System SpecsSystem Spec
.


09 Jun 2010   #4
lpaul626

Windows 7
 
 

I just ran the test and the results were as follows:

download - 12.21 mb/s
upload - 8.06 mb/s

For comparison purposes, I ran the same test on an older lap top (approx 3.5 years old - Dell Latitude D620) running Windows XP and the results were as follows:

Download - 18.44 mb/s
Upload - 8.93 mb/s

To put things into perspective, both laptops were side by side approx. 50-60 ft from the router.

My wife also indicated that the mail program in 7 is also painsfully slow to start up.

Any thoughts?
My System SpecsSystem Spec
09 Jun 2010   #5
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Nothing wrong with those speeds, so not your ISP. Try a new broswer, Chrome has a good reputation for speed.
My System SpecsSystem Spec
10 Jun 2010   #6
roncerr

Windows 8 Pro w/MC 32-bit
 
 

Quote   Quote: Originally Posted by lpaul626 View Post
... I upgraded from Vista Home version...to Windows 7...
Were you able to do a clean install?
http://www.winsupersite.com/win7/cle...rade_media.asp
Did you follow up the clean install with all the Windows Updates for IE8 and Win7?

Does it take a long time just to open a blank tab? (I had this problem when using Vista after switching from IE7 to IE8 but that problem lasted almost a year and magically cleared up with future Windows Updates.)
My System SpecsSystem Spec
10 Jun 2010   #7
lpaul626

Windows 7
 
 

Actually, I wasn't aware of this. I will take a look tonight. Thanks-
My System SpecsSystem Spec
Reply

 Internet Explorer 8 Painfully Slow after Vista Upgrade




Thread Tools





Similar help and support threads
Thread Forum
WMP Painfully Slow (Not Responding)
Having traversed many of the forums/threads and tried most suggestions offered, I come to the conclusion than the μSoft WMP folks should, by this time realize that their product has serious performance problems/issues when dealing with relatively large media DBs. I would suggest that there exists...
Music, Pictures & Video
I plugged out my PC as it was shutting down. Now it is painfully slow.
Hi, I'm not sure if something similar has been posted here before, spent a while searching the net for similar isuues but found nothing... The other night, I plugged out my PC as it was shutting down. Now it is painfully slow to start up.... It's on the black "Starting Windows" screen for a good...
Performance & Maintenance
Please Help:Painfully slow internet at work but okay at home.
Hi Everyone, I have a very strange problem. I am using a Windows 7 ASUS laptop N61J. I can connect to the internet fine at home and get good speeds at home. However, when I go to work and connect to the wireless there my internet speed is so slow I want to dig out my old dialup modem and start...
Network & Sharing
Painfully Slow Internet Browsing, High Ping
Hello. In the last 3 or 4 days, my desktop computer running Windows 7 64-Bit has been practically unable to browse internet pages, play online games, or load YouTube videos. I don't know what caused this, and nothing jumps out at me suggesting what might be causing this. Any help would be really...
Network & Sharing
Painfully slow printer
Hello, I have installed Windows 7 Ultimate on my pc. I love it. All is fine but my printer. The software disk says it will work with windows os through xp. I tried to load it anyway. I get an error when I try to load it saying it cannot run command. The printer is an HP Photosmart C6180 all...
Software
netbook wifi painfully slow
I have a Samsung NC10 with W7 installed (build 7264). My wifi has always been fine, fairly speedy for a netbook. However, now that I'm overseas in the middle east at this time, its very slow specifically for me. I'm connected to a cable connection. My two friends are upstairs and their...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App