Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer 8 Painfully Slow after Vista Upgrade


09 Jun 2010   #1

Windows 7
 
 
Internet Explorer 8 Painfully Slow after Vista Upgrade

Hi Everyone-

First post for me. A few days ago, I upgraded from Vista Home version on my Dell Inspiron laptop to Windows 7. Since doing the upgrade, Internet Explorer is painfully slow loading websites. I use a Linksys Wireless router with which my laptop previouslly ran well prior to the upgrade. I've also tried the LAN connection with the same results.

Connectivity seems to be fine and I've run the diagnostic which found no problems. I've also disabled all add-ons.

Thoughts?

Thanks in advance-


My System SpecsSystem Spec
.

09 Jun 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Welcome

To help me diagnose, try another browser. FF and Chrome are good choices.
Take this speed test, too

http://speedtest.net/index.php

What are the results?
My System SpecsSystem Spec
09 Jun 2010   #3

Windows 7
 
 

Thanks! I will try it tonight when I'm home and report back.
My System SpecsSystem Spec
.


09 Jun 2010   #4

Windows 7
 
 

I just ran the test and the results were as follows:

download - 12.21 mb/s
upload - 8.06 mb/s

For comparison purposes, I ran the same test on an older lap top (approx 3.5 years old - Dell Latitude D620) running Windows XP and the results were as follows:

Download - 18.44 mb/s
Upload - 8.93 mb/s

To put things into perspective, both laptops were side by side approx. 50-60 ft from the router.

My wife also indicated that the mail program in 7 is also painsfully slow to start up.

Any thoughts?
My System SpecsSystem Spec
09 Jun 2010   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Nothing wrong with those speeds, so not your ISP. Try a new broswer, Chrome has a good reputation for speed.
My System SpecsSystem Spec
10 Jun 2010   #6

Windows 8 Pro w/MC 32-bit
 
 

Quote   Quote: Originally Posted by lpaul626 View Post
... I upgraded from Vista Home version...to Windows 7...
Were you able to do a clean install?
http://www.winsupersite.com/win7/cle...rade_media.asp
Did you follow up the clean install with all the Windows Updates for IE8 and Windows 7?

Does it take a long time just to open a blank tab? (I had this problem when using Vista after switching from IE7 to IE8 but that problem lasted almost a year and magically cleared up with future Windows Updates.)
My System SpecsSystem Spec
10 Jun 2010   #7

Windows 7
 
 

Actually, I wasn't aware of this. I will take a look tonight. Thanks-
My System SpecsSystem Spec
Reply

 Internet Explorer 8 Painfully Slow after Vista Upgrade




Thread Tools



Similar help and support threads for2: Internet Explorer 8 Painfully Slow after Vista Upgrade
Thread Forum
I plugged out my PC as it was shutting down. Now it is painfully slow. Performance & Maintenance
Please Help:Painfully slow internet at work but okay at home. Network & Sharing
Painfully Slow Internet Browsing, High Ping Network & Sharing
Painfully slow printer Software
Office apps painfully slow to save Microsoft Office
Digital River Download painfully slow! General Discussion
netbook wifi painfully slow Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:22 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33