Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Firefox suddenly slowed

09 May 2009   #1
dannet

Windows 7 Professional x86
 
 
Firefox suddenly slowed

I'm running the latest version of firefox and in the last couple of days it's suddenly slowed right down when accessing a lot of websites.

Internet explorer 8 doesn't seem to have been affected though. Has anyone else found their firefox unusually slow or managed to fix this?


My System SpecsSystem Spec
09 May 2009   #2
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

I have had mine do it on the odd occasion, but I usually just run CCleaner, restart and it speeds up again.
My System SpecsSystem Spec
09 May 2009   #3
dannet

Windows 7 Professional x86
 
 

Just tried CCleaner and it had no effect so I guess it was something else. I even enabled pipelining in firefox to try and speed it up and it hasn't sped it up. It's still taking an unusually long time to load some websites.
My System SpecsSystem Spec
09 May 2009   #4
12eason

Windows 7077
 
 

Tried it in safe mode?
My System SpecsSystem Spec
11 May 2009   #5
dannet

Windows 7 Professional x86
 
 

Hmm when I try and start safe mode a norton windows comes up called 'recovery mode' asking for a registration key and when I cancel it it loads windows normally?

Can I not bypass this?
My System SpecsSystem Spec
11 May 2009   #6
12eason

Windows 7077
 
 

Hmm, I meant FF is safe mode. It's under its startmenu folder.
My System SpecsSystem Spec
14 May 2009   #7
dannet

Windows 7 Professional x86
 
 

Hmm I reinstalled it and now it seems to be working fine. Before this I tried safe mode but it didn't seem to make any difference so I'm not sure what the problem was but nevermind.

Thanks anyway.
My System SpecsSystem Spec
14 May 2009   #8
burtie

Vista/Windows 7
 
 

I used to get this problem with firefox after a while of using it...a fresh install always seemed to sort it out.
My System SpecsSystem Spec
14 May 2009   #9
ZoeButton55

Vista
 
 

I came across this situation twice before, and my solutions were reinstallation. I want to know whether somebody has other solutions?? I don't like reinstallation every time.
My System SpecsSystem Spec
15 May 2009   #10
burtie

Vista/Windows 7
 
 

Unfortunetly no I never did
In the end I gave up on FF and now use Chrome instead.
I dont know what it is about the recent FF releases but they have always been getting slow after some time of usage. it never used to happen with V2 its only been with V3+
My System SpecsSystem Spec
Reply

 Firefox suddenly slowed




Thread Tools





Similar help and support threads
Thread Forum
Firefox profiles suddenly deleted and browser updated after reset
Hello, After steam started acting funny I quickly rebooted the PC. Since the PC had been running for a few days lots of programs were running and I was too lazy to wait for them to shut down - so I simply reset the PC. Big mistake apparently. Firefox, v. 3.6.25 was updated to 4.01 after the...
Browsers & Mail
slowed down boot up
OK, i was in Cali for about 4 days so i left my pic on to remote access it from my iPhone (bf3 early beta was about to come out so i wanted to download it before i got back) any ways, when i came back i turned it off for the first time since i left and back on. since them my PC has been taking a...
Performance & Maintenance
PC slowed right down the last two or three days.
A heads up more than anything. Was messing about, downloading, installing and uninstalling gadgets the last few days. My PC started to slow right down. I'd only installed paint.NET so I removed that, but no difference. I couldn't figure out what was going on. I cleaned out all the trash (temps...
Gadgets
Win 7 Slowed WAY down
Guys, I am having a problem with my PC that maybe you can help me with. Yesterday all of a sudden everything slowed WAY down. It would take 2-3 minutes for the system to respond to anything. Resources were at 75-100%. A problem like this is hard to work on when it takes so long for anything...
Performance & Maintenance
Win 7 slowed to a crawl
My system has slowed to a crawl (and rebooting makes no difference). Every mouse click takes anything between 10 and 60 seconds to get a response and most programmes state 'not responding'. When I boot into Safe Mode it's fine, so I'm guessing it's not a hardware problem. I tried rolling...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App