Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Boot problems, windows gets hung

14 Sep 2010   #1

Windows 7
Boot problems, windows gets hung

Windows did an auto update on my computer about 2 weeks ago. Since then, when i try to start my computer it says it wants to check my C drive and that if i want to skip i should hit any key. However, when i hit a key nothing happens, and when i let the 10 seconds pass where it should begin the disk check nothing happens. It gets hung up or something. I can't do anything and it won't do anything. It just sits there. What can I do short of wiping my computer.

Additionally, if it helps, i have a partitioned hard drive that has both Linux Mint and Windows 7 to boot from. Thus far i can still use my computer if i boot into Linux from the grub screen. In Linux i can still access all my files. Is there someway i can perform a system recovery or access a certain file to allow window to boot?

Thank you for any help

My System SpecsSystem Spec
14 Sep 2010   #2
Microsoft MVP


I would first try these free diagnostics:
H/W Diagnostics:
Please start by running these bootable hardware diagnostics:
Memory Diagnostics (read the details at the link)
HD Diagnostic (read the details at the link)

Also, please run one of these free, independent online malware scans to ensure that your current protection hasn't been compromised: Malware (read the details at the link)
If it still has problems, then try Startup Repair using this guide: Startup Repair
My System SpecsSystem Spec
14 Sep 2010   #3

Windows 7 Professional x64

In addition to usasma's excellent advice, you may consider trying a system restore to get to a point before the troubles.
My System SpecsSystem Spec


 Boot problems, windows gets hung

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Windows 7 will not complete install. gets hung up after first reboot
So i am trying to do a clean install of win7 on my Lenovo t510. It has 8 gb of DDR3 1333 ram non ECC. i5 quad. i have tried 3 different HDD. 2 different install disks. even a USB with a bootable windows 7 on it. It seems to install fine until the first reboot. looks somewhat like this but with...
Installation & Setup
Hung up on boot screen (HP Pavilion)
My system - HP Pavilion Desktop P6310f, AMD Athlon II x4 630 2.8GHz, 6gb ram, GForce 8600GT, 1Tb HDD (new installed 12 mnts ago), Win7 64bit installed by a vendor. When I got it home, I created 3 Recovery DVDs. System have worked fine. Uninstalled a program today, that I do not use and did a...
Hardware & Devices
computer hung on boot with windows logo
I installed a raid combo card with sata and ide and also hooked up two ide drives now boot never finishes even if i boot with a backup drive or from a win pe dvd i have set bios back to defaults and still will not boot
Hardware & Devices
Windows 7 Ultimate OEM for System Builders-Hung on "Completing Install
I'm trying to install a Windows 7 Ultimate OEM x64 DVD that I got from NewEgg. It's called "For Systembuilders". It does the first phase of the install OK and reboots. it goes through a similar looking process, this time displaying a 100MB partition, and the other drive. it goes through...
Installation & Setup
Ide problems and cant boot into Windows
Hoping someone can help an idiot. Story so far is ( and I am sorry it's a long one ): windows 7 machine working fine. bust laptop so while it was being repaired borrowed wife's Eee pc so as it is Linux tried to put Debian on my PC. Screwed up mbr and ? on boot Bios finds 2 HDD 1 CDROM and 1...
Hardware & Devices
Windows 7 hung on setup is starting services
this is what i have done so far. got a win 7 dell pc, a vostro 400 to be precise. installed all apps and settings that we need on our desktops. then i used sysprep to run the OOBE and generalize switch, then booted into windows PE to capture an image .wim file of the entire isntallation. this .wim...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:52.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App