Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Hangs/Freezes when using Add/Remove Programs

23 Sep 2010   #11

Windows 7 Ultimate 32bit

I have now performed the clean boot and the problem persists.
MalwareBytes did not find anything.

Autoruns shows the following services still running:

I want to let you know that I have tried the cmd-tool WMIC, to call the installed programs list, and the system did not hang not freeze. (While in normal boot)

My System SpecsSystem Spec
23 Sep 2010   #12

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Bottom line:
No problem in safe mode, but the problem still occurs in clean boot?
My System SpecsSystem Spec
23 Sep 2010   #13

Windows 7 Ultimate 32bit

Yes, you are correct Richard.
My System SpecsSystem Spec

23 Sep 2010   #14

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Did the problem just start?
If so, have you added or changed anything that may relate to the problem.
My System SpecsSystem Spec
23 Sep 2010   #15

Windows 7 Ultimate 32bit

The problem started when troubleshooting the problems in the thread referred to in 1st post.

The first time I had a problem with the add/remove programs, I was heading to remove Panda Cloud Antivirus.
When I found Panda in the list, I clicked on it, at then it just hang, I could move my mouse around, but nothing responded. Then I Ctrl+Alt+del and clicked the Task Manager, then it showed the desktop while the mouse icon was showing a blue ring, which circles around, for 1 sec and then froze. Stopped.

After removing Panda it seems that I can load add/remove programs just fine, but if I stay more than 3 seconds it acts as the first time. And it seem to happen a lot earlier if I scroll down. (Do not even reach the bottom)

I have checked the system clock and the Logs, nothing to notice when it happens.
My System SpecsSystem Spec
23 Sep 2010   #16

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

This is what I think. The major difference between clean boot and safe mode, is that SM loads only minimum drivers, all none Microsoft drivers are not installed.
Since you work fine in SM but not clean boot, I tend to think that it is a driver problem.

To a lesser extent, I think that it is registry problems.

Solution. A system restore would solve the problem, but then you will go back to the time that you had the BSOD problems, which I hope are resolved now.

In lieu of the above, try an SFC scan.
SFC /SCANNOW Command - System File Checker Run three times if errors are found
If not sucessful
Try a repair install. Back up your stuff, just in case.
Repair Install
My System SpecsSystem Spec
23 Sep 2010   #17

MS Windows 7 Ultimate SP1 64-bit

Is following correct:
Safe Mode works,
MalwareBytes full scan gave you a clean bill of health,
MSE full scan gave you a clean bill of health.

If and only if all of above are true, then
Go to ASUS website and make 100% sure you have the latest bios firmware installed.

And although I don't think following will solve your problem, but it certainly won't hurt:
Download, install and run CCLEANER and also run the registry clean portion thereof.
CCleaner - Optimization and Cleaning - Free Download

If you still have problems, then try following:
Go to the website of your graphics card, and fetch and install the very latest Win 7 driver for the graphics card.

Graphic card drivers are probably the most troublesome drivers.

Still got problems, then zip up your minidump file and include same in your next post.

There are some real experts here at correctly reading a minidump.
My System SpecsSystem Spec
23 Sep 2010   #18

Windows 7 Ultimate 32bit

Ok, sorry for this late post, I have been away from home.

As I already have tried the SFC /SCANNOW command several times, and I rather not set my system back in time, I went with the Repair Install.

This happened, both with the CD and with a bootable USB. (I know I have to run it inside a normal boot of windows with a admin account, and I did)

I started the installation, next, next, and came to the screen where the choice between an Upgrade or a Custom Install is presented.
I chose upgrade, and next thing is the setup wizard will check for compatibility. In this process it hangs and acts exactly as it does when I use the Add/Remove program tool. Only thing to do -> Power button.

Safe Mode works, both MSE and MalwareBytes full scan gives me clean sheets.

The latest BIOS firmware is installed (1201).

CCleaner has been used many times doing the last weeks and every day during the past days.

I see my Graphic card drivers are from 08-03-2010 and ATI already came with a new one 09-15-2010.
I will try that one and let you know.

@Karlsnooks - You want minidump files created by BSODs?
I think these problems are gone, thanks to richc46, but if you want them I will shure give in next post.

Thank you both so far!
My System SpecsSystem Spec
23 Sep 2010   #19

Windows 7 Ultimate 32bit

Well, either it just hang or else it just shows different numbers when looking at the driver page, and checking in the Catalyst Control Center.

The recent zipped minidump files package can be downloaded in first post here ->

My System SpecsSystem Spec
23 Sep 2010   #20

Windows 7 Professional x64

Good going Rich.

crate: do I understand that Rich solved the problem, or do you still have troubles?
My System SpecsSystem Spec

 Hangs/Freezes when using Add/Remove Programs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Recently installed programs not showing up in add/remove programs?
Hello Today I decided to install some stuff on my computer as it was out of date.. I installed Java, Flash player and adobe reader X but when I go to add/remove they are not showing up in that section? Has anyone any suggestions or advice as to why this is happening? Thank you.
Remove entries in Programs and Features" without uninstalling programs
Is there a way to remove entries from "Programs and Features"? The screenshot shows many entries for MegaSceneryEarth, can I get rid of all these entries someway? I do not want to uninstall the program, I just do not want all this crap showing up under "Programs and Features".
Random Freezes and Hangs
Hey Whats going on : Recently I started experiencing random Freezes and Hangs. Even during logon My computer was working fine till yesterday night. In the morning I was in a hurry and Shut down the laptop. Windows asked me if I wanted to Force Close all programs which I did. Now it...
BSOD Help and Support
screen freezes and hangs
I have a HP laptop , IE 8 and my screen freezes and hangs just while Googling . I have tried alot of fixes and nothing works . any ideas ??? THANKS Roz
Browsers & Mail
Lockups, Freezes, Hangs
Hi, I ran RC7100 since it was released. When I upgraded from 7000 to 7100 I ran into what appeared to be an ACPI issue, but on closer inspection turned out to be resolved early on by disabling my Belkin WiFi card. A while later my LAN Nic blew out so I reenabled the belkin wireless and the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:40.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App