Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Hangs/Freezes when using Add/Remove Programs

24 Sep 2010   #21

Windows 7 Ultimate 32bit

Hello Jonathan

Rich helped me with my problems in this thread ->

The problems described in this thread are still there - not solved.

My System SpecsSystem Spec

 Hangs/Freezes when using Add/Remove Programs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Recently installed programs not showing up in add/remove programs?
Hello Today I decided to install some stuff on my computer as it was out of date.. I installed Java, Flash player and adobe reader X but when I go to add/remove they are not showing up in that section? Has anyone any suggestions or advice as to why this is happening? Thank you.
Remove entries in Programs and Features" without uninstalling programs
Is there a way to remove entries from "Programs and Features"? The screenshot shows many entries for MegaSceneryEarth, can I get rid of all these entries someway? I do not want to uninstall the program, I just do not want all this crap showing up under "Programs and Features".
Random Freezes and Hangs
Hey Whats going on : Recently I started experiencing random Freezes and Hangs. Even during logon My computer was working fine till yesterday night. In the morning I was in a hurry and Shut down the laptop. Windows asked me if I wanted to Force Close all programs which I did. Now it...
BSOD Help and Support
screen freezes and hangs
I have a HP laptop , IE 8 and my screen freezes and hangs just while Googling . I have tried alot of fixes and nothing works . any ideas ??? THANKS Roz
Browsers & Mail
Lockups, Freezes, Hangs
Hi, I ran RC7100 since it was released. When I upgraded from 7000 to 7100 I ran into what appeared to be an ACPI issue, but on closer inspection turned out to be resolved early on by disabling my Belkin WiFi card. A while later my LAN Nic blew out so I reenabled the belkin wireless and the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:40.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App