Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: COM Surrogate


26 Sep 2010   #1

Windows 7 Ultimate x64
 
 
COM Surrogate

After doing a disk cleanup and deleting "Thumbnails" without realizing it would cause this, I have started to get the message "COM Surrogate has stopped working" a lot of the times that I try to open images (and other people who receive this error report it to happen with videos/movies as well, but I currently don't have any to test that out). How can I go about fixing this problem? I tried doing a system restore, because I set a restore point last night, but I can't quite remember if I saved the restore before or after I did the disk cleanup. In any case, it didn't help. Would be nice to get rid of this problem, I'm not sure what COM Surrogate is or what it does, but maybe disabling it would solve my problems without creating new ones?

Any help is greatly appreciated (and rewarded with +rep of course )


My System SpecsSystem Spec
.

26 Sep 2010   #2
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

My System SpecsSystem Spec
26 Sep 2010   #3

Windows 7 Ultimate x64
 
 

so far the first one has not worked, and it would also be great if I COULD see thumbnails, they are very helpful when browsing pictures. What exactly got deleted when I deleted the "thumbnail" during disk cleanup, did it just delete the copies of each thumbnail I have, or did it delete a file that enables them or something? Cause I can see the thumbnails (until now cause of the method of fixing, which didn't help), so I don't see why I have this problem

edit: tried them both, reset computer, problem still occurs. This is very annoying, I guess I have to restore farther back, to before I deleted the thumbnails in disk cleanup. Can I go ahead and undo the things I did in your suggestions?
My System SpecsSystem Spec
.


26 Sep 2010   #4

Windows 7 Ultimate x64
 
 

Did not work, I don't have any restore points from before deleting "Thumbnails". I'm not pro, but maybe someone who knows a good amount about PC's could try creating a restore point for current time, and backing up the "Thumbnails", and then do the same thing that I did (disk cleanup, deleted thumbnails) and try and figure it out from there? Just a suggestion, again I don't actually know if that would help in any way, but I would really like to see this problem solved.
My System SpecsSystem Spec
26 Sep 2010   #5
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

In your Pictures folder set the 'view' to medium icons ... and let us know if you see them now
My System SpecsSystem Spec
26 Sep 2010   #6

Windows 7 Ultimate x64
 
 

not to seem rude, but that's not what my problem is. I can see the thumbnails perfectly fine.
edit: the problem is that 1 out of 3 times that I try to open a picture (I can see the thumbnail for them all), it displays the COM Surrogate has stopped working message
My System SpecsSystem Spec
28 Sep 2010   #7

Windows 7 Ultimate x64
 
 

anybody? it gets more and more on my nerves each time, may not seem like a big thing but the right side of my collarbone is broken, and im right handed, so it's difficult for me to move the mouse normally. sounds lame, but it's a real hassle :'(
My System SpecsSystem Spec
28 Sep 2010   #8

windows 7 professional & ultimate 64bit laptops
 
 

My System SpecsSystem Spec
29 Sep 2010   #9

Windows 7 Ultimate x64
 
 

i will try it, but I am using Windows 7 fyi, and also I have noticed that pictures don't work even if I just use the "details" view, I am 99% sure it has to do with the "disk cleanup" removing thumbnails though, it only started when I did that.
My System SpecsSystem Spec
29 Sep 2010   #10

Windows 7 Ultimate x64
 
 

this did not work. are there no guru's who know Windows SEVEN solutions to this problem? Possibly someone who actually helps make computers / program them?
edit: sorry for double post, maybe this will help:

Problem signature:
Problem Event Name: APPCRASH
Application Name: DllHost.exe
Application Version: 6.1.7600.16385
Application Timestamp: 4a5bc6b7
Fault Module Name: gdiplus.dll
Fault Module Version: 6.1.7600.16385
Fault Module Timestamp: 4a5bd976
Exception Code: c0000005
Exception Offset: 0004284b
OS Version: 6.1.7600.2.0.0.256.4
Locale ID: 4105
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
My System SpecsSystem Spec
Reply

 COM Surrogate




Thread Tools



Similar help and support threads for2: COM Surrogate
Thread Forum
Solved Is it Normal for COM Surrogate like this ? General Discussion
Com Surrogate keeps opening and closing General Discussion
COM SURROGATE issue General Discussion
(COM surrogate has stopped working) General Discussion
COM Surrogate BSOD Help and Support
COM Surrogate crashes BSOD Help and Support
COM Surrogate error Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33