Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Explorer.exe hangs with R6031 error

26 Sep 2010   #1

Windows 7 Home Premium
Explorer.exe hangs with R6031 error

I have an extremely frustrating problem everytime I log into Windows.

Startup is successful however as soon as I log in explorer starts it loads a few items in the task bar and then an error message pops up:

Microsoft Visual C++ Runtime Library
- Attempt to initialize the CRT more than once.
This indicates a bug in your application.

Then explorer hangs.

I can use Task Manager to start a new explorer.exe process however the same thing happens.

I've been troubleshooting this for a few days now and there are no errors in the windows event log. I only have one application set to start up on boot and that's AVG which starts successfully.

I've used Autoruns to check all stuff that's set to start up on boot and log on and there's nothing that appears to want to load apart from AVG.

I "think" I've checked all services that could offend and nothing seems unusual.

I'm really struggling with this especially as it also happens in safe mode.

Is there any way I can see what is loading to find the offending process?

My System SpecsSystem Spec
26 Sep 2010   #2
Microsoft MVP


If explorer.exe is hanging, try this to generate a memory dump of the hung process: Generating a memory dump for a hung process
My System SpecsSystem Spec
27 Sep 2010   #3

Windows 7 Home Premium

Thanks very much for the response, although I'm not sure that is possible for explorer.exe as it doesn't appear in the application tab.

however, I did follow the instructions here Troubleshooting Explorer.exe Crashing Issues

But unfortunately had no luck with any of the steps.

SFC found a couple of corrupt files but said it couldn't fix them.
A repair install couldn't be carried out because windows kept telling me it couldn't get disk information.
The registry fix to obtain c:\Localdump dumps when explorer.exe crashes didn't seem to dump anything.

So.. I went for a fresh install which has obviously fixed the issue but given me some extra work to set up all my apps again.
My System SpecsSystem Spec


 Explorer.exe hangs with R6031 error

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Explorer.exe hangs on Boot
Hi All, any help would be appreciated. I received a new PC build with Windows 7 home 64 bit, Intel i7 3820K 4 Core 3.6GHz, 16GB RAM. After setting up my PC with applications a day or 2 later Explorer.exe started to hang. Upon boot all seems ok but when you attempt to navigate into a...
General Discussion
Internet Explorer hangs
I have Windows 7 and with Internet Explorer 9 and it hangs (gets stuck) about a dozen times a day then after I do an ctrl-alt-del and close the page then restart it say restoring your last sesson. What can I do about this?
Browsers & Mail
Right click hangs Explorer.exe on Windows 7
I just upgraded to Windows 7 build 6801 from Vista Ultimate and pleased to says it works fine except for this nagging issue. Whenever i right click anything on my desktop, explorer.exe hangs ("stopped working") and it restarts explorer.exe again. Apparently, it is a common issue and I also had it...
General Discussion
Explorer.exe hangs on shutdown
One of the computers in the office where I work hangs when the user shuts down in the evening. The error dialog says there are two processes still running, and the title bar of the dialog says "explorer.exe error". The message in the dialog says something like "The instruction at "0xXXXXXXXX"...
General Discussion
Internet Explorer hangs for a minute or so
After setting up Windows 7 on a newly formatted HDD, I installed Norton IS 2010, and Office 2007. Somehow it seems that IE wants to hang for about 30-45 sec up to a minute for no apparent reason - no busy circle or anything. I cannot find a reason why. Any ideas? James
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:20.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App