Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Registry permission error in Windows 7 64 bits


21 Oct 2010   #1

Windows 7 Ultimate x64
 
 
Registry permission error in Windows 7 64 bits

I have some registry problems in my recently installed windows 7 64 bits.

When I try to add a 32 bits ODBC throw C:\Windows\SysWOW64\odbcad32.exe (and running as Administrator) and It throws me a "Cannot Write to registry" error.

If I enter into regedit as an administrator and if I go to any entry under the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI I get an Access Denied error. If I try to assign rights to that key, It says I don't have permission to change the permissins.

Thanks, Ariel


My System SpecsSystem Spec
.

06 Nov 2010   #2

Windows 7 Home Premium x64
 
 

I need help with this as well. When I go into RegEdit (as Admin), I get as far as Computer/HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft with Full Permission, when I get to anything inside there I lose permission, I had it a week or so ago, but now I don't have it anymore, is there anyway I can get it back.

and yes, I do know what I'm doing

EDIT: Only TrustedInstaller has full access rights.
My System SpecsSystem Spec
06 Nov 2010   #3

 

You have to run regedit as administrator and take ownership of some registry keys in order to access them and change the permissions. I had this problem in trying to completely remove windows defender. (should be called defenseless for all the good it does)
My System SpecsSystem Spec
.


06 Nov 2010   #4

Windows 7 Home Premium x64
 
 

How do I do that?
My System SpecsSystem Spec
06 Nov 2010   #5

 

Open permissions for the container of the key you can't access, click the advanced button, then select the owner tab, highlight your account name, check the "replace owner on subcontainers and objects" then click apply. Make sure you have full control of the container key. Then apply the permissions for the subkeys. There's a take ownership script somewhere in this forum, but I've found it doesn't always work... I'll post screenshots of how to do it if needed
My System SpecsSystem Spec
06 Nov 2010   #6

Windows 7 Home Premium x64
 
 

Thank you! Worked perfectly. I don't know if I can mark this topic as Solved or not since it's not mine, but it's Solved both our issues

There was a tutorial that you could get rid of the Splash Screen for Windows Live Mail, but it doesn't seem to work That's sad.
My System SpecsSystem Spec
Reply

 Registry permission error in Windows 7 64 bits




Thread Tools



Similar help and support threads for2: Registry permission error in Windows 7 64 bits
Thread Forum
16-bits program error message in 64-bits W7... Performance & Maintenance
Solved Windows Update error; cannot start BITS service Windows Updates & Activation
Solved registry cosole tool keeps asking for permission & maybe i got a virus System Security
Command line Registry Permission General Discussion
Windows 7 ultimate 32 bits keeps throwing an error message General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:13 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33