Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: athrxusb.sys causing bsod?

02 Dec 2010   #1

Windows 7 Ultimate x64 SP1
 
 
athrxusb.sys causing bsod?

Im running on windows 7 ultimate x64 with a new desktop that i built about a week ago. I get an average of 1-2 bsod each day after my first bsod and I think its my wireless usb adapter. Im using a really old router, a model AR420W airlink router. I tried searching for ar420w drivers and awll4030 drivers(the model of the usb) but I couldn't find any or they did not work for win 7. After many methods I got the wireless to work by updating through windows update. When I found out that athrxusb.sys was popping up in my bsods I thought that the driver was faulty. So uninstalled it and installed the item on the last post here VISTA - Wireless USB AR5523 Drivers? - [H]ard|Forum (AR5523 is what I see on device manager). Wireless work and I thought I fixed it until I got another blue screen and athrxusb.sys was mentioned again so now I'm pooped =/. Help would be most appreciated(sorry for barging in here and only asking for help >.<).

btw the router is not in the same room that my desktop is in so I'd have to move my desktop if I wanted to use a cable

My System SpecsSystem Spec
.

02 Dec 2010   #2

Windows 7 Ultimate x86 SP1
 
 

Hello,
Yes you right, your Atheros driver was causing the crash.
Better for you to update that driver → http://www.atheros.com/pt/index.html

Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck D1, {59, 2, 0, fffff88003cfd181}

Unable to load image \SystemRoot\system32\DRIVERS\athrxusb.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for athrxusb.sys
*** ERROR: Module load completed but symbols could not be loaded for athrxusb.sys
Probably caused by : athrxusb.sys ( athrxusb+9b181 )

Followup: MachineOwner
---------
My System SpecsSystem Spec
02 Dec 2010   #3

Windows 7 Ultimate x64 SP1
 
 

Thanks soooo much for the help! So I am able to update it? Glad to hear that but sadly I cannot find any drivers and the site you linked me didn't have any drivers for me to download.

oh and im gonna assume its the AR5523 that I should be looking for?

Maybe I should head over to the drivers section since the problem now is finding the correct driver. But if I continue getting help here, two topics would be one too many.
My System SpecsSystem Spec
.


02 Dec 2010   #4

Windows 7 Ultimate x86 SP1
 
 

Hi,
It seems your awll4030 USB wireless adapter is not support with windows 7. It has been discontinued.
Adapters &ndash; AWLL4030

Then the driver that you use right now is from different chipset so it would never work.
AR5005UG → chipset AR5523
awll4030 → chipset Atheros™

Maybe it's time to buy new device that full support with windows 7.
My System SpecsSystem Spec
03 Dec 2010   #5

Windows 7 Ultimate x64 SP1
 
 

Aw man. I had a feeling it was gonna be like this, dang. But anyways, thanks for clearing things up!!
My System SpecsSystem Spec
Reply

 athrxusb.sys causing bsod?





Thread Tools



Similar help and support threads for2: athrxusb.sys causing bsod?
Thread Forum
Is My new Ram Causing BSOD BSOD Help and Support
BSOD - Not sure what's causing it. BSOD Help and Support
BSOD Help. Don't what what is causing it. BSOD Help and Support
BSOD athrxusb+760e1 Network & Sharing
athrxusb.sys causing BSODs need help Network & Sharing
Hi, what is causing this BSOD ? BSOD Help and Support
BSOD: Stop error 7E and mentioned athrxusb.sys BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:02 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33