Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Disk read error", cannot boot Win7 partition

18 Jan 2011   #1
wongnog

Windows 7 x64 RTM
 
 
"Disk read error", cannot boot Win7 partition

So something happened to my Windows 7 partition this morning, I got a random BSOD while working and now Windows won't post. Instead I'm greeting with this:
Quote:
A disk read error occurred
Press Ctrl+Alt+Del to restart
If I boot from my Windows 7 DVD and attempt a startup repair, it does not recognize any windows installation so it doesn't really do anything when I attempt the startup repair. All it says is:
Quote:
Root cause found: System volume on disk is corrupt.
Repair action: File system repair (chkdsk)
Result: Completed successfully. Error code = 0x0
When I go to command prompt, I cannot access my C:\ partition at all. I can however access my D:\ partition from the same hard drive which has all my data.

I've tried some bootrec commands, but it didn't seem to fix it. I've used Diskpart to make the C:\ partition active. Diskpart can still see the C:\ partition, but I can't seem to get access to the partition.

Worst case scenario, I could format the C:\ partition and make a clean install. I may have to because previously my windows install wasn't running so well. However I'd really like to be able to access the C:\ partition first to backup my settings and programs. Really hoping someone here could offer some helpful suggestions. Thanks very much!


My System SpecsSystem Spec
.

18 Jan 2011   #2
wongnog

Windows 7 x64 RTM
 
 

Here's some more info. When I go to command prompt from the Windows DVD and run the command bootsect.exe /nt60 all /force, for the C:\ drive it says:
Quote:
Could not open the volume root directory:
The parameter is incorrect
When I try to access the C:\ drive from the command prompt, it says "The disk structure is corrupted and unreadable"
My System SpecsSystem Spec
19 Jan 2011   #3
wongnog

Windows 7 x64 RTM
 
 

Starting to get worried my thread is being lost among the other posts, so here's some more info. I loaded Ultimate Boot CD and ran the SeaTools for my Seagate hard drive (that's the one with the Windows partition that is no longer being recognized), but SeaTools reports it could not find any drives! DiskPart can see the hard drive and all the partitions, but it can't access the C: partition. It says there are some NTFS errors and to run a Chkdsk /f on the partition, but I can't because the system says C:\ is unreadable. Just finished a full surface scan using ViVARD and found no errors.

Really hope someone can help here!
My System SpecsSystem Spec
.


19 Jan 2011   #4
wongnog

Windows 7 x64 RTM
 
 

Okay I ran chkdsk c: /f and got this:
Quote:
Corrupt master file table. Windows will attempt to recover
master file table from disk.
Windows cannot recover master file table. CHKDSK aborted.
Failed to transfer logged messages to the event log with status 50.
My System SpecsSystem Spec
19 Jan 2011   #5
wongnog

Windows 7 x64 RTM
 
 

Darn I was hoping to avoid that, so there's no way to get the data off that partition before formatting, eh?
My System SpecsSystem Spec
25 Jan 2011   #6
theherkman

Windows 7 Home Premium 64bit
 
 

Use Steve Gibson's SpinRite. That should do the trick.
My System SpecsSystem Spec
Reply

 "Disk read error", cannot boot Win7 partition




Thread Tools





Similar help and support threads
Thread Forum
"A disk read error occurred" and Safe Mode Issues
So yesterday, my computer was in sleep mode, working fine. I was vacuuming my room and I blew a circuit, no biggie, happens all the time, so I turn off the vacuum and lights, went down to the fuse box, and flipped the switch back. I haven't tried to use my computer until I finished vacuuming. Once...
General Discussion
Win7 bootable USB "A Disk Read Error Ocurred"
Hello, registered to get some help with setting up a desktop PC, seven forums seems like good place to start ;] I've made a bootable USB Win7 x86 installation stick using Rufus, following the instructions to the letter and the PC gave me "A disk read error occured" on boot. I formatted it in...
Installation & Setup
Hard Disk can't read in "my computer ", "initialized",I/O device error
I have a big problem here, I have used my hard disk for 9month, Yesterday when I watched movie on the half way, My hard disk suddenly disfuntion, And I thought my laptop problem due to always lagging so I restart my computer. But after that I can't read my hard disk (WD)in my computer. It can...
Hardware & Devices
"Disk read error" during boot when pc has been turned off for a while
Hi all, I just bought a new HDD since my 500gb drive wasn't big enough. I bought a 1.5TB drive and I wanted to use both drives. First I tried to transfer my Windows install to the new drive, I started getting some errors while booting up after a few hours. First Windows froze during the boot...
Hardware & Devices
Made bootable USB but getting "Disk read error" at boot time, why?
Would greatly appreciate some help trying to create a bootable system on my 16GB USB stick. Here's what I did: In Diskpart: clean to wipe the USB stick clean create partition primary offset=32 align=32 to create a fresh partition starting at sector 64 (rather than 63) active to make it...
Installation & Setup
"Cannot read from disk" at boot problems
Occassionally I get "Cannot read from disk, pres CTRL + ALT + DEL to reboot" error when I turn on my PC. Fiddling about with the cable seems to solve the problem temporarily. Do you think I need to buy a new cable or a new disk?
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App