Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD - possible issue with SATA 3 control??

28 Jan 2011   #1

Windows 7 Professional 64 bits
BSOD - possible issue with SATA 3 control??


I have put together a brand new tower:

video: GIGABYTE GTX580
cpu: INTEL CORE I7-960
Windows 7 pro 64 bits.

It worked for about two weeks before I started noticing strange stuff happening; second HDD dissappearing from My computer list during a copy (writing on that drive).
Then, BSODs when surfing on internet (during caching I think mostly, or flash video).
Access to hard drives suddenly very slow at times (even entering folders can result in "Not responding", and temporary freezes, bsod's, extremely slow cache swapping in internet browser, "windows explorer" crashing and restarting every minute or so, HDD not recognized at boot, computer not being able to boot, BSOD during boot, safe mode not starting, safe mode freezing, etc...).

I want to format the whole thing and start over again; I notice SATA3 in my BIOS is on IDE instead of the better (as I've read) AHCI. I read about the issues concerning switching from one to the other when an OS is already installed, so I decide to to a clean re-install of windows7 (format) with disks set on AHCI (SATA2 still on IDE for my optical drive, AHCI made even the windows7 install crash!!!).

So I re-install, let windows do the countless updates it needs to, I even restart a couple of time just to make sure, and then I start moving archives in on my internal drives (45 GB of files); the drive starts well - slows down - hangs - not able to click anything - cursor freeze - bsod. (sob!)

I did quite some installs from DVDs and from files downloaded from the internet. no problems there, it's when files are copied around that it has problems now. for now.

So from all the problems it could have been, I'm wondering if the harddrives are being controlled properly... It's not software since I've taken great care into installing one thing at a time and rebooting between installs, starting with windows updates, then drivers, then some apps (google chrome, trend micro Titanium maximum security).

I've installed the motherboard chipset and sata3 drivers, have an anti-virus and not much else is running when it hangs. I'm just preparing for it to worsen again.


I've included the perfmon report of my current install, as well as the mini-dump(s) of the last crash(es). (all in one zip.)

Here's the last log, just bluescreen this one, not bsod;

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7600.
Locale ID: 1033

Additional information about the problem:
BCCode: f4
BCP1: 0000000000000003
BCP4: FFFFF80002F815D0
OS Version: 6_1_7600
Service Pack: 0_0
Product: 256_1


My System SpecsSystem Spec
28 Jan 2011   #2

Windows 7 Professional 64 bits

Also, I get a lousy 5.9 in primary hard drive performance for Windows Experience Index (( I don't get what I've done wrong.
My System SpecsSystem Spec
30 Jan 2011   #3

Windows 7 Professional x64


Run hard drive diagnostics with SeaTools: | Seagate

Run both the Small FFTs and Large FFTs tests.

If SeaTools gives a clean report, run driver verifer: Driver Verifier - Enable and Disable

...Summary of the dumps:

Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Debug session time: Fri Jan 28 20:57:36.249 2011 (UTC - 5:00)
System Uptime: 0 days 0:21:40.342
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
SystemProductName = To Be Filled By O.E.M.
My System SpecsSystem Spec

31 Jan 2011   #4

Windows 7 Professional 64 bits
Blue Screen of Fatal Hard Drives.... cont'd

Hey JK,

thanks for the reply, I'm running the tests now (with Small and Large FFT do you mean Short and Long Generic? is that the same? )

Also in the dump I was wondering about that line "Built by: 7600.16617.amd64fre.win7_gdr.100618-1621"

any reason AMD is mentioned here? because I'm on an Intel i7...

Also, external USB drives connected while booting can give me a BSOD right after starting (checked BIOS, and booting from USB is last in drive order).

Does this help figuring out what it is?
My System SpecsSystem Spec
31 Jan 2011   #5

Windows 7 Professional x64

Ah, sorry about that. The Small and Large FFTs tests are Prime95 tests; I got my wires crossed for some reason.

The correct SeaTools tests are Short and Long DST tests; the generic ones will lose data.

The Intel i7 uses the AMD64 technology; that's the technology AMD developed in 1999, and first implemented in the original Athlon 64s in 2003. The Athlon 64 was able to run both x64 and x86, meaning it was compatible with the programs and operating systems that came before it. By contrast, the Intel 64-bit technology at the time was exclusively 64-bit; all new software had to be written for it, which put it out of the class of your average user.

Enough history for now; for all it's worth in BSOD analysis, it means that you have a 64-bit OS, instead of 32-bit.
My System SpecsSystem Spec
31 Jan 2011   #6

Windows 7 Professional 64 bits

thanks again for the insight

hmm, can't seem to perform either short nor long DST. "Test Unavailable"...

In drive category, my two internal drives are listed as "SCSI-FC-SAS" and not as SATA3 . (?)

I know Windows 7 can confuse a SATA3 for a SCSI drive, but is that still not fixed?
My hard drives are listed this way even among the other hard drives in the "Safely Remove Hardware and eject Media". Is it even normal for the drives to be listed there? (i'm new to windows 7)..Or is it because of AHCI hot plugging capabilities?

still, I can't do the two tests... Should I go straight to driver verifier?
My System SpecsSystem Spec
31 Jan 2011   #7

Windows 7 Professional x64

I honestly cannot give any insight into that error; all I can suggest is a workaround, by using a different program.

Try using Western Digital's DataLifeguard instead.

WD Support / Downloads / SATA & SAS / WD Caviar Black

Enable Driver Verifier whenever you're ready to; you don't have to wait for the hard drive test to be done.
My System SpecsSystem Spec
02 Feb 2011   #8

Windows 7 Professional 64 bits

Hey JK,

the drives show no errors in any of the tests, but they are listed as being IDE, when in the Bios they're set to AHCI and are recognised this way by the Bios.

This makes me think about how it's the only place it's listed as AHCI.
Windows lists them as SCSI disk devices (device manager), and there's no sign of the Marvell SATA3 controllers...

Here's my problem again if it helps:

I have 2x internal 2TB Barracuda XT drives, which randomly slow down, go to a halt, then are invisible to windows explorer, if it's not my boot drive crashing. It mostly ends with bsods.
It happens on its own, mostly during heavy file read or write. It almost always happens copying files from an external USB drive to one of the internal drives. Bsod assured.
But it crashes even without external drives attached, only less often (but I lose data when I'm saving work and it crashes).
One of the drives is my boot drive, and both have been set to AHCI in the BIOS before windows 7 installation (crashed already in previous installment of windows, when set to IDE).

Windows7 recognises them as being SCSI drives (?), and file transfer between the two internal drives never exceed 30Mb/s (copying files on one to the other). I get a Windows Experience quote of 5.9 for the primary hard drive, which seems low considering how fast it should be.

Can you help?
My System SpecsSystem Spec
03 Feb 2011   #9

Windows 7 Professional 64 bits
New Dump files

Hadn't done the long test yet on the drives, but stopped midway through one (of two drives), which had been busy for 7+ hours... (

I've included new dump and perfmon files to check in on, maybe the new files would help?

While having verifier on, it BSOD'd at startup because of various drivers (cbludf.sys, ... just such third party drivers that aren't signed), but with verification only on the Marvell drivers, it handles pretty well (usually).

I still get random BSODs during heavy disk access...
My System SpecsSystem Spec
03 Feb 2011   #10

Windows 7 Professional 64 bits

Just plugged the two drives in SATA2 (IDE), have copied over a couple of gigs around at speeds much higher!!!!

NO BSOD so far.

What gives? it's 2011 guddammit!
My System SpecsSystem Spec

 BSOD - possible issue with SATA 3 control??

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Changing Sata port for the Win-7 HDD glitchy issue
Good afternoon, I recently needed to reinstall Win -7 Pro x64. I unplugged all my other drives (5 all total) and installed Win-7 with the new HDD connected to the SATA0 port of my MB. Then post install, I moved the HDD with Win-7 on it to the SATA4 port and then plugged in my other client...
Installation & Setup
Issue with SATA HDD.
Hi. From time to time I cannot start up my computer due to HDD issue. It's a SATA drive. I can switch it to another SATA channel. but after a while the same issue persist. What can be the reason ?
Hardware & Devices
GPU Control Center issue (ATI Catalyst Control Center ) NEED HELP!!!!
Decided to update my GPU driver ATI mobility radeon 550v ( version 8.692 ) and the ATI CCC 10.1 to the latest 11.2 and the GPU driver. GPU driver can be installed and uninstalled with no prob... the prob was with the ATI CCC 10.1 . Did not uninstall this and went str8 to the new installation...
Graphic Cards
Pci Sata Control Card
Have an issue with my Syba SD-VIA-1A2S sata controller card that occassionally cause bsod. Updating the driver reduced the frequency but did not eliminate the issue. I would like to replace the card but after extensive research, I have not found a pci sata controller card that I feel confident that...
Hardware & Devices
a new twist to the win7/ sata hdd issue
Ok I’ll start at the beginning, I put together a pc and having issue’s with win7 64bit setup seeing my sata2 hdd it’s a western digital caviler blue 500 gig drive and gigabyte mb in the bios I tried sata in native ide also ahci those letters might be mixed up under ahci there is an option for...
Installation & Setup
sata issue
I have a secondary sata in my computer however i cant get any of my data from there as it is very important. if i start in normal mode and when i get to the insert password the screen goes all haywire, then if i restart it in safe mode and go to the computer management it says that my drive is...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

ฉ Designer Media Ltd

All times are GMT -5. The time now is 22:58.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App