Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: EIO Driver Cannot Be Loaded!

13 Mar 2011   #1
IMAyNeed

Windows 7 Ultimate 64-bit
 
 
EIO Driver Cannot Be Loaded!

Usually happening when I am syncing the external drives.










My System SpecsSystem Spec
.

13 Mar 2011   #2
usasma
Microsoft MVP

 
 

Uninstall Asus SmartDoctor/TurboGear Enhanced driver
Test for further problems.
If necessary, go to the Asus support website and download the latest version of this utility for your system/mobo
It's listed under the VGA section and is named the TurboGear Enhanced Driver here: ASUSTeK Computer Inc.-Support- download_item_mkt
My System SpecsSystem Spec
14 Mar 2011   #3
IMAyNeed

Windows 7 Ultimate 64-bit
 
 

I already updated the driver from there. The problem is still going on.
I will try to uninstall TurboGear though.
I hope it is the same program.
(TurboGear Extreme is installed on my computer used for overclock).

I don't know if they are related, the program on my computer is :



I can delete that program. No problem.

I already updated the TurboGear Enhanced Driver before, from your link.
If there is anyway to uninstall TurboGear Enhanced Driver, tell me (other than deleting TurboGear Extreme I mean).

Thanks.
My System SpecsSystem Spec
.


16 Mar 2011   #4
usasma
Microsoft MVP

 
 

First, set a system restore point.
Then delete the Asus stuff from Control Panel...Programs...Uninstall a program
Delete anything that you don't need - that'll make troubleshooting further dumps much easier.

Also, go to C:\Windows\System32\drivers and rename EIO.sys to EIO.BAK
Reboot to see if the changes remain.
My System SpecsSystem Spec
17 Mar 2011   #5
IMAyNeed

Windows 7 Ultimate 64-bit
 
 

Before your post, on Device Manager, there were 2 EIOs, I deleted where there was a yellow mark, the troubled one.

Thanks, and I will inform the results after your instructions.
My System SpecsSystem Spec
23 Mar 2011   #6
IMAyNeed

Windows 7 Ultimate 64-bit
 
 

I uninstalled ASUS TurboGear Program.
I uninstalled EIO driver from Device Manager.
I change the BIOS setting to enable TurboGear Overclocking to disabled.
Let's see what happens.

Update: Nope. This time blue screen. A crucial something to the operating system has been terminated. I changed the BIOS setting to enable again. Does NVIDIA use the EIO driver? I remember updating NVIDIA around this thing started to happen.
My System SpecsSystem Spec
23 Mar 2011   #7
usasma
Microsoft MVP

 
 

Did you check in C:\Windows\System32\drivers and rename EIO.sys to EIO.BAK?
Please upload this info to help us in analyzing the BSOD(s): http://www.sevenforums.com/crashes-d...tructions.html
My System SpecsSystem Spec
24 Mar 2011   #8
IMAyNeed

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by usasma View Post
Did you check in C:\Windows\System32\drivers and rename EIO.sys to EIO.BAK?
Please upload this info to help us in analyzing the BSOD(s): http://www.sevenforums.com/crashes-d...tructions.html
I have EIO64.sys. Will that do?
And I have also EIO64_xp.sys. Should I delete the EIO64_xp.sys or should I name it to bak also?
I have also a file named as MsftWdf_Kernel_01009_Inbox_Critical.Wdf. I don't know if it is related though.

I can't post BSOD because the dumping failes with 0x0...0c always so there is no dump files (even with no restart and mini dump selected).
My System SpecsSystem Spec
24 Mar 2011   #9
usasma
Microsoft MVP

 
 

Rename EIO64.sys to EIO64.BAK
Rename EIO64_xp.sys to EIO64_xp.BAK also

I'm not just looking for the memory dump files - those reports contain a lot of other information that may be useful in diagnosing these problems.
My System SpecsSystem Spec
25 Mar 2011   #10
IMAyNeed

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by usasma View Post
Rename EIO64.sys to EIO64.BAK
Rename EIO64_xp.sys to EIO64_xp.BAK also

I'm not just looking for the memory dump files - those reports contain a lot of other information that may be useful in diagnosing these problems.
ok, I will change the names and when the BS happens again, I will try to post.
My System SpecsSystem Spec
Reply

 EIO Driver Cannot Be Loaded!




Thread Tools





Similar help and support threads
Thread Forum
mscorwks.dll could not be loaded
Hello, I am new to this forum. I have a Dell laptop with windows 7 OS 64-bit. The problem is that for the last 2 days i have found it impossible to install anything on it as an error keeps popping up saying MSCORWKS.DLL COULD NOT BE LOADED. I have a lot of important files on my system and i don't...
General Discussion
Driver not loaded - BluRay driver BC5600-S
Hi, Recently, not sure exactly when but my Blu-Ray drive meant missing from Windows. At the same a drive letter for a software based drive went missing too. There is no hardware for this second drive. The driver allows me to mount ISO images easily in Explorer. I spotted in the hardware...
Drivers
Can I use the software loaded in a HD from another HD with Win 7?
I would like to open and work with software programs loaded in any of the 6 HDDs I have connected to my Desktop computer, They are internal and external connected via an external enclosure. Is this possible in some way? or do I need to install every software program on every hard drive do do...
Software
No Driver Files Are Loaded For This Device...
Hey there - Just a quick question regarding Device Manager. I was updating some drivers and was checking through System Devices and noticed that when I checked the properties on some of the devices ( Intel ICH9 Family SMBus Controller 2930 for example ) it says that there are no driver...
Drivers
RAS DLL couldn't be loaded
I'm running Win 7 Pro 64 bit, FF is primary browser. I have a Verizon FIOS network. I've been getting the following message when I boot up: "The RAS DLL couldn't be loaded. If you don't have a modem installed this is a normal situation. If you use a modem, check that the RASAPI32.DLL is properly...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App