Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: app hang b1 error


19 Mar 2011   #1

Windows 7 Professional x64 SP1
 
 
app hang b1 error

Hi, sorry for my poor english, but i will try to explain my problem.

When i use some program such as Internet Explorer, Firefox or OpenOffice and i browse trough folders to save a file, the system frozen and i receive the error message apphangb1. I have noticed that the problem appear only with 32-bit program and not with 64-bit (i use Windows 7 Professional x64 with SP1).

I've tried to start in Safe Mode and the probleam disappear. Then i've tried to start normal windows in clean mode (so without autostart program and without third-part services, only microsoft services) and the problem reappers.

How can i solve this problem? This is the memory dump of IE8 at the moment of crash:

http://***************/files/453302307/iexplore.rar

Thanks

My System SpecsSystem Spec
.

20 Mar 2011   #2

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Hi! fanfa, welcome to 7F

What program(s) do you use for malware protection? When was the last time you ran any malware scans?

After you make sure your machine is clean, see:
Troubleshooting Internet Explorer Issues
If you have multiple user accounts check each one.
My System SpecsSystem Spec
20 Mar 2011   #3

Windows 7 Professional x64 SP1
 
 

Quote   Quote: Originally Posted by Anak View Post
Hi! fanfa, welcome to 7F

What program(s) do you use for malware protection? When was the last time you ran any malware scans?

After you make sure your machine is clean, see:
Troubleshooting Internet Explorer Issues
If you have multiple user accounts check each one.
I've done a scan with Spybot Search&Destroy and with CCleaner, and both have not found anything. However the problem is not only with IE, but also with other 32-bit program.
My System SpecsSystem Spec
.


20 Mar 2011   #4

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Did you try to work through the troubleshooter I linked to?

Your multiple apphangb1 errors can usually be attributed to everything Capt. Jack wrote about, incompatible drivers and third party add-ons, especially add-ons. Follow the tutorial.

Help for Firefox:
Firefox 3.6.13 Randomly Hangs, Crashes: AppHangB1 • mozillaZine Forums
Notice the part in dfoulkes post about making sure your system is up to date! Use Secunia PSI.

Do you usually have the browsers open when you have other non-internet programs running, like OOo?
If you have a problem while one of these browsers are open then I would say the problem starts with one, the other or both browsers, and it is affecting the rest of your system.

If it continues then the problem lies in the particular program that the apphangb1 error points to.

The OOo error could be from a corrupted download or profile.

Troubleshooting one apphangb1 error is tedious by itself, multiples can become a nightmare.

Try to determine specifically when and what you are doing when the error occurs, and start with that program.
My System SpecsSystem Spec
21 Mar 2011   #5

Windows 7 Professional x64 SP1
 
 

The problem appear also with only one open program.

For example, if i open OpenOffice and try to save a new file (also with only one character), when i browse thorugh folders to choice the destination it crashes.
My System SpecsSystem Spec
21 Mar 2011   #6

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

What version of Java do you have installed? the latest is (Version 6 Update 24).
If you do not know go here: Verify Java Version If it tells you, you need to update allow it to do it.

Btw...I would like to know more about your machine that you are having trouble with.
Please take the time to fill out your system specs, the how-to is listed in the information box where you create your post.
My System SpecsSystem Spec
21 Mar 2011   #7

Windows 7 Professional x64 SP1
 
 

i have the last version of Java 6u24.
I have also compiled my system spec.
My System SpecsSystem Spec
21 Mar 2011   #8

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Thank you for filling out your system specs!

I do not see a manufacturer, I surmise that you have built this machine, correct, incorrect?

Have you been running the Corsair 2X1GB and Kingston - HyperX 2X1GB ram together since the machine has been built or have you installed one set or the other at a later date?

If you added one kit at a later date, was it shortly after you made the addition that you started having these apphangb1 errors?

Pull the corsair and re-boot make note if you have any errors or if they get worse. Re-install the corsair then,
Pull the Kingston and re-boot make note if you have any errors or if they get worse.

If the errors clear, then it is a compatibility problem with your memory.

If no change or worse, then I need you to run memtest86, see: RAM - Test with Memtest86+

And, I can not get into rapidshare to read your file. Please follow the instructions here, and attach the resulting file to your next post.
My System SpecsSystem Spec
22 Mar 2011   #9

Windows 7 Professional x64 SP1
 
 

Yes, i have built this machine.

First i have only corsair kit, then i add the kingston. However i have added this at beginning of december and the problem starts 2/3 weeks ago, this are their characteristics:

Corsair Kit 2048MB (2X1GB) 800MHz Twinx2 CL4 Pc6400
Kingston - HyperX RAM DDR2 PC800 2GB KIT CL4

I have tried to remove RAM alternately but the problem still persist.
Now i'm running the memtest, this afternoon i will check also the dump file.


Thanks
My System SpecsSystem Spec
22 Mar 2011   #10

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Can you recall any changes to your machine at that point two to three weeks ago?

Any programs added?
Any upgrades to programs?
Any windows updates?
Any add-ons to programs?
Did you run any registry cleaners?
Did you run Ccleaner at that time, go back and check the log dates.

Continue to set-up to run this: http://www.sevenforums.com/crashes-d...tructions.html It is the same as the here link I gave you earlier.
My System SpecsSystem Spec
Reply

 app hang b1 error




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33