Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Copying files to USB Portable Hard Drive stalls system

03 May 2011   #1

Windows 8 Pro x64
Copying files to USB Portable Hard Drive stalls system

Hi guys,

Today a friend of mine came to get some files from my computer and we ran into a bit of a problem.

We were copying some huge files using windows explorer, some were around 10GB in size. Total size of about 90GB. Check system specs please. We were copying from the RAID spindle drives to the USB. Write caching enabled from Intel Rapid Storage driver ver.

While the copying was going on, the system was getting pauses. Getting unresponsive. I got a Skype call, and the video froze while I could hear the audio. We stopped the copying, and then PC was back to normal. Then we resumed copying and while it was taking a long time, we tried to play Crysis 2. And it was getting pauses of like 5 seconds after every 30 seconds or so. The game is installed on the SSD array. There was no direct intervention between the copying and the game, as far as the drives were concerned.

While the copying was going on, we noticed another thing. The activity LED would not light up continuously. It would light up for about 5 seconds, and then turn off. But the USB drive was busy.

I checked with my portable drive and it was also same.

Then we tried copying from the backup drive as I had the same stuff there too, and again it was the same result.

I googled for this problem, but could not find out a solid answer. Some were saying that the problem was with Windows 7, some were saying it was the Intel AHCI driver, some were saying it is a problem with explorer.

Then I tried Teracopy, same RAID-0 spindle drive array, and it worked perfectly. Not stalls, I could play Crysis 2 with no pauses, and the hard drive activity LED was always blinking as if something is going on. the problem is with Explorer?

One more thing. I am using that option "Show folder windows in a separate process." just for improved stability. I will see if it does something, but I doubt it.

Is anyone else having this problem?

My friend is a Mac guy and I was making fun of him for using a Mac and that he cannot do most of the things we can do in Windows, and now after this, I'm gonna have to keep my mouth shut for a while. I need to find a solution. >_>

My System SpecsSystem Spec

03 May 2011   #2

Windows 8.1 x64

Teracopy (and technically robocopy or xcopy) would not use the same exact API call tree to copy a file from one drive to another, so I'd bet if you used xcopy or robocopy they'd work properly. If that is the case, it would sound like either a filesystem filter driver issue, or perhaps an explorer shell extension (perhaps antivirus?) that would be something to look at.

A procmon running while the file copy was going (slowly especially) might yeild clues too. You could always use the keyboard to crash the machine and generate a kernel dump to be completely sure (you'd have to change the default dump type in sysdm.cpl from minidump to kernel, though, before doing so, and reboot).
My System SpecsSystem Spec
03 May 2011   #3

Windows 8 Pro x64

I'm using MSE and the CPU usage doesn't exceed 10%.

I didn't get that part about the kernel dump.
My System SpecsSystem Spec


 Copying files to USB Portable Hard Drive stalls system

Thread Tools

Similar help and support threads
Thread Forum
Painfully Slow Speed When Copying Files Onto an External Hard Drive
I decided to do a backup of my data, because I will be formatting my laptop. I'm using a WD elements 1TB hard drive (usb-powered). While it does support USB 3.0, my laptop doesn't. It is half full, still has about 400GB of free space. My problem is, when I'm copying any files onto it, the speed...
General Discussion
BSOD after copying files from one hard drive to another
Hello. I hope you can help as this problem is very frustrating. Just built a new PC: - Gigabyte Z97X Gaming 7 mobo - 8 gig Corsair Vengance 1866 mhz - EVGA GTX 770 video - Intel 4770K CPU - two 1 Tb WD black hard drives as RAID 1 - one ADATA 256 Gb SSD as OS drive - one 1 Tb Toshiba drive -...
BSOD Help and Support
Copying files to a usb hard drive
I try to copy files to a usb harddrive but windows just stays there copying forever. I tried the usb hardrive on another computer and it works fine. I am using Windows 7 ultimate x64.:(
General Discussion
Portable hard drive shows hidden files (prefixed with ".")
My portable hard drive is showing all the hidden files and folders on it (the ones prefixed with ".", but not the System Information folder, interestingly). I don't have this trouble with any other drives, or elsewhere on my computer, so it seems somehow to be associated with this specific drive. ...
Hardware & Devices
"0x80070057" Error copying files from hard drive to hard drive??
"0x80070057" error. I was simply trying to copy a folder or group of files to another hard drive. Hard drive to Hard drive, no SSD or External was involved. Any solutions to this issue? It literally refuses the copying to be performed ... I'm trying to copy folders/files from a Seagate...
Hardware & Devices
Copying rar files to a usb hard drive
All, Got a strange problem. I've have .rar files on the c: drive all around 90+mb each. On c: the rar files are error free (no crc errors when testing them). When copying to a usb hard drive after copying (with no errors during the copying process) the rar files fail with a CRC error. I've...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:10.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App