Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Black screen + cursor instead of login screen

12 May 2011   #1

Windows 7 Professional 64-bit
 
 
Black screen + cursor instead of login screen

I've got a problem with my Win 7 install. I recently bought a copy of Win 7 Pro & installed the 64-bit version (as I intend to get more ram at some point fairly soon). I installed it last weekend & for a few days it's been running fine. Then ~2 days ago when I start it up instead of a login screen all I have is a black screen with a cursor, if I wait until the screensaver kicks in & then move the mouse (or press a key, etc) then I can see the login screen (& log in with no problems), if I wait until the HD activity finishes & then type in my password I can login fine. Safe mode starts fine & if I log in to normal mode then everything runs fine & I don't get any other black screens.

At no point am I getting any errors.
I've run my usual AV (Avira free version) & MalwareBytes Antimalware & neither of them have come up with any issues.
Windows seems to be booting up fine until it gets to the login screen (after the swirly windows screen) & it's obviously doing something as there's a normal amount of HD activity.
I've tried the Startup repair on the install disk to no avail.
I've tried post #8 from this thread, but things went a bit pear-shaped around the "taking ownership" bit, though I've not had any errors afterwards.
I've tried enabling the OEM default background registry edit (since it seemed straight forward enough) to no avail.
I've even tried changing the background colours via the registry switch (Hkey users\default\control panel\colours\Background) from 0 0 0 (black) to 255 255 255 (white).

The login screen is still there, since I can enter my password & get into windows, it's just black on black on black, which is somewhat annoying.

So I'm stumped, since the vast majority of what google returns for combinations of "win 7 login screen black" are issues where Windows goes black after loging in, which isn't my problem.

I've also uploaded my ntbtlog, though nothing really jumped out to my non-professional (I'm an accountant & probably know just enough to really screw up windows ) eyes.

Any ideas? Or am I going to have to re-install windows a mere ~7 days after installing it for the first time (though at least I do have everything I'd need to install afterwards saved)?

And finally (& probably unrelated), I seem to have mislaid the Search button/thing on the start menu...

Any help with the blakc login screen would be much appreciated.


My System SpecsSystem Spec
.

12 May 2011   #2

Windows 7 Professional 64-bit
 
 

Avira, no idea why it's showing as AVG, I've not had that installed in several years (& several re-installs including a reformat)...

Edit: Though googling avgntflt.sys says that it's part of Avira.
My System SpecsSystem Spec
12 May 2011   #3

Win 8 Release candidate 8400
 
 

Sorry was just pulling my post when you replied. It is there in the folder but DID NOT load. Still a minor problem.

Other thought is to try a video driver re-install. sometimes a slightly different driver can cause something like this and it is easy to un-install/re-install it.
My System SpecsSystem Spec
.


12 May 2011   #4

Windows 7 Professional 64-bit
 
 

Re-installing the (same) graphics drivers fixed it, thanks for solution & sorry for bothering you with such a trivial problem.
My System SpecsSystem Spec
12 May 2011   #5

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Llama8 View Post
Re-installing the (same) graphics drivers fixed it, thanks for solution & sorry for bothering you with such a trivial problem.
Dont worry about it, you get fixed and we add to our knowledge. A win-win for us both.


Let us know if you need help


Ken
My System SpecsSystem Spec
13 May 2011   #6

Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
Dont worry about it, you get fixed
Apparently not...

I turned my PC on this morning to run the AV while I have breakfast/etc & all was well. The AV turned my PC off after it was finished as per usual & when I booted my machine up to check my mail the login screen was black again...

Windows hadn't installed any updates overnight & the only thing that had happened was the AV being run (which didn't come up with any issues). About the only thing I can think of is that the AV is somehow borking the gfx drivers...

Edit: I wonder whether it's possible to exclude the gfx drivers from the AV's scan, but I'm not sure which files/folders to exclude without excluding too much (ie, the entire windows folder).
My System SpecsSystem Spec
14 May 2011   #7

Windows 7 Professional 64-bit
 
 

I tried excluding Windows from my AV but I'm still getting the black login screen...

I'll try the latest drivers for my gfx card, as I notice that there's some new ones.
My System SpecsSystem Spec
14 May 2011   #8

windows 7 ultimate
 
 

Definitely sounds graphics related to me, but from searching the web it usually appears to be nVidia related.

There were some problems with the ATI/AMD v11.4 drivers I believe. The latest version is 11.5a which suggests that there may have been issues with the v11.5 as well.

If at the black screen with mouse cursor, does pressing Ctrl+Alt+Del bring up the Task Manager options screen? If it does, does pressing Cancel let you see the correct LogIn or Desktop?
My System SpecsSystem Spec
14 May 2011   #9

Windows 7 Professional 64-bit
 
 

Yeah, I was using 11.4 & I've just installed 11.5. Interestingly, when installing 11.4 at the end of the install I'd get a black screen along with an error about the installer, though either hitting Enter or removing & replacing the monitor cable would get the screen working properly. This didn't happen with 11.5, so it'll be interesting to see if the login screen works properly after an AV scan.

When I get the black login screen, Ctrl+Alt+Del doesn't do anything, but waiting till the screensaver kicks in & then moving the mouse gets the login screen back. I've never had a problem with black screens anywhere else other than in the last few days on the login screen.
My System SpecsSystem Spec
14 May 2011   #10

windows 7 ultimate
 
 

Fingers crossed!!
My System SpecsSystem Spec
Reply

 Black screen + cursor instead of login screen




Thread Tools



Similar help and support threads for2: Black screen + cursor instead of login screen
Thread Forum
Black screen with movable mouse cursor before login screen appears BSOD Help and Support
Solved Black screen, cursor active before login screen. BSOD Help and Support
Solved Login screen don't appear, only black background and cursor General Discussion
Black screen before login screen, no cursor General Discussion
Black Screen of Death with Mouse Cursor before Login Screen BSOD Help and Support
Black Screen With Cursor after Login BSOD Help and Support
Black Screen with Cursor = Slow Login Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33