Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Class not registered (Exception from HRESULT: 0x800154).....


30 Jun 2011   #1

Windows 7 64-bit
 
 
Class not registered (Exception from HRESULT: 0x800154).....

So EVERYTHING was working perfectly fine today on my Sony Vaio VGN-FW510D Laptop until I uninstalled Team Fortress 2 today. (It's a game) I used Revo Uninstaller to uninstall it and then scanned and deleted the leftovers (it scans and deletes leftover files and folders and registry strings/keys) ... everything was fine... then, I went to eat dinner.... I come back and log on... First problem I notice, no sound. For some reason there were no more sounds working anymore... I tried YouTube videos, going into Playback devices, sound check... nothing worked... The next problem was these two windows error boxes that now pop up when I log on.. The box both say:

SmartWi Connection Utility

Class not registered (Exception from HRESULT: 0x80040154(REGDB_E_CLASSNOTRED))

And now my wireless internet does not work! (That's the SmartWi..)
Yes... right now I'm typing using a temporary wired connection
So... being able to solve many computer related problems myself, I tried all of these methods and obviously did not succeed.. :

- CCLEANER
- Free Windows Registry Repair
- Little Registry Cleaner
- Windows Disk Check
- Windows Memory Check
- Safe Mode
- System Restore
- Uninstalling STEAM
- Re-Installing SmartWi Connection

Please.... anyone who's knowledgeable with registry keys and such, I think I accidentally deleted an important registry key with Revo Uninstaller and I need to do the Run: regsvr32 ______.dll thing... but I'm not experienced with it and I don't know which .dll's to put....
Any help will be greatly appreciated

So the problems are:
- No Sound
- No Wireless Internet

I have a Sony Vaio Laptop and I'm using Windows 7 64-bit... this same message will be posted on other forums so please don't say something obvious like check Sony's forums..

My System SpecsSystem Spec
.

30 Jun 2011   #2

 
 

Hi, welcome to the forums

Have you tried uninstalling the SmartWi software then downloading the latest version from the Sony site and re-installing?

A re-install of the software should replace any missing registry entries that would have been previously removed, regardless of how.
My System SpecsSystem Spec
Reply

 Class not registered (Exception from HRESULT: 0x800154).....




Thread Tools



Similar help and support threads for2: Class not registered (Exception from HRESULT: 0x800154).....
Thread Forum
class not registered General Discussion
Class Not Registered Software
Class not registered error Performance & Maintenance
Windows movie maker-Class not registered Music, Pictures & Video
mmc.exe class not registered error General Discussion
Class is not registered. [NEED HELP] Music, Pictures & Video
Class not registered - Windows Movie Maker Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:29 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33