Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD ks.sys after failure to install SP1

30 Jun 2011   #1
houldsworth1

Windows 7 Home Premium 64bit
 
 
BSOD ks.sys after failure to install SP1

He there,

I have a Windows 7 64-bit machine. I recently tried to install Service Pack 1 and it failed with a BSOD. I was able to get the machine back by booting in safe mode and allowing it to undo. I tried this several times - going all the way to removing everything and running with no services started. Each time the same result.

Now I have started getting the BSOD even when I am not installing the SP - e.g. I was just using the machine earlier and it crashed.

The machine is an Acer Aspire AMD II X2 215, 4gb of RAM.
Windws 7 Home Premium was pre-installed with the machine.

I have attached the logs as requested.

I would really appreciate the help of the gurus here since I would rather not have to reinstall from scratch.

Thanks!


My System SpecsSystem Spec
.

30 Jun 2011   #2
JMH

Win 7 Ultimate 64-bit. SP1.
 
 

Quote   Quote: Originally Posted by houldsworth1 View Post
He there,

I have a Windows 7 64-bit machine. I recently tried to install Service Pack 1 and it failed with a BSOD. I was able to get the machine back by booting in safe mode and allowing it to undo. I tried this several times - going all the way to removing everything and running with no services started. Each time the same result.

Now I have started getting the BSOD even when I am not installing the SP - e.g. I was just using the machine earlier and it crashed.

The machine is an Acer Aspire AMD II X2 215, 4gb of RAM.
Windws 7 Home Premium was pre-installed with the machine.

I have attached the logs as requested.

I would really appreciate the help of the gurus here since I would rather not have to reinstall from scratch.

Thanks!
Hi houldsworth1 and welcome

It seems to be a conflict between KS.sys (a windows OS driver) and is Related to WD Smartware. (
Note: Located in \%Program Files%\Western Digital\WD Smartware\Front Parlor\WDFME\)

I would first remove the WD software to test and if it still BSOD's I would do a repair install from the original Win 7 DVD to repair the KS.sys


Let us know if you require further assistance with this.
My System SpecsSystem Spec
01 Jul 2011   #3
houldsworth1

Windows 7 Home Premium 64bit
 
 

Thank you so much for the quick response! I will give this a shot and see if that works.

Assuming that does work - do you think that my chances of getting SP1 installed are higher too? I feel as though I have to do that or I am going to end up falling behind with security updates.

Thanks again!
My System SpecsSystem Spec
.


01 Jul 2011   #4
houldsworth1

Windows 7 Home Premium 64bit
 
 

Interestingly I found another post that talks about problems with a Logitech web cam and WD Smartware causing BSOD. I have both of those so if removing the WD Smartware doesn't work I will also try the webcam driver.
My System SpecsSystem Spec
01 Jul 2011   #5
JMH

Win 7 Ultimate 64-bit. SP1.
 
 

Thanks for reporting back....
Once this "problem" is sorted out you should be ready to go ahead with SP1.

Please keep us posted.
My System SpecsSystem Spec
01 Jul 2011   #6
houldsworth1

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by JMH View Post
Thanks for reporting back....
Once this "problem" is sorted out you should be ready to go ahead with SP1.

Please keep us posted.
Update. After uninstalling WD Smartware SP1 installed without any issue.

Thank you so much - I was expecting to spend a chunk of the weekend reinstalling windows 7 and getting all of my software back in place. Not to mention that my cloud backup would start again from scratch (last time it took 3 weeks to complete the first backup).

You guys ROCK!

P.S. How did you spot that it was WD Smartware that was causing the problem? I would love to know for the future...
My System SpecsSystem Spec
Reply

 BSOD ks.sys after failure to install SP1




Thread Tools





Similar help and support threads
Thread Forum
.NET 4.0 Install Failure
I was on my way to install Freemake video conversion tool and it requires .NET 4.0, which isn't on my Win7 Ultimate x64 mule, so it fetched the installer and I ran it. It failed to install throwing a fairly generic code "file not found". I have been doing some searches and the problem/s with such...
Software
Windows SDK install failure
I am in kind of a hurry starting up my account as I am not able to install the Windows SDK, I have previously installed and uninstalled it before but I need to reinstall it now and I got this error while the install was on Installation of the "Microsoft Windows SDK for Windows 7" product has...
Software
SP1 Install Failure 8024200D
Anyone else get this one yet? Any resolution? I've tried all the recommendations: other updates all installed, anti-virus disabled, system update readiness tool, etc, etc, etc. No luck at all installing this service pack. It just fails every time. WTF Microsoft? :confused:
Windows Updates & Activation
BSOD + Repair Install Failure 0x80070241
I've had many BSOD crashes, which I thought were caused by bad memory, but I thoroughly checked the memory and could not isolate any problems. Then I found this forum, and tried Driver Verifier, which also didn't show any specific problems (at least not that I could tell). Then I tried Blue...
BSOD Help and Support
Update install failure
My Pc is a Dell Inspiron 531, running Windows 7 64 bit. I received the updates available message and clicked install and received an unable to install updates message but no suggested fixes or where to start looking for assistance.
Windows Updates & Activation
Os 7 dvd install failure
ISSUE: GRMCULXFRER_EN_DVD FAILED ON 64 BIT MACHINE USING DVD ISO extracted on 64 bit machine burnt at 1X speed (No Joy) ISO extracted on 32 bit machine burnt at 1X speed (No Joy) Boot priority set as CD/DVD 1 Using ISO MAGIC and burning on Memorex DVD Media at 1X speed See system Specs...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:46.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App