Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GOEC62-1.dll Error


16 Oct 2011   #1

 
GOEC62-1.dll Error

Attachment 179549

The above reads:
"The application or DDL C:\PROGRA~1\Google\GOOGLE~1\GOEC62~1.DLL is not a valid Windows image. Please check this against your installation diskette." (Have moved twice since it got this computer and have NO CLUE where that disk is???)

Running a six-year old Dell Inspriron 6000 laptop and for the past month now, keep getting this error - especially during start-up as all the JUNK programs are loaded! In order to get past each display of the error msg. I have to hit the OK button. Have tried a couple things to get rid of it, but no success. One prog. I tried was Rezooka - didn't work!

If you notice, it says the location of the dll is in C:\progra~1\Google\google~1\GOEC62-1.dll. But 'progra~1' must be a hidden directory 'cause I can't find it? There is a c:\programs files\google\google~1\.... that does contain the dll named 'GOEC62-1.dll'. I know/think there is directory called 'progra~1' there 'cause I tried to create one in under c: and was advised it already existed!

Anybody got an idea what's the problem and how to fix it?

BTW - every time I try to launch any program, I get the same pop-up error and have to just hit OK to continue?

And 'YES' I did a search here for 'GOEC62-1.dll" and was not able to locate anything - so IF this subject has been addressed, point me in the correct direction.


My System SpecsSystem Spec
.

18 Oct 2011   #2

Windows 7 Ultimate x86
 
 

Said dll is connected to Google Desktop and/or Google Earth. So you should uninstall both (if present), and if so desired re-download and reinstall them.
The ominous "google~1" or "progra~1" is how long path/filenames are shown in 8.3 notation (which is a relic from DOS times . As an example if you have on your drive the directories "C:\Program Files" , "C:\Program Tools" and say "C:\Programmers Utilities" In 8.3 notation they would read as follows:
C:\progra~1
C:\progra~2
and C:\progra~3

-DG
My System SpecsSystem Spec
20 Oct 2011   #3

 

OK, think I understand the 'ominous" part and I think you're saying that the directory on my computer named 'c:\programs files' is the same as 'C:\PROGRA~1' as far as this 8.3 thingy goes and there actually is NO so named 'C:\PROGRA~1' directory?

When this crap/error started showing up, I located the 'goec62-1.dll' file in the PROGRAM FILES directory and renamed it to 'goec62-1BK.dll' hoping IF that was the correct one the error would read CAN NOT FIND .DLL instead of bad image... but that did not happen - error msg. stayed the same! And I didn't know a .dll was a Windows image as stated in the error msg?

Now, as far as Google Desktop and Google Earth - don't believe I have them on this computer - at least they are not listed in the ADD OR REMOVE PROGRAMS area. Only think 'google' is CROME which I just added about three days ago HOPING that IF it added the .dll in question, I'd get a GOOD one!! Didn't happen. If G.Desktop is on here, could it be under something else?

I think at one time I had GoogleEarth, but removed it a couple years ago - and this error just started showing up about a month ago??
My System SpecsSystem Spec
.


20 Oct 2011   #4

Windows 7 Ultimate x86
 
 

Right there is no directory with that name. It's a translation from a long name into the traditional 8.3 format. You have to think of it as a mask kind of like in "progra*"
The first name found that matches the mask would be referred to as progra~1, the second one as progra~2 and so on.
More info here : How Windows Generates 8.3 File Names from Long File Names
As for your error message: it might well be some residue. Nut in case it's more, load this, update it and run a full check:

Malwarebytes : Malwarebytes Anti-Malware is a free download that removes viruses and malware from your computer

If you're (and only if you 're really) familiar with the registry, make a restore point and delete this key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs
That should get rid of the error message.

-DG
My System SpecsSystem Spec
10 Nov 2011   #5

 

Sledge - yup, that worked; the part about deleting the problem key!! Thanks for the 'help'.
My System SpecsSystem Spec
11 Nov 2011   #6

Windows 7 Ultimate x86
 
 

You're very welcome and I'm glad the issue is resolved
Thanks for the feedback

-DG
My System SpecsSystem Spec
Reply

 GOEC62-1.dll Error




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33