Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: BSOD - while playing ut2004 (portcls.sys)

12 Feb 2012   #1

Windows 7 Ultimate 64bit
 
 
BSOD - while playing ut2004 (portcls.sys)

BSOD appears only while playing ut2004. BF3 etc works fine.
Appeared after graphic card change Ati 4870 --> GTX 560 Ti

Everything at stock clocks.
The most of components are half year old.
OS installed 08.19.2011

System specs:
AMD Phenom II X4 955
Asus M4A87TD/USB3
2x4gb Kingston HyperX 1600mhz DDR3
NVIDIA Geforce GTX 560 Ti
Creative Soundblaster X-Fi titanium
Samsung F1 750gb, own 60gb part for OS.
Windows 7 Ultimate x64 retail

My System SpecsSystem Spec
.

13 Feb 2012   #2

Windows 7 Home Premium 64 Bit
 
 

Code:
Loading Dump File [F:\BSODDmpFiles\valtsu\Windows_NT6_BSOD_jcgriff2\021212-16863-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Machine Name:
Kernel base = 0xfffff800`03259000 PsLoadedModuleList = 0xfffff800`0349e670
Debug session time: Sun Feb 12 06:36:24.716 2012 (GMT-7)
System Uptime: 0 days 0:36:56.308
Loading Kernel Symbols
...............................................................
................................................................
...................................
Loading User Symbols
Loading unloaded module list
.....
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 3B, {c0000005, fffff88003f8cbf9, fffff8800379bd00, 0}

Probably caused by : portcls.sys ( portcls!CPortPinWaveRT::PowerNotify+1829 )

Followup: MachineOwner
---------

2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_SERVICE_EXCEPTION (3b)
An exception happened while executing a system service routine.
Arguments:
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff88003f8cbf9, Address of the exception record for the exception that caused the bugcheck
Arg3: fffff8800379bd00, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:
------------------


EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP: 
portcls!CPortPinWaveRT::PowerNotify+1829
fffff880`03f8cbf9 3b4828          cmp     ecx,dword ptr [rax+28h]

CONTEXT:  fffff8800379bd00 -- (.cxr 0xfffff8800379bd00)
rax=0000000000000000 rbx=00000000c0000001 rcx=0000000000002000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88003f8cbf9 rsp=fffff8800379c6e0 rbp=fffffa8008144060
 r8=0000000000002000  r9=0000000000000000 r10=fffffa8006d0e158
r11=fffffa8006d0e158 r12=fffffa800c925190 r13=fffffa8007743790
r14=fffffa800c7e3330 r15=000000000012c000
iopl=0         nv up ei ng nz na po cy
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010287
portcls!CPortPinWaveRT::PowerNotify+0x1829:
fffff880`03f8cbf9 3b4828          cmp     ecx,dword ptr [rax+28h] ds:002b:00000000`00000028=????????
Resetting default scope

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x3B

PROCESS_NAME:  audiodg.exe

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from 0000000000000000 to fffff88003f8cbf9

STACK_TEXT:  
fffff880`0379c6e0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : portcls!CPortPinWaveRT::PowerNotify+0x1829


FOLLOWUP_IP: 
portcls!CPortPinWaveRT::PowerNotify+1829
fffff880`03f8cbf9 3b4828          cmp     ecx,dword ptr [rax+28h]

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  portcls!CPortPinWaveRT::PowerNotify+1829

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: portcls

IMAGE_NAME:  portcls.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4a5bcc03

STACK_COMMAND:  .cxr 0xfffff8800379bd00 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_portcls!CPortPinWaveRT::PowerNotify+1829

BUCKET_ID:  X64_0x3B_portcls!CPortPinWaveRT::PowerNotify+1829

Followup: MachineOwner
---------
Nothing conclusive shows up in your crash report. I did notice AODDriver 4.01 is disabled or not working correctly. I would recommend uninstalling the software if you can. AMDOverdrive or EasyTune needs to be removed. Other possible causes of your crash type are Memory problems... Corrupted hard disk file system... Corrupted System Files... Graphics Driver... Drivers...
My System SpecsSystem Spec
13 Feb 2012   #3

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by writhziden View Post
Nothing conclusive shows up in your crash report. I did notice AODDriver 4.01 is disabled or not working correctly. I would recommend uninstalling the software if you can. AMDOverdrive or EasyTune needs to be removed. Other possible causes of your crash type are Memory problems... Corrupted hard disk file system... Corrupted System Files... Graphics Driver... Drivers...
hmm, i tried remove AMDOverdrive or EasyTune but i can't even find those from my Hard drive.
My System SpecsSystem Spec
.


13 Feb 2012   #4

Windows 7 Home Premium 64 Bit
 
 

Do you have AMD Vision Engine Control Center installed?
My System SpecsSystem Spec
14 Feb 2012   #5

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by writhziden View Post
Do you have AMD Vision Engine Control Center installed?
Nope, i had it before I changed my graphic card. I am pretty sure that formating and fresh OS install would solve this issue but im too lazy to do it.

Thanks anyway.
My System SpecsSystem Spec
14 Feb 2012   #6

Windows 7 Home Premium 64 Bit
 
 

You could try the following steps.
  1. Manually create a system restore point.
  2. Download and install Driver Sweeper.
  3. Restart your computer in Safe Mode.
  4. In Driver Sweeper, put a tick in AMD - Display; analyze, and clean.
See if that helps. If it makes the problem worse or causes other problems, use the system restore point to go back.
My System SpecsSystem Spec
14 Feb 2012   #7

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by writhziden View Post
You could try the following steps.
  1. Manually create a system restore point.
  2. Download and install Driver Sweeper.
  3. Restart your computer in Safe Mode.
  4. In Driver Sweeper, put a tick in AMD - Display; analyze, and clean.
See if that helps. If it makes the problem worse or causes other problems, use the system restore point to go back.
Thanks for advice, I did the following steps. I will let you know if it worked or not.
My System SpecsSystem Spec
06 Mar 2012   #8

Windows 7 Home Premium 64 Bit
 
 

You're welcome. How is the system responding?
My System SpecsSystem Spec
06 Mar 2012   #9

Windows 7 Ultimate 64bit
 
 

I thought it worked but still caused bsod by portcls.sys but it happened only once.
Tomorrow I will get 120 ssd so I will clean my comp completely.
My System SpecsSystem Spec
06 Mar 2012   #10

Windows 7 Home Premium 64 Bit
 
 

Alright, let us know how the system responds after the clean install.

Also, make sure everything is up to date for the SSD firmware and chipset wise. See the Quote by usasma regarding SSDs in post #2 of BSOD when hibernating.
My System SpecsSystem Spec
Reply

 BSOD - while playing ut2004 (portcls.sys)





Thread Tools



Similar help and support threads for2: BSOD - while playing ut2004 (portcls.sys)
Thread Forum
Portcls.sys and Kernal mode Bsods BSOD Help and Support
BSOD playing too long, watching a video and playing a game or gmod BSOD Help and Support
Intermitant BSOD on shutdown w autorestart. ntoskrnl.exe? portcls.sys? BSOD Help and Support
portcls BSOD with three audio programs open BSOD Help and Support
BSOD on a daily basis, mostly when playing playing Heroes of Newerth. BSOD Help and Support
BSOD portcls.sys BSOD Help and Support
Repeated BSOD on reboot (before login) 0xD6 portcls.sys (audiodg.exe) BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:28 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33