Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD playing Red Faction/other Games, related to win32k.sys


15 Feb 2012   #1

Microsoft Windows 7 Ultimate 64-Bit 7601 Multiprocessor Free Service Pack 1
 
 
BSOD playing Red Faction/other Games, related to win32k.sys

Hi Sevenforum Members,
i hope you can help me with my PC problems.
My System:
Windows 7 64 Ultimate OEM Version (Installed myself)
- What is the age of system (hardware)?
Just recently bought a new mainboard,cpu,memory
- What is the age of OS installation (have you re-installed the OS?)
Reinstalled with the new hardware.

I already took some of your recommended tests to find out what is wrong. But i have not been sucessful yet.
I identified the FNETTBOH_305.sys as a problem with driver verifier. It got rid of it and my PC is already running a lot more stable.

My PC is often crashing with a BSOD when playing games. It has not happend if just browsing the Web or anything else not related to 3D graphics so I suppose the first problem is solved.

I made a zip file as described. I hope I did everything correct.

If you have any idea what causes the BSODs please get in touch.

Sincerely Alexander


My System SpecsSystem Spec
.

15 Feb 2012   #2

Windows 8.1 Pro x64
 
 

Your BSODs were caused by the Creative Audio/Sound Blaster Driver
Update that driver & associated software
Creative Worldwide Support

Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800030a072c, address which referenced memory

Debugging Details:
------------------


WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800032cb100
 0000000000000000 

CURRENT_IRQL:  2

FAULTING_IP: 
nt!KeWaitForSingleObject+17c
fffff800`030a072c 4c8938          mov     qword ptr [rax],r15

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0xA

PROCESS_NAME:  svchost.exe

TRAP_FRAME:  fffff8800a8384f0 -- (.trap 0xfffff8800a8384f0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffffa800d3a6ee0
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800030a072c rsp=fffff8800a838680 rbp=0000000000000000
 r8=fffff78000000008  r9=0000000000000000 r10=0000000000000000
r11=fffff880037e4180 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
nt!KeWaitForSingleObject+0x17c:
fffff800`030a072c 4c8938          mov     qword ptr [rax],r15 ds:c8b0:00000000`00000000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800030981e9 to fffff80003098c40

STACK_TEXT:  
fffff880`0a8383a8 fffff800`030981e9 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0a8383b0 fffff800`03096e60 : 00000000`00000010 fffff8a0`04abacac fffff800`032ce500 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`0a8384f0 fffff800`030a072c : fffffa80`0ed9c8b0 00000000`00000000 fffffa80`0d3a6b30 00000000`00000000 : nt!KiPageFault+0x260
fffff880`0a838680 fffff800`0306b61e : fffff880`0a838700 fffff800`00000022 fffffa80`0e83f000 fffffa80`0e83f000 : nt!KeWaitForSingleObject+0x17c
fffff880`0a838720 fffff800`030ab1c5 : 00000000`00000001 00000000`00000000 00000000`00000000 fffff880`0a8389e8 : nt!KiAcquireFastMutex+0x4e
fffff880`0a838760 fffff880`0697f2c2 : fffffa80`0ed9cae8 fffffa80`0ed9cb30 00000000`00000010 fffff880`0697f1d8 : nt!ExAcquireFastMutex+0x45
fffff880`0a838790 fffffa80`0ed9cae8 : fffffa80`0ed9cb30 00000000`00000010 fffff880`0697f1d8 00000000`00000000 : ctaud2k+0x772c2
fffff880`0a838798 fffffa80`0ed9cb30 : 00000000`00000010 fffff880`0697f1d8 00000000`00000000 00000000`00000000 : 0xfffffa80`0ed9cae8
fffff880`0a8387a0 00000000`00000010 : fffff880`0697f1d8 00000000`00000000 00000000`00000000 00000000`00000010 : 0xfffffa80`0ed9cb30
fffff880`0a8387a8 fffff880`0697f1d8 : 00000000`00000000 00000000`00000000 00000000`00000010 fffffa80`0840da10 : 0x10
fffff880`0a8387b0 00000000`00000000 : 00000000`00000000 00000000`00000010 fffffa80`0840da10 fffffa80`0ed9c8b0 : ctaud2k+0x771d8


STACK_COMMAND:  kb

FOLLOWUP_IP: 
ctaud2k+772c2
fffff880`0697f2c2 ??              ???

SYMBOL_STACK_INDEX:  6

SYMBOL_NAME:  ctaud2k+772c2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ctaud2k

IMAGE_NAME:  ctaud2k.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4be16bc4

FAILURE_BUCKET_ID:  X64_0xA_ctaud2k+772c2

BUCKET_ID:  X64_0xA_ctaud2k+772c2

Followup: MachineOwner
---------
My System SpecsSystem Spec
15 Feb 2012   #3

Microsoft Windows 7 Ultimate 64-Bit 7601 Multiprocessor Free Service Pack 1
 
 

First of all, thank you for your advice!

I found a newer Version on the Creative Homepage. Strangely the Autoupdate did not show it to me?!
Old Version was: 6.0.100.1015 from 04.11.2011
New Version: 6.0.100.1022 from 28.11.2011

I will try and see if this resolves my problem and get back in touch.
Have a pleasent day.
Alexander
My System SpecsSystem Spec
.


20 Feb 2012   #4

Microsoft Windows 7 Ultimate 64-Bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi, I hope you can help me again. Sadly I still received another bluescreen today. But it was about the dxgkrnl.sys. I have attached everything again and hope someone can give me another hint what is wrong

Things I remember I changed from the last one:
-The Creative Sound driver
-The newest ATI graphic driver
-deactivated the integrated INTEL graphics device
My System SpecsSystem Spec
21 Feb 2012   #5

Windows 8.1 Pro x64
 
 

dxgkrnl.sys is related to your graphics card & its driver. Reinstalling those could fix your problem.
My System SpecsSystem Spec
Reply

 BSOD playing Red Faction/other Games, related to win32k.sys




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33