Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: LAN connection gets disabled by itself on idle. Sometimes BSODs.


21 Feb 2012   #1

Windows 7 Ultimate 32 bit
 
 
LAN connection gets disabled by itself on idle. Sometimes BSODs.

Hii..here's what's happening..
A few days ago I tried connecting a MBlaze modem to my laptop (Windows 7 Ultimate 32 bit) to access internet. But it resulted in instant BSOD everytime.
I deleted the modem software after that & didn't try to connect it again.
But now, whenever I connect using my LAN broadband, connection works fine as long as I am continuously browsing something. But as soon as I stop browsing and it goes in idle mode in about 10-15 minutes, the connection gets disconnected and in the Broadcom Netlink Ethernet properties it shows "No drivers are available for this device".
The only solution to this is a forced shutdown & restart, after which it works fine untill not idle. I am not able to download anything because of this.
I tried many things like reinstalling the network adapter driver, unchecking the power management feature, resetting the connection, etc. but nothing is working.
Plzz somebody help...


My System SpecsSystem Spec
.

21 Feb 2012   #2

Windows 7 Home Premium 64 Bit
 
 

Please follow the http://www.sevenforums.com/crashes-d...tructions.html to provide us with the necessary information to debug the problem.
My System SpecsSystem Spec
22 Feb 2012   #3

Windows 7 Ultimate 32 bit
 
 

Actually the BSODs are gone. The problem is just that the connection gets disconnected by itself on idle.
Even the adapter properties now show that the driver is working fine. But I am not able to get the connection working persistently. What can be the possible reason?
FYI, the earlier BSODs that occured were of type 'Driver IRQL not less or Equal.' with errors showing for the drivers spsys.sys & haspnt.sys.
Is this sufficient to get a solution on my problem? I don't have the .dmp files of earlier BSODs in minidump folder as the feature was disabled before. so no logs were written.
My System SpecsSystem Spec
.


22 Feb 2012   #4

Windows 7 Home Premium 64 Bit
 
 

See spsys.sysand Haspnt.sys

You may have corrupted network drivers. I would suggest doing a clean re-install of the drivers.

To fully re-install a driver, use the following steps.
  1. Click Start Menu
  2. Right Click My Computer/Computer
  3. Click Manage
  4. Click Device Manager from the list on the left
  5. Find the device you are trying to uninstall by expanding the appropriate set of devices
  6. Right click the device
  7. Click Uninstall (do not click OK in the dialog box that pops up after hitting Uninstall)
  8. Put a tick in Delete driver software for this device (if this option is available, otherwise just hit OK) and hit OK
  9. Install the latest driver for the device.

Alternatively:
  1. Login as an adminstrative user.
  2. Click Start Menu
  3. Click Control Panel
  4. Click Hardware and Sound
  5. Click Device Manager (the last link under Devices and Printers)
  6. Find the device you are trying to uninstall by expanding the appropriate set of devices
  7. Right click the device
  8. Click Uninstall (do not click OK in the dialog box that pops up after hitting Uninstall)
  9. Put a tick in Delete driver software for this device (if this option is available, otherwise just hit OK) and hit OK
  10. Install the latest driver for the device.
My System SpecsSystem Spec
27 Feb 2012   #5

Windows 7 Ultimate 32 bit
 
 

Your solution didn't work. The same problem continues. I can do browsing for hours without any problem. But when I stop browsing & put something on download, the adapter stops working in 10-15 minutes. What can be the problem?
Some process must be killing the adapter on idle mode.
My System SpecsSystem Spec
27 Feb 2012   #6

Windows 7 Home Premium 64 Bit
 
 

Do the following:
My System SpecsSystem Spec
27 Feb 2012   #7

W7 Pro SP1 64bit
 
 

Is this unchecked in the NIC's properties?

Attachment 200555

That is not a setting that you want to leave unchecked on a laptop - I'm just wondering if the power controls are working at all for you.
My System SpecsSystem Spec
27 Feb 2012   #8

Windows 7 Ultimate 32 bit
 
 

@UserNameIssues: It is unchecked. Also I have disabled 'side scaling'. Changed the power plan to never go into sleep mode on both Battery & when plugged in. And set it for 'maximum performance'.

@writhziden: Tried your options..
1. The system is already up to date.
2. The troubleshooter couldn't identify the problem.
3. sfc/scannow couldn't complete it's operation. shows following:

C:\Windows\system32>sfc/scannow
Beginning system scan. This process will take some time.
Beginning verification phase of system scan.
Verification 15% complete.
Windows Resource Protection could not perform the requested operation.

tried 3 times..couldn't get it to perform the task..

4. There hasn't been any BSOD since I activated the logging feature to log the reports to a dump file, as per the instructions. Still I am attaching the zip file of report for your consideration.
Additionally, I have attached a text file of details of error message that had come when last BSOD occured & after restart it showed that 'windows has recovered from an error'.

I definitely think that this problem is caused by hardware, affecting the drivers. As it never had a problem for it in last 2 years untill I tried using internet via that MBlaze modem I mentioned in my original post. So please look in that direction.
And thanks for your help in advance. Really appreciate it.
My System SpecsSystem Spec
27 Feb 2012   #9

W7 Pro SP1 64bit
 
 

My System SpecsSystem Spec
21 Mar 2012   #10

Windows 7 Home Premium 64 Bit
 
 

I am concerned that you cannot complete the system file check. This indicates your system is not functioning as it should. Have you at any time used an automated registry cleaner that may have caused problems to the system?

You said you used Tuneup Utilities... I recommended a Repair Install.

Are you still having problems with your computer?
My System SpecsSystem Spec
Reply

 LAN connection gets disabled by itself on idle. Sometimes BSODs.




Thread Tools



Similar help and support threads for2: LAN connection gets disabled by itself on idle. Sometimes BSODs.
Thread Forum
Solved Frequent, different BSODs, usually when idle BSOD Help and Support
Experiencing Various BSODs while Idle BSOD Help and Support
Solved cpu underclocking when idle. c1e, cool n quiet disabled PC Custom Builds and Overclocking
5 BSODs in one week, most when idle BSOD Help and Support
Shitton of BSODS, Idle or not. BSOD Help and Support
Wireless USB Disabled on Idle Hardware & Devices
DLink Disabled my Remote Desktop Connection Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:25 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33