Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: COM surrogate stopped working error - no solution seems to work

23 Mar 2012   #11
PrinorB

Windows 7 Professional x64
 
 

I followed the procedure outlined here for the VSS error. I hope that was ok...
Event ID 12348

I think my Crucial firmware is up to date c.f. attachment.

I am on testing drives again .


My System SpecsSystem Spec
.
23 Mar 2012   #12
PrinorB

Windows 7 Professional x64
 
 

Just to let you know. I copied the pics to my C drive (SSD) and viewed them and there is the same problem. I have my operating system on C (and thus photo viewer runs from that drive).

So I am not sure how the Seagate drive can be the problem... I guess it must be a problem with the SSD or with Windows somehow? Someone suggested Windows may be faulty. It's a genuine CD purchased from Newegg but I guess that doesn't mean there can't be problems. Is there any way to find out if the Windows installation has issues that it shouldn't have beyond the Scan that I did to start with?
My System SpecsSystem Spec
23 Mar 2012   #13
writhziden

Windows 7 Home Premium 64 Bit
 
 

How old is the installation? Any chance you have a corrupted user file? Fix a corrupted user profile

You could just start by making a new user and see if the problem persists. Then if it does not, think about creating a permanent new user and moving things over through the steps in that link.
My System SpecsSystem Spec
.

23 Mar 2012   #14
PrinorB

Windows 7 Professional x64
 
 

The installation is about two months old. I wouldn't know what should have happened to corrupt it (I also ran virus scans etc.)

I am also not aware that I deleted anything in any file that I shouldn't have. I only changed some of the windows features that were switched on.

I'll try the new user profile anyway.
My System SpecsSystem Spec
24 Mar 2012   #15
PrinorB

Windows 7 Professional x64
 
 

Hi writhziden,

I am just about to make a new user profile. Then I noticed another thing. Internet was really slow for a moment and I found the attached errors. I think I kept getting the DNS error before. The name of the script (?) that timed out varies. Should I follow this: Event ID 1014 Microsoft Windows DNS Client - TechNet Articles - Home - TechNet Wiki

Might this be a hardware problem?

I also found a user profile error. Maybe that is relevant (attached) because you were suggesting the user profile had a problem.
My System SpecsSystem Spec
24 Mar 2012   #16
PrinorB

Windows 7 Professional x64
 
 

Same with the other user account!

i just created a new account and viewed pics in there. I didn't delete the old one. I don't know if that is important.

Attached is the event viewer stuff that was associated with the new user account.
Note that the first time I logged onto the new user account I hadn't logged out of the old one and I got a message from a program "Panda vaccine" that it is still open in another account and cannot run twice. Some errors might have arisen from that. Then I logged out of the old one and logged into the new one again. In both cases the COM surrogate error occurred.
My System SpecsSystem Spec
24 Mar 2012   #17
writhziden

Windows 7 Home Premium 64 Bit
 
 

Yes, proceed through the steps in Event ID 1014 Microsoft Windows DNS Client - TechNet Articles - Home - TechNet Wiki and see if it helps.

Also, how do you connect to the internet? Do you connect directly through a modem provided by your ISP or do you have a router that the computer and modem connect to?


You may also want to look at these: http://www.sevenforums.com/crashes-d...d-working.html

Com Surrogate has stopped working

RC1 - "COM Surrogate Has Stopped Working"


I am also now subscribed to: COM Surrogate Windows 7 64bit

You have received excellent advice in that thread, as well. It was actually going to be what I suggested next.
My System SpecsSystem Spec
24 Mar 2012   #18
PrinorB

Windows 7 Professional x64
 
 

In other words you think I should reinstall windows with a different disk then the one I have? It is the last thing I would want to do because I have some software licensed through the university etc and it would be a pain getting all that back... If it is the only solution that you think would work though. So be it. I connect to a university network through a LAN cable. And i also had a look at all the other posts and tried most of the things (except disabling thumbnails and I didn't find this application that can check codecs (MMCompView). Does something similar exist for Windows 7?)
My System SpecsSystem Spec
24 Mar 2012   #19
writhziden

Windows 7 Home Premium 64 Bit
 
 

I was actually thinking you could use a new disc and do a repair install. Repair Install does not affect your programs or user files, so you shouldn't have to get licenses set up again.

You may have to Clean Install Windows 7 if the repair install does not work, but I would prefer to start with the least invasive method, first.
My System SpecsSystem Spec
24 Mar 2012   #20
PrinorB

Windows 7 Professional x64
 
 

quick question: How do I find out if my windows DVD has SP1 installed on it? The resulting installation procedure is different. I thought I try installing with the DVD I have and see if the error persists before downloading something else. Maybe its stupid
My System SpecsSystem Spec
Reply

 COM surrogate stopped working error - no solution seems to work




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
COM Surrogate has stopped working...
is there any proper solution for this problem...whenever i open pictures the "COM Surrogate has stopped working" comes.i set it with some ways after searching from google but it comes again..
Hardware & Devices
Com Surrogate Stopped Working. Win7 Home Premium 64bit
Problem signature: Problem Event Name: APPCRASH Application Name: DllHost.exe Application Version: 6.1.7600.16385 Application Timestamp: 4a5bc6b7 Fault Module Name: RPCRT4.dll Fault Module Version: 6.1.7601.17514 Fault Module Timestamp: 4ce7ba59 Exception Code: c0020043 Exception Offset:...
General Discussion
COM Surrogate has Stopped Working
Hi, I keep getting this message: http://174.36.240.130/wp-content/uploads/comsurrogatehasstoppedworking.png After this warning I choose to Close the program, and when I click "My Computer" windows explorer won't show any of the disks (C, etc), instead it shows a green bar at the top that slowly...
General Discussion
COM Surrogate stopped working
Whenever I launch a RECORDED video (by DXtory), or simply open the folder of where the videos are located I get this annoying error "COM Surrogate has stopped working" I tried to download several different codecs. but I still have this problem. Description Faulting Application Path: ...
General Discussion
COM Surrogate has stopped working
what the hell is that? How do I fix it? :huh: I've never even heard of this....and it only does it on my 64 bit Win7 Ultimate. Any help? Anyone? :mad:
BSOD Help and Support
Com Surrogate has stopped working
Any ideas what this means? It keeps popping up ever few seconds. I THINK ever since i un installed Bitcomet. Using build 7077. Thanks Dave.
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App