Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Invalid Class String

08 Apr 2012   #1

Florida
 
 
Invalid Class String

Hello All-

I have an awesome fan app (FAN Xpert) that I have been using on my Rampage IV Rig. I recently did a re-install of Win 7 (about a week ago) and it has yet to run. It actually is part of suite of utilities that comes bundled with ASUS Mobo's. I have installed it a number of times in the past and have never had any problems. First thing I did was uninstall and re-install I used Revo Uninstaller in safe mode. The problem re-occurred so I then did a regular uninstall.Next I ran SFC. I got a bunch of errors (11) that were all Explorer.exe based. I then replaced Explorer with a fresh copy from the Windows 7 DVD. still Class not recognized. I don't use any of those Registry repair utilities as I have found them to be more detrimental then helpful. So far I have had no problems with any other Apps.

I would like to fix these system issues before they get out of hand. I attached an example of the errors. They are all basically the same in my SFC log. If you guys need more info please let me know.


My System SpecsSystem Spec
.

09 Apr 2012   #2

Windows 7 Home Premium 64 Bit
 
 

A few questions:
  • How did you re-install?

  • Are you still getting the above errors, or have you since replaced explorer.exe from the DVD again?

  • When you replaced explorer.exe, did you run sfc /scannow again after a restart to see if the corruption was indeed fixed?

Once the explorer.exe problem is fixed, we can proceed with other steps. To make sure I understand the problem: You can install the program, but it will not run. You get a "class not recognized" error when you try to run it? Would it be possible to post a screenshot of that error? Uninstalling and re-installing resulted in the errors through the system file check but did not resolve the running problems with the program, correct?
My System SpecsSystem Spec
09 Apr 2012   #3

Florida
 
 

Hi, and thanks for the response-

I did a full reinstall with formatting directly from the DVD. Yes, I am still getting the same errors. I only replaced explorer.exe once. I did run sfc /scannow immediately after I replaced the explorer.exe file and found the same errors (all explorer related) that were there prior to replacing the explorer.exe file. I am going to see if the same number of errors exist right now or if they have increased. I don't want things to go down hill.

TIA!
My System SpecsSystem Spec
.


09 Apr 2012   #4

Florida
 
 

I just scanned and found two more errors. A lot of repairs as well. The last 2 times I ran sfc there were no repairs....
My System SpecsSystem Spec
09 Apr 2012   #5

Windows 7 Home Premium 64 Bit
 
 

It may be best to cut your losses and Repair Install Windows 7. Up to you. If you want to go that route, let us know, and we can help if needed.
My System SpecsSystem Spec
10 Apr 2012   #6

Florida
 
 

Yeah, I was planning to do that last week. I figure I might give it a whirl. Hopefully my registry will be repaired. I would rather do it now as opposed to later, these things only get worse.

I will let you know how things turn out.

Thanks again.
My System SpecsSystem Spec
10 Apr 2012   #7

Windows 7 Home Premium 64 Bit
 
 

You're welcome. Look forward to seeing how the system responds after the repair install.
My System SpecsSystem Spec
12 Apr 2012   #8

Florida
 
 

Hi-

Sorry for the late reply, I was out of town. I did the repair install. System files are all fixed. I have been checking them periodically. I cannot install that fan app. So strange. I believe it has something to do with Catalyst. I hate AMD drivers. I normally never buy their cards. It took them 4 months to come out with a stable driver for my TriFire setup. I normally buy Nvidia as their drivers are so much more robust. I bought 3 Geforce 680's last month (for another box) and the drivers right out of the box work great.

Needless to say, I need to do a repair install again with Catalyst uninstalled prior to running it, install the ASUS software suite after it is done, AND THEN install the VGA drivers. I bet that will work. I just get nervous about doing a repair install again.

Overall, I would recommend the repair install to anyone with corrupt system files. I was amazed.

Thanks again!
My System SpecsSystem Spec
12 Apr 2012   #9

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

When you do SFC scan, you should be running it from the Windows 7 cd, not from the boot drive. Also, explorer.exe has nothing to do with the AMD drivers, nor the fan app, so it's unrelated to this case, though it's necessary that you had it fixed. I personally find it disconcerting that both the locally cached version of explorer.exe and the running version were corrupt. Be alert for possible drive failure. You can also run Seatools for surety's sake (all tests except advanced).
My System SpecsSystem Spec
12 Apr 2012   #10

Florida
 
 

I agree on the exloper.exex being corrupt in both cases it made no sense to me. I didn't think Explorer.exe had something to do with AMD drivers. I think (which is a stretch) that the ASUS Suite is having problems with AMD drivers. It is good to know that I should run SFC off the DVD. BTW- My startup disk is a RAID array (0). The reason I re-installed recently is because I had a failing SSD. All my drives are SSD. So unfortunately I can't use Seatools.

Any ideas?

TIA!
My System SpecsSystem Spec
Reply

 Invalid Class String




Thread Tools



Similar help and support threads for2: Invalid Class String
Thread Forum
Monitor CMD window for a string? Software
Registry String Value NoWorkingDirectory?? General Discussion
SQL string manipulation Software
A peculiar java string:its fun to know Chillout Room
String value changes not showing??? Customization
Invalid IP Config + Invalid BOOT.INI = HELP!! Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:16 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33