Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD when installing programs, error 0xc000000e


12 Apr 2012   #1

Windows 7 x64 Pro
 
 
BSOD when installing programs, error 0xc000000e

I started to experience bsods lately when I am trying to install (and sometimes uninstall) programs. PC would not boot past 'starting windows' logo and I got a blank screen with

Windows failed to start.
[bla bla bla]
Status: 0xc000000e
Info: The boot selection failed because a required device is inaccessible.

Booting from Win Repair Disk and attempting automatic repairs as well as rebuilding bcd/mbr is of no help.

Now, safe mode boot hangs on error with \system32\drivers\atipcie.sys
I think that might be related to the fact that about two month ago I switched motherboards from Gigabyte MA-790GP-UD4H to Gigabyte 970A-UD3. But the process was smooth as butter and I had a pretty solid pc for the last two month. I also reinstalled (just in case) ATI chipset drivers, once I got window 7 running off new mobo.

What would you guys recommend me to do to get pc back to normalcy so that I can install programs like in a good old days. I can now boot into Windows 7 fine, so I can experiment and I have a backup.

1. Should I rename atipcie.sys to atipcie.sys.old? (but would not Windows 7 just pull the driver from its repository on HDD?)
2. Something else?

Thanks a lot for all your help!


My System SpecsSystem Spec
.

12 Apr 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

You would need to do a repair install of Windows 7 by overwriting the existing copy of Windows, or run an SFC scan from Windows CD (crucial!).

This can occur when settings concerning your drives in the BIOS have been altered after installation of Windows, such as setting it to AHCI when it was originally in IDE mode, and vice versa. This can happen with default settings that existed on the new mobo that weren't set as such on the old one that you replaced.

This can also be caused by the motherboard drive controller failing (bad mobo), or the drive itself is bad. If this an SSD drive special firmware and drivers need to be installed, and even motherboard settings and a new installation of Windows 7 might be necessary. SSD drives also have a relatively high rate of failure so that could also account for it.

If you can boot into Windows 7, you should run JCGriff Report to send data to us so we can figure out more, but most likely what I've mentioned is responsible for this.
My System SpecsSystem Spec
13 Apr 2012   #3

Windows 7 x64 Pro
 
 

Thanks so much for your for your help. I will definitely try SFC scan & post memory dump (although the latter might be a bit tricky as pc becomes completely unbootable after BSOD).

Just a few observations so far:

1. I do not think it is malfunctioning hardware. I can replicate the situation 1-1 with non-SSD hdd, i.e. working & rebooting as many times as I need, but as soon as I need to install some programs - BSOD. Given this pattern, I do not think it is mobo controller going bad. Again why it would be working flawlessly until I need to install smth.

2. It can be related to the fact that I swapped motherboard, but I think only with *** additional *** factor. Otherwise how to explain that I was working fine for a few month without any problems after I did that.

3. So, most likely, it is OS specific. Something related to ATI (chipset?) drivers, as failure of booting in safe mode shows...


But once again, thanks a lot!
My System SpecsSystem Spec
.


13 Apr 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

So downloading, copying files, moving files, etc., are all functions that work ok, but it's just installation of programs that is the issue? Also, when you said you can replicate it on a non-SSD drive, are you implying you have Windows installed on that drive as well and the same exact behavior occurs? How did you install Windows on the HDD? Did you make a drive image of what's on the SSD and copy it to the HDD, or did you manually install Windows on the HDD?

The OS would most likely not be loading the ATI chipset drivers during Safe Mode. They are optional drivers aside from any drive controller drivers that are necessary to access your drive for Windows.

Have you tried running a full Disk Check on the drive? Make sure to check to fix bad sectors as well.

We'll most likely need more information as is possible for this. At the very least zip up and send us the minidumps (located in \Windows\Minidump). All I can tell right now is there has to be hardware failure, especially if it's being repeated on two separate drives with two separate installations of Windows (if I am reading things correctly). It may not be the drive, but it'll have to be some issue regarding the motherboard.
My System SpecsSystem Spec
15 Apr 2012   #5

Windows 7 x64 Pro
 
 

Ok, managed to make some progress. What I did:

1. Run chkdsk: no bad sectors or anything
2. Run SFC: no errors here as well

so, no errors but no results. Then

3. I enabled System Restore on disk C:\

and everything start working fine - I can install & uninstall programs, with one little twist. I getting bunch of small annoyances in the form that some programs refusing to work and I have to reinstall them (like logitech setpoint for mouse), or I am missing some parts, e.g. I am missing Adobe Acrobat X pdf printer driver and now I have to reinstall the whole Adobe Suite.

So, it appears that my installation cache (?) or settings (?) was damaged. Then it enabling system restore "fixed" it? But there error is still there and propagating itself. Is there some diagnostics that I can do on that?

Thanks a lot!

EDIT: Actually, let me monitor this a bit, it might be just a coincidence or something else.
My System SpecsSystem Spec
16 Apr 2012   #6

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

I don't understand, so has the c000000e boot error suddenly been fixed as well? The installation cache has nothing to do with your system failing to detect your drive. Rather, it has to be related to the drivers for your drive controller or the drive controller itself isn't compatible with the SSD drive (or is just broken). While your installations may be bugged, that would most certainly be caused by corruption of the Windows installer cache. However, how it got corrupted would probably be related to why your drive controller failed to access the boot drive.
My System SpecsSystem Spec
16 Apr 2012   #7

Windows 7 x64 Pro
 
 

Yes, it kind of works now (I still have no solution for missing Adobe pdf printer driver).

Would you be so kind as to explain the following:
"While your installations may be bugged, that would most certainly be caused by corruption of the Windows installer cache. However, how it got corrupted would probably be related to why your drive controller failed to access the boot drive."

So, can I somehow fix the installer cache now (or at least diagnose?)
My System SpecsSystem Spec
17 Apr 2012   #8

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

I don't believe I was clear on my statement. What I meant to say was, you may be able to fix the installation cache, but there is an underlying issue that caused the cache to be corrupted in the first place. Because the installation cache, while it is responsible for your installation/uninstallation issues, it could not be the cause for your c000000e errors at bootup. Rather, what is causing the c000000e errors would very well be responsible for corrupting your installation cache, which in turn would cause your programs to fail to install/uninstall properly.

If you wish to still go after the installation cache, you can use MSIZap.exe to flush your installation cache. You can obtain it by installing the Windows SDK (link in the article). Once installed, you can access MSIZap by going to the start menu then to the SDK then to the SDK command prompt and type in the proper command there. It's best to type it as followed: "msizap w" (no quotes). The 'w' argument will set it to flush Windows Installer info for all users on the PC. You may also use 'g' to flush Windows Installer data files. Be warned that these are destructive methods, and so you'll want to create a restore point prior to using msizap. There is the chance you will not be able to naturally uninstall any existing programs after this is done, which is not a good thing, hence using the restore point.

Again, I don't believe this is the fundamental problem. I have a feeling we're dealing with the plant but the tainted roots are still lingering. Given that this happens on two separate SSD drives with Windows installed, I have to point finger at your drive controller on your new mobo.
My System SpecsSystem Spec
18 Apr 2012   #9

Windows 7 x64 Pro
 
 

Thank you very much! I will keep that in mind. Drive controller might be very plausible, it is at this moment I have very little direct evidence of it malfunctioning at the first place: chkdisk repeatedly comes fine, I can copy files et. etc. (work on PC for month!) and not see any errors.

Now the good question, what could that be besides drive controller ... (hm)

Thank you so much for your help!
My System SpecsSystem Spec
18 Apr 2012   #10

Microsoft Community Contributor Award Recipient

Windows 7 64-bit
 
 

Motherboard failure as well as PSU failure are extremely difficult to diagnose without some special tools to do so. They are very spontaneous and can fail to deliver results during specific software-based hardware tests. Often when I find that when those tests come up nil despite the symptoms being present, I usually point finger at PSU or motherboard, and I'm often correct with that speculation. Because the issues were primarily based off what appeared to be drive failure, yet it was occurring on another drive too with a completely separate Windows installation, then that kinda boils it down to the drive controller.

The only software explanations for these kinds of failures would be chipset drivers, drive controller/RAID drivers, and the BIOS. If you haven't already, make sure all of those are up to date. Even go ahead and reflash the BIOS if you already have the latest version just to be sure.
My System SpecsSystem Spec
Reply

 BSOD when installing programs, error 0xc000000e




Thread Tools



Similar help and support threads for2: BSOD when installing programs, error 0xc000000e
Thread Forum
Windows 7 Boot error 0xc000000e General Discussion
BSOD: Error 0xc000000e among others. Can only access safe mode BSOD Help and Support
Lua Error when installing programs Software
Error While installing Programs Software
Installing Programs, Receiving Error! Error 1935 Software
cloning Win7 Pro gives 0xc000000e error BSOD Help and Support
Boot Error 0xc000000e BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:25 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33