Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Does Anyone Know of a Fix for the 0xc0000142 Problem

02 Sep 2009   #1
Harold76

Windows 7
 
 
Does Anyone Know of a Fix for the 0xc0000142 Problem

After my computer is inactive for a few hours and I come back to start using it again, almost always, any icon that I click on, I will get the following: a message box comes up over with the text "The application failed to initialize properly (0x0000142). Click OK to terminate the application."
If I reboot the computer, all seems to be fine until it sits inactive for a while. This is getting to be a real nuisance. I have done a lot of searching in google and so far I have not found the fix. I have seen a lot of messages where others or having the same problem. I sure hope someone in the Windows 7 forums has the fix for this. I am using Windows 7 RTM (64 bit) on an almost new Dell XPS 420 with 8 gig of ram with an intel Core 2 Quad processor.


My System SpecsSystem Spec
.

02 Sep 2009   #2
Tews

64-bit Windows 8.1 Pro
 
 

Try Systen restore to restore the comtputer to a date/time prior to when the problems began.

Also might try running sfc /scannow from the Run command to replace any damage or missing system files.
My System SpecsSystem Spec
02 Sep 2009   #3
zigzag3143

Win 8 Release candidate 8400
 
 

You must be getting BSOD's with that error code. could you go into c:\windows\minidump, zip the dum file (*.dmp) and upload it for us to see. If its not in minidump you can search for *.dmp

Ken
My System SpecsSystem Spec
.


02 Sep 2009   #4
Harold76

Windows 7
 
 
Reply concerning 0xc0000142 error

No, not getting a BSOD, only getting what I posted.
My System SpecsSystem Spec
24 Dec 2009   #5
NoSubstitute

Windows 7 Ultimate
 
 

What I've found so far and I've been looking around a LOT, since this is aproblem for me too, is this:
Error message when you call the CreateProcess function to start a process of a console application by using an account other than the current logon account in Windows Server 2003: "The application failed to initialize properly (0xc0000142
This seems to be the only valid explanation and could maybe be linked to this solution:
Unexpected behavior occurs when you run many processes on a computer that is running SQL Server

Sadly, no solutions are suggested to work with Windows 7 and currently I'm afraid to reboot my computer, in fear of running into even more severe issues.

All solutions suggested by Microsoft themselves for this issue on other OSs mention this file, Winsrv.dll, as the culprit. This reference can also be found in the kb/824422-article above, since that is listed in that particular registry value.
I will not, ever, use System Restore to fix anything on my computer, so that is never a valid solution. I should be able to fix anything on a current system, with replacing files or editing system settings. There's no telling what changes has been made since last restore point was saved and will be lost forever if I "go back".
My System SpecsSystem Spec
24 Dec 2009   #6
usasma
Microsoft MVP

 
 

MSINFO32
Please go to Start and type in "msinfo32.exe" (without the quotes) and press Enter
Save the report as an .nfo file, then zip up the .nfo file and upload/attach the .zip file with your next post.

If you're having difficulties with the format, please open an elevated (Run as administrator) Command Prompt and type "msinfo32 /nfo C:\Users\Public\Desktop\TEST.NFO\" (without the quotes) and press Enter. Then navigate to the C:\Users\Public\Desktop directory to retrieve the TEST.NFO file. If you have difficulties with making this work, please post back.
My System SpecsSystem Spec
25 Dec 2009   #7
NoSubstitute

Windows 7 Ultimate
 
 

Here's the test.nfo.

I had to shutdown my computer since it was time to go away for the Christmas celebrations. When booting again the error hasn't (yet) reccurred.

/Kim
My System SpecsSystem Spec
25 Dec 2009   #8
usasma
Microsoft MVP

 
 

No file was uploaded, please give it another go!
Thanks!
My System SpecsSystem Spec
25 Dec 2009   #9
NoSubstitute

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by usasma View Post
No file was uploaded, please give it another go!
Thanks!

I edited my post.
I had forgotten to zip it, so it was refused the first couple of times :-)
My System SpecsSystem Spec
25 Dec 2009   #10
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Someone fixed it like this but I'm not familor with the program.

In responce to this question.
Has anyone had msys working on Windows 7 64 bit version?
I'm getting "The application failed to initialize properly (0xc0000142)"
error.
I tried both 1.0.10 and 1.011 with the same result.

Alex.

Hello,
I had the same problem with Msys and Windows Seven, but found a workaround : start msys without Rxvt

msys.bat -norxvt
My System SpecsSystem Spec
Reply

 Does Anyone Know of a Fix for the 0xc0000142 Problem




Thread Tools





Similar help and support threads
Thread Forum
0xc0000142 Errors
Hi, I'm using Windows 7 Ultimate. I've been using it for some time without problems, but this morning I was unable to get on the Internet. Yesterday I'd installed an update for ZoneAlarm which I thought was probably the problem, so I uninstalled in and downloaded and installed PC Tools Firewall...
General Discussion
Saints row 4 0xc0000142
can anyone help me every time i open saints raw 4 i always ended up getting a error
Gaming
error 0xc0000142 help!
I'm getting the below error message when I try to open Outlook 2007. This only happens if the PC has been left on over night or for a long time without use. A reboot does a temp fix. The application failed to initialize properly (0xc0000142) Click OK to terminate the application
BSOD Help and Support
0xc0000142 Problem
After my computer is inactive for a few hours and I come back to start using it again, almost always, any icon that I click on, I will get the following: a message box comes up over with the text "The application failed to initialize properly (0x0000142). Click OK to terminate the application." If...
BSOD Help and Support
0XC0000142 Error
Hey there, first post. Hopefully this is the right place to place this question. Many times when I shut down my computer I get an error code: 0XC0000142 with a message about PCANUser.exe. It does not always happens, but happens maybe 75% of the time. Any idea what it could be and how I correct...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App