Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: COM Surrogate

17 Jun 2012   #1
GhostFreak

Windows 7 Home Premium x64
 
 
COM Surrogate

Okay so I got a new laptop a few days ago and whenever I go through pictures it pops up with an error that says COM Surrogate has stopped working. Any idea on how to fix this. Help would be nice! New PC: Alienware M17x R4


My System SpecsSystem Spec
17 Jun 2012   #2
writhziden

Windows 7 Home Premium 64 Bit
 
 

What antivirus are you using?

Have you installed any 3rd party codecs?

Start by going through the steps to Troubleshoot Application Conflicts by Performing a Clean Startup.
My System SpecsSystem Spec
18 Jun 2012   #3
GhostFreak

Windows 7 Home Premium x64
 
 

I have Symantec AntiVirus
No I have not installed 3rd party codecs.
My System SpecsSystem Spec
18 Jun 2012   #4
GhostFreak

Windows 7 Home Premium x64
 
 

Okay I guess the problem is fixed because I restarted my PC a few hours ago and now I haven't seen the error anymore. I think the restart fixed it.
My System SpecsSystem Spec
19 Jun 2012   #5
writhziden

Windows 7 Home Premium 64 Bit
 
 

Alright, good to see. Let us know if the problem returns or you find the problem is indeed solved.
My System SpecsSystem Spec
19 Jun 2012   #6
GhostFreak

Windows 7 Home Premium x64
 
 

Problem is back :O I guess the problem only shows up if I have picks on a device or pictures that I download from the internet.
My System SpecsSystem Spec
19 Jun 2012   #7
writhziden

Windows 7 Home Premium 64 Bit
 
 

Have you had a chance to Troubleshoot Application Conflicts by Performing a Clean Startup ?

Also, contact Symantec for steps to uninstall the software. Replace with Microsoft Security Essentials - Free Antivirus for Windows just to test.
My System SpecsSystem Spec
19 Jun 2012   #8
GhostFreak

Windows 7 Home Premium x64
 
 

I'll try.
My System SpecsSystem Spec
Reply

 COM Surrogate




Thread Tools





Similar help and support threads
Thread Forum
com surrogate error
Have used SF Diagnostic tool and Zipped files as requested. I have uninstalled photoshop as I was told by searching somewhere and few others. Followed MS instructions to no avail. All help is much appreciated, Thank you. Acer E1-571 x64 5gb ram 500gb hd. Intel HD 4000 graphics.
General Discussion
Com surrogate keeps popping up
I have a windows 7, MSI A6200 I've read posts on here about how to remove the com surrogate pop up and hopefully I didn't try everything to remove this pop up. The thing is about this pop up, it pops up ALL the time, every 5 or 10 secs. It doesn't matter if I'm looking through any pictures or...
General Discussion
Is it Normal for COM Surrogate like this ?
Is it normal for Com Surrogate to takeover all of your RAM ? i had a problem when i was opening explorer and searched for videos my computer just got hot all over, and then i tried to open the task manager when i saw my COM Surrogate was using 75% of the RAM was it normal ? can any body...
General Discussion
COM Surrogate
After doing a disk cleanup and deleting "Thumbnails" without realizing it would cause this, I have started to get the message "COM Surrogate has stopped working" a lot of the times that I try to open images (and other people who receive this error report it to happen with videos/movies as well, but...
BSOD Help and Support
COM Surrogate crashes
Ok I installed the latest Shark007 codecs which were released last week I believe and I started getting some hard lockups with the message being "COM surogate has stopped responding". When these errors happened I couldn't do anything but puch the power button because Only the mouse was movable and...
BSOD Help and Support
COM Surrogate error
I've been getting that error when opening some of my video folders when I installed a codec package. I uninstalled it, but still have the eror. Anyone know a solution to this? I'm using Windows 7 64bit.
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App