Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BDOD on boot up Windows 7 x64 (crashes when the Windows logo appears)

28 Jun 2012   #1

Windows 7 Ultimate 64bit
BDOD on boot up Windows 7 x64 (crashes when the Windows logo appears)

Hi there,

This thread is not much of question but rather an answer to anyone who encounters a similar problem.
Therefore, I do not know if this is the best place to post this. You are welcome to move this thread.

Here was my problem:
I had recently formatted my PC and reinstalled Windows 7 Ultimate 64bit and every time I would start my computer, generally after it spent the night switched off, the machine would hang while Windows loads, as the logo would start to appear.
The computer would hang for 2 seconds or so, then I would get a BSOD with varying error messages and codes.

My computer would reboot on its own but keep crashing until it eventually hangs generally as Windows is loading forcing me to restart manually.
After enough restarts (and BSODs), the computer would manage to load Windows and get me to the welcome screen. I could log on fine and would not get BSODs under Windows while I was using it. The crashes happened solely while Windows was loading during boot up.

My system consists of the following:
- 64GB SSD drive on which I have my OS installed.
- 2x 1TB HDDs set up in RAID 0
- 2TB HDD used for backup
- Intel i7 930 processor
- 6GB of DDR3 RAM
- AMD 6800 HD Graphics card
- MSI X58 pro-e motherboard

I formatted the PC and reinstalled Windows about 6 times from different images of Windows, yet the problem still persisted.

I checked my drivers and downloaded the latest for each components and nothing would do.
After nearly a month of research and trial and error and with the help of a friend, I went into the process of disabling most of my devices from Safe Mode. The machine would boot without problems into Safe Mode but also BSOD when trying to run Windows Recovery during boot up.

I eventually pin pointed the cause of these crashes to be the Communication Port. Once I disabled it, the computer would not crash anymore during boot up and everything worked just fine.

Isolating this problem took me a while since there were several other changes that had been done (such as a BIOS update which was done on the first reinstall or my RAID 0 config) that could have possibly influenced the computer to behave that way.

Anyway, I have finally fixed this problem and wanted to share it so that if anyone runs into something similar, this post will hopefully help you solve your problem much faster.
The article that helped me to resolve my problem was this one:
Windows 7 Blue Screen Of Death Loop, Cannot log onto my Primary Hard - Microsoft Answers
The instructions in the first answer helped me pin point my problem.

That's all I wanted to share. I hope it helps whoever is unfortunate to run into the same problem.

My System SpecsSystem Spec

28 Jun 2012   #2

Windows 7 Home Premium 64 Bit

Thank you very much! That is a very detailed post and will help many experiencing similar problems. Nice job!
My System SpecsSystem Spec
28 Jun 2012   #3

Windows 7 Ultimate 64bit

Thanks writhziden. I struggled long enough with this so it was only fair of me to share the solution
My System SpecsSystem Spec


 BDOD on boot up Windows 7 x64 (crashes when the Windows logo appears)

Thread Tools

Similar help and support threads
Thread Forum
Computer crashes after the Windows sign appears during startup
About an hour ago, I took the side panel off my computer to get rid of some dust inside the case. Once I had finished up, I started up the computer again to find the message 'reboot with proper start up device' or something a long those lines. I proceeded to put the disk of Windows 7 into the disk...
Hardware & Devices
Computer restarts as soon as windows logo appears in a loop
I have a custom build from about 5 years ago and when i boot it up i press f1 to continue then it gives me the option to repair or resume windows as soon as the red windows dot appears it reboots and this happens over and over. I can provide more details if needed, i also tried my laptop hd which...
Installation & Setup
Acer logo appears 2 times then starts windows.
Hi to all Eight forums. I have recently bought an Acer S670MG or M679G desktop computer with the following specs. Intel core 2 due 3.1ghz. 6mb L2 cache. 6gb ddr3 ram at 1066mhz bus Nvidia Geforce 9800GT 512mb/256bits external graphic card. 1tb SATA WD hdd. and I have facing a problem that...
Hardware & Devices
BSOD, Crashes after the 'Starting windows' logo, Error 0x000000F4
Hello, Here's the full story, On Tuesday 9 April i was running Toolwiz Timefreeze (A program that freeze your computer and doesn't save anything while its running its more like a portable DeepFreeze) So while i was running it a windows update came up, so i said it won't be saved, but when i...
BSOD Help and Support
Windows 7 crashes after windows logo just before the login screen.
Greetings guys! this is my first topic so please be gentle :) alright about a week ago my pc kept rebooting himself, tried to fix it by doing virus scans, i did have a nasty worm virus but that was from MSN (worm) anyway since a few days my pc wont boot in W7 at all, so i went to my mate and...
BSOD Help and Support
Windows logo no longer appears during startup . .
i've had my computer for about 2 months now. running windows 7 premium and recently when i boot up my computer, after it displays the bios menu, it skips the windows logo screen and goes straight to the welcome screen. i havent noticed any issues other then this however i did notice strange noises...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:47.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App