Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: BSOD with sleep/resume

06 Jul 2012   #1

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
BSOD with sleep/resume

Hello, first post, need some help debugging a homebuilt system. Since built have had trouble with sleep/resume crashes. Tried updating drivers, several settings in device manager, and BIOS changes to no avail. In the end, I nuked the hard drive and did a complete re-install from the ground up. Seemed to go ok initially, but have again begun having crashes around the sleep/resume times. The computer is my wife's machine, built exclusively for photo editing. Windows 7 x64 Home Premium. Built Jan '11, last OS install about 2-3 months ago. Thanks so much for your help!

My System SpecsSystem Spec
.

06 Jul 2012   #2

Windows 8.1 Pro x64
 
 

Welcome to SevenForums.

Your dump files indicate a hardware error, the system couldn't initialize the HAL (STOP 0x0000005C: HAL_INITIALIZATION_FAILED).
Usual causes: Hardware, file system, boot corruption.

Check the connections to your hard drive (both power and data), make sure that your PSU is powerful enough to drive everything in the system. Make sure that the cards inside the case are properly seated. If you've added things recently - remove them. Ensure your Windows Updates are up to date. Please scan for malware with Malwarebytes

Run those tests:
HDD Diagnostic: HD Diagnostic / Disk Check
Memory Diagnostic: RAM - Test with Memtest86+
System File Scan: SFC /SCANNOW Command - System File Checker

Post back with your results.

There were also a lot of unrecognized drivers which were being loaded on your system. This can either mean that you're using an old (possibly an incompatible [Chinese?] program/driver) or that the system has some Malware infection(s).
Code:
Unknown_Module_fffff880`02800000        fffff880`02800000    fffff880`028c9000    0x000c9000    0x4ce793ce    20/11/2010 13:24:30                
Unknown_Module_fffff880`02c00000        fffff880`02c00000    fffff880`02c21000    0x00021000    0x4ce7a86f    20/11/2010 14:52:31                
Unknown_Module_fffff880`02d41000        fffff880`02d41000    fffff880`02d4d000    0x0000c000    0x4a5bcaa1    14/07/2009 04:00:33                
Unknown_Module_fffff880`02d4d000        fffff880`02d4d000    fffff880`02d5d000    0x00010000    0x4ce7a3ed    20/11/2010 14:33:17                
Unknown_Module_fffff880`02d97000        fffff880`02d97000    fffff880`02da3000    0x0000c000    0x4a5bccd8    14/07/2009 04:10:00                
Unknown_Module_fffff880`02dd2000        fffff880`02dd2000    fffff880`02ded000    0x0001b000    0x4a5bcce9    14/07/2009 04:10:17                
Unknown_Module_fffff880`04743000        fffff880`04743000    fffff880`04755000    0x00012000    0x4ce7a844    20/11/2010 14:51:48                
Unknown_Module_fffff880`05ef4000        fffff880`05ef4000    fffff880`05f16000    0x00022000    0x4a5bd8e5    14/07/2009 05:01:25                
Unknown_Module_fffff880`064b3000        fffff880`064b3000    fffff880`0654b000    0x00098000    0x4dba2b1e    29/04/2011 07:06:06                
Unknown_Module_fffff880`06583000        fffff880`06583000    fffff880`065b4000    0x00031000    0x4ce7a654    20/11/2010 14:43:32                
Unknown_Module_fffff880`065de000        fffff880`065de000    fffff880`065e9000    0x0000b000    0x4ce7a416    20/11/2010 14:33:58                
Unknown_Module_fffff880`065e9000        fffff880`065e9000    fffff880`065fc000    0x00013000    0x4a5bc18f    14/07/2009 03:21:51
င∄ࠄ耀        fffff880`04755000    fffff880`047be000    0x00069000    0x4dba2b0a    29/04/2011 07:05:46                
澺齟믽�侧὏䯿ﹷ翿﻽㛸絇�轗쿿㷟�빻껿콶뽿㳿軹ﵿ⽿쿻        fffff880`01425000    fffff880`01432000    0x0000d000    0x4ce7933e    20/11/2010 13:22:06                
退            fffff880`065d2000    fffff880`065de000    0x0000c000    0x4a5bc113    14/07/2009 03:19:47                
뿻닺ﵟ燵刺矧ッ粒￶竿뿛ᾟ￿﾿鷿绱←盽烞꿯폯﷾콷㟾ᕵﯽ㷵��        fffff880`05f1c000    fffff880`05f72000    0x00056000    0x4eddfb1b    06/12/2011 15:23:07                
쨾齏跿쯿㟿缿罟㿿㾿쫓﫞�痿￿ﵷ埿叶崟N콿俛￿﷿﫹໦㿿￧￿�彿        fffff880`03aed000    fffff880`03b76000    0x00089000    0x4efa9418    28/12/2011 07:59:20                
ソ翽㏹ﳿ㟿�矿ソ翟鶿ꝿ︿뿿痢갳ﯣ￷㫿쿿￿濳ퟗ�彻⦅湏㦯뿖翧�ﹿ훾移        fffff880`03b76000    fffff880`03bbb000    0x00045000    0x4ce79386    20/11/2010 13:23:18
Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

HAL_INITIALIZATION_FAILED (5c)
Arguments:
Arg1: 0000000000002001
Arg2: 0000000000000002
Arg3: 0000000000000004
Arg4: 0000000000000000

Debugging Details:
------------------


CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x5C

PROCESS_NAME:  System

CURRENT_IRQL:  f

LAST_CONTROL_TRANSFER:  from fffff80002c43f9a to fffff80002cd71c0

STACK_TEXT:  
fffff880`09696698 fffff800`02c43f9a : 00000000`0000005c 00000000`00002001 00000000`00000002 00000000`00000004 : nt!KeBugCheckEx
fffff880`096966a0 fffff800`02c419e0 : 00000000`00000004 00000000`00003705 00000000`40000294 00000000`00000001 : hal!HalpSetInterruptControllerWakeupState+0x1a7
fffff880`096966f0 fffff800`02c151ed : ffffffff`ffd0d000 fffff800`02f11670 fffff800`02f11670 00000000`00000000 : hal!HalpAcpiPostSleep+0x134
fffff880`09696720 fffff800`02f16ca9 : 00000000`00003705 00000000`00000000 00000000`00000000 fffff880`096968c0 : hal!HaliAcpiSleep+0x2de
fffff880`09696790 fffff800`02f16d4f : 00000000`00000000 fffffa80`09985230 fffff800`02e7ec60 00000000`02f12880 : nt!PopHandleNextState+0x12a
fffff880`096967e0 fffff800`02f1c3d0 : 00000000`00000005 00000000`00000001 00000000`00000000 fffff880`09696960 : nt!PopIssueNextState+0x1f
fffff880`09696810 fffff800`02f1c834 : 00000000`00000000 00000000`0021ae00 00000000`00000000 00000000`00000001 : nt!PopInvokeSystemStateHandler+0x3c0
fffff880`096969d0 fffff800`02f18684 : ffffffff`ffffffff ffffffff`ffffffff 00000000`0021ae00 00000000`00000000 : nt!PopEndMirroring+0x84
fffff880`09696aa0 fffff800`02f1cbb5 : fffff880`09696bc0 fffff880`00000008 00000000`00000000 fffffa80`00000008 : nt!MmDuplicateMemory+0xb64
fffff880`09696b90 fffff800`02f6de6a : fffffa80`0b73ca00 fffffa80`0806e180 00000000`00020000 fffff8a0`044676b0 : nt!PopTransitionToSleep+0xd5
fffff880`09696c00 fffff800`02cc7ec6 : fffff800`02e49e80 fffffa80`0b73ca00 fffff800`02e57cc0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`09696c40 00000000`00000000 : fffff880`09697000 fffff880`09691000 fffff880`096967e0 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt!PopHandleNextState+12a
fffff800`02f16ca9 8be8            mov     ebp,eax

SYMBOL_STACK_INDEX:  4

SYMBOL_NAME:  nt!PopHandleNextState+12a

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4fa390f3

FAILURE_BUCKET_ID:  X64_0x5C_HAL_FAILED_TO_RESTART_PROCESSOR_AFTER_SLEEP_nt!PopHandleNextState+12a

BUCKET_ID:  X64_0x5C_HAL_FAILED_TO_RESTART_PROCESSOR_AFTER_SLEEP_nt!PopHandleNextState+12a

Followup: MachineOwner
---------
My System SpecsSystem Spec
07 Jul 2012   #3

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Thanks for your quick reply. I checked the hardware. The power supply is a 600 W OC PSU, I think it should be adequate for the task in this box. All ram and network card and other connections look okay. I'll run those checks and post back in a bit thanks again.
My System SpecsSystem Spec
.


08 Jul 2012   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Thanks again for your help, also, putting the links in your post made it so much easier to find and perform the tests! Testing completed this morning.

Checked hardware connections in box without finding any loose connections. Only have the one PCI card for network, one hard drive, one DVD-ROM drive, PSU, and case connections.

-Malwarebytes found no problems. Have been using MS Security Essentials for antivirus - first program put on the computer after build.

-HDD
Check Disc found no errors.
SeaTools (Seagate HDD) long test found no errors.

-MemTest - 8 passes completed with no errors.

-SFC - sfc /verifyonly run - no integrity violations found.

Where do we go from here?
My suspicion has always been that a driver issue was the most likely cause. When I wiped the HDD and reloaded the entire system last, I downloaded all the drivers direct from the various manufacturers (ASUS, Gigabyte). How can we go about checking the drivers?

Thanks again!
My System SpecsSystem Spec
08 Jul 2012   #5

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by barndg00 View Post
Thanks again for your help, also, putting the links in your post made it so much easier to find and perform the tests! Testing completed this morning.

Checked hardware connections in box without finding any loose connections. Only have the one PCI card for network, one hard drive, one DVD-ROM drive, PSU, and case connections.

-Malwarebytes found no problems. Have been using MS Security Essentials for antivirus - first program put on the computer after build.

-HDD
Check Disc found no errors.
SeaTools (Seagate HDD) long test found no errors.

-MemTest - 8 passes completed with no errors.

-SFC - sfc /verifyonly run - no integrity violations found.

Where do we go from here?
My suspicion has always been that a driver issue was the most likely cause. When I wiped the HDD and reloaded the entire system last, I downloaded all the drivers direct from the various manufacturers (ASUS, Gigabyte). How can we go about checking the drivers?

Thanks again!
The drivers wouldn't post an problems if they're up-to-date. However obsolete drivers may cause issues. Ensure that you download & install the latest versions.
You can check the drivers installed on your system by opening a Command Prompt and by entering the "driverquery' command.
My System SpecsSystem Spec
08 Jul 2012   #6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Ok I did the driverquery command, didn't realize there were so many drivers. I can't get it to copy and paste the list here. Most are dated 2009+, but there are a few from 2006 listed. How should I go about finding and attempting to update them? Any idea which are likely causative?
My System SpecsSystem Spec
08 Jul 2012   #7

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I went through Device Manager to try and find what were the old drivers, the 2006 drivers are all dated 6/21/2006, are from Microsoft, and cover a bunch of processors, discs, USB stuff. I've copied their version numbers below. Is this any help? The MS website does not states my drivers need updating, but I'm not certain how accurate that is.

6.1.7601.17577 - USB Mass Storage device + others
6.1.7600.16385 - ACPI x64 based PC + others
6.1.7601.17514 - ASUS DRW-24B1ST aATA device +many others
also
6.1.7601.17514 same number but dated 11/19/2010 for the High Definition Audio Controller.
6.1.7601.17586 - USB Root Hub

Thanks!
My System SpecsSystem Spec
08 Jul 2012   #8

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Also, checked again the Gigabyte website for updated drivers, there are only a few there, copied below.


Audio Version
Realtek Function driver for Realtek Azalia audio chip (Including Microsoft UAA Driver in English edition) 5.10.0.6554 104.11 MB 2012/03/06
Chipset
Intel Management Engine Interface 7.1.20.1119 6.20 MB 2011/11/15
Intel INF installation 9.2.0.1030 2.43 MB 2011/09/19

LAN
Realtek LAN Driver 7.049.0927.2011 3.48 MB 2012/03/21
Realtek Ethernet Diagnostic Utility 2.0.1.6 3.83 MB 2010/12/14

SATA RAID Version
Intel SATA Preinstall driver 10.6.0.1002 0.39 MB 2011/06/22

Intel® Rapid Storage Technology 10.6.0.1002 10.54 MB 2011/06/22

USB 3.0
NEC USB 3.0 Driver 2.0.30.0 5.61 MB 2010/12/21

VGA
Intel VGA Driver 15.26.1.64.2618 87.66 MB 2012/02/22
My System SpecsSystem Spec
08 Jul 2012   #9

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by barndg00 View Post
I went through Device Manager to try and find what were the old drivers, the 2006 drivers are all dated 6/21/2006, are from Microsoft, and cover a bunch of processors, discs, USB stuff. I've copied their version numbers below. Is this any help? The MS website does not states my drivers need updating, but I'm not certain how accurate that is.

6.1.7601.17577 - USB Mass Storage device + others
6.1.7600.16385 - ACPI x64 based PC + others
6.1.7601.17514 - ASUS DRW-24B1ST aATA device +many others
also
6.1.7601.17514 same number but dated 11/19/2010 for the High Definition Audio Controller.
6.1.7601.17586 - USB Root Hub

Thanks!
Those drivers don't require updating since they're system drivers. Only 3rd party drivers usually need to be updated especially the graphics driver. Everything driver related looks fine on your system. The issue lies elsewhere, I'm more inclined on the possibility of a hardware problem.

You should test the CPU, Run Prime 95 to test your CPU. Carefully the instructions in this tutorial: CPU - Stress Test with Prime95. Run 3 separate tests, one on each of the settings (Blend, Small FFTs, Large FFTs). Post back with your results.
Note that this test may overheat the CPU, ensure proper cooling.

Post back with your results.
My System SpecsSystem Spec
08 Jul 2012   #10

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Ran all three tests till it said passed on all three, no errors, no warnings. Max temp seen was 74 C.
My System SpecsSystem Spec
Reply

 BSOD with sleep/resume





Thread Tools



Similar help and support threads for2: BSOD with sleep/resume
Thread Forum
Solved BSOD, 0xA, random and at resume from sleep, ntkrnlmp.exe BSOD Help and Support
BSOD x0000001E on resume from S3 Standby/Sleep BSOD Help and Support
Sleep resume problems - Slow / black screen upon resume General Discussion
Solved BSOD on resume from sleep BSOD Help and Support
BSOD While trying to resume from sleep mode. BSOD Help and Support
BSOD after resume from sleep BSOD Help and Support
W7-64 resume sleep BSOD BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:00 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33