Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: atikmpag.sys Causing BSOD


02 Sep 2012   #1

Windows 7 Home Premium 64 Bit
 
 
atikmpag.sys Causing BSOD

I am getting pretty frequent BSODs since I rebuilt my computer because of new hardware about a week ago. New mobo, added another gpu and a new cpu. which are listed in my computer specs. I have run the microsoft debug utility and found out it was caused by atikmpag.sys. It hasn't happened in a little while, but it will likely happen again, so help would be appreciated. The SF Diagnostic Tool folder is attached. I had originally thought this to be an issue with the fuel.service.exe because of the event viewer errors occurring around the time of the crash. I have disabled fuel service in msconfig and it hasn't crashed since I did this last night, but haven't been on computer much since then.




Attachment 229644

My System SpecsSystem Spec
.

02 Sep 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64Bit
 
 

Welcome to the forum.

BSOD Analyze

Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 116, {fffffa800b7de010, fffff88009c0745c, 0, 2}

Unable to load image \SystemRoot\system32\DRIVERS\atikmpag.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for atikmpag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys
Probably caused by : atikmpag.sys ( atikmpag+745c )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

VIDEO_TDR_FAILURE (116)
Attempt to reset the display driver and recover from timeout failed.
Arguments:
Arg1: fffffa800b7de010, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: fffff88009c0745c, The pointer into responsible device driver module (e.g. owner tag).
Arg3: 0000000000000000, Optional error code (NTSTATUS) of the last failed operation.
Arg4: 0000000000000002, Optional internal context dependent data.

Debugging Details:
------------------


FAULTING_IP: 
atikmpag+745c
fffff880`09c0745c 4883ec28        sub     rsp,28h

DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_TDR_FAULT

CUSTOMER_CRASH_COUNT:  1

BUGCHECK_STR:  0x116

PROCESS_NAME:  System

CURRENT_IRQL:  0

STACK_TEXT:  
fffff880`0c6469c8 fffff880`0565d000 : 00000000`00000116 fffffa80`0b7de010 fffff880`09c0745c 00000000`00000000 : nt!KeBugCheckEx
fffff880`0c6469d0 fffff880`0565cd0a : fffff880`09c0745c fffffa80`0b7de010 fffffa80`0acd8010 fffffa80`0bcbe010 : dxgkrnl!TdrBugcheckOnTimeout+0xec
fffff880`0c646a10 fffff880`0612ff07 : fffffa80`0b7de010 00000000`00000000 fffffa80`0acd8010 fffffa80`0bcbe010 : dxgkrnl!TdrIsRecoveryRequired+0x1a2
fffff880`0c646a40 fffff880`06159b75 : 00000000`ffffffff 00000000`00020f97 00000000`00000000 00000000`00000002 : dxgmms1!VidSchiReportHwHang+0x40b
fffff880`0c646b20 fffff880`061582bb : 00000000`00000102 00000000`00000000 00000000`00020f97 00000000`00000000 : dxgmms1!VidSchiCheckHwProgress+0x71
fffff880`0c646b50 fffff880`0612b2c6 : ffffffff`ff676980 fffffa80`0bcbe010 00000000`00000000 00000000`00000000 : dxgmms1!VidSchiWaitForSchedulerEvents+0x1fb
fffff880`0c646bf0 fffff880`06157e7a : 00000000`00000000 fffffa80`0acd8010 00000000`00000080 fffffa80`0bcbe010 : dxgmms1!VidSchiScheduleCommandToRun+0x1da
fffff880`0c646d00 fffff800`03160e6a : fffffa80`0bef8c10 fffffa80`094acb50 fffffa80`06d0c040 fffffa80`08a99a60 : dxgmms1!VidSchiWorkerThread+0xba
fffff880`0c646d40 fffff800`02ebaec6 : fffff800`0303ce80 fffffa80`094acb50 fffff800`0304acc0 fffff880`03f28620 : nt!PspSystemThreadStartup+0x5a
fffff880`0c646d80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND:  .bugcheck ; kb

FOLLOWUP_IP: 
atikmpag+745c
fffff880`09c0745c 4883ec28        sub     rsp,28h

SYMBOL_NAME:  atikmpag+745c

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: atikmpag

IMAGE_NAME:  atikmpag.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4dae3558

FAILURE_BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys

BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys

Followup: MachineOwner
---------

1: kd> lmvm atikmpag
start             end                 module name
fffff880`09c00000 fffff880`09c50000   atikmpag T (no symbols)           
    Loaded symbol image file: atikmpag.sys
    Image path: \SystemRoot\system32\DRIVERS\atikmpag.sys
    Image name: atikmpag.sys
    Timestamp:        Wed Apr 20 07:22:32 2011 (4DAE3558)
    CheckSum:         00050398
    ImageSize:        00050000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
1: kd> lmvm atikmpag
start             end                 module name
fffff880`09c00000 fffff880`09c50000   atikmpag T (no symbols)           
    Loaded symbol image file: atikmpag.sys
    Image path: \SystemRoot\system32\DRIVERS\atikmpag.sys
    Image name: atikmpag.sys
    Timestamp:        Wed Apr 20 07:22:32 2011 (4DAE3558)
    CheckSum:         00050398
    ImageSize:        00050000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Get the latest drivers for your graphics card.

Source | atikmpag.sys | ATI Video driver (remove the Catalyst Control Center and only install the Display Driver) | AMD Support & Drivers

Latest drivers also for -> Source | RzSynapse.sys | Razer Synapse Engine/Razer Naga |Razer Support

Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffff8a000c9d000, 0, fffff88005c09b31, 0}

Unable to load image \SystemRoot\system32\DRIVERS\RzSynapse.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for RzSynapse.sys
*** ERROR: Module load completed but symbols could not be loaded for RzSynapse.sys

Could not read faulting driver name
Probably caused by : RzSynapse.sys ( RzSynapse+9b31 )

Followup: MachineOwner
---------

2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: fffff8a000c9d000, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff88005c09b31, If non-zero, the instruction address which referenced the bad memory
	address.
Arg4: 0000000000000000, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003105100
 fffff8a000c9d000 

FAULTING_IP: 
RzSynapse+9b31
fffff880`05c09b31 0fb74220        movzx   eax,word ptr [rdx+20h]

MM_INTERNAL_CODE:  0

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  System

CURRENT_IRQL:  0

TRAP_FRAME:  fffff880031765b0 -- (.trap 0xfffff880031765b0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ffff000006d5e30d rbx=0000000000000000 rcx=0000057ff7516698
rdx=fffff8a000c9cfe0 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88005c09b31 rsp=fffff88003176740 rbp=0000000000000048
 r8=0000000000000000  r9=000000000000100a r10=fffff80002e57000
r11=fffff880031767e8 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
RzSynapse+0x9b31:
fffff880`05c09b31 0fb74220        movzx   eax,word ptr [rdx+20h] ds:7aa0:fffff8a0`00c9d000=????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002e7e54c to fffff80002ed61c0

STACK_TEXT:  
fffff880`03176448 fffff800`02e7e54c : 00000000`00000050 fffff8a0`00c9d000 00000000`00000000 fffff880`031765b0 : nt!KeBugCheckEx
fffff880`03176450 fffff800`02ed42ee : 00000000`00000000 fffff8a0`00c9d000 fffff880`00000000 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x456df
fffff880`031765b0 fffff880`05c09b31 : 00000000`00000000 00000000`000007ff fffffa80`08b27aa0 fffff880`00f54789 : nt!KiPageFault+0x16e
fffff880`03176740 00000000`00000000 : 00000000`000007ff fffffa80`08b27aa0 fffff880`00f54789 fffffa80`08b27a00 : RzSynapse+0x9b31


STACK_COMMAND:  kb

FOLLOWUP_IP: 
RzSynapse+9b31
fffff880`05c09b31 0fb74220        movzx   eax,word ptr [rdx+20h]

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  RzSynapse+9b31

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: RzSynapse

IMAGE_NAME:  RzSynapse.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4e941b13

FAILURE_BUCKET_ID:  X64_0x50_RzSynapse+9b31

BUCKET_ID:  X64_0x50_RzSynapse+9b31

Followup: MachineOwner
---------

2: kd> lmvm RzSynapse
start             end                 module name
fffff880`05c00000 fffff880`05c2f000   RzSynapse T (no symbols)           
    Loaded symbol image file: RzSynapse.sys
    Image path: \SystemRoot\system32\DRIVERS\RzSynapse.sys
    Image name: RzSynapse.sys
    Timestamp:        Tue Oct 11 16:31:47 2011 (4E941B13)
    CheckSum:         0002C4DC
    ImageSize:        0002F000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Remember to uninstall the older drivers completely before installing newer ones.

Do the above and keep us posted.
My System SpecsSystem Spec
02 Sep 2012   #3

Windows 7 Home Premium 64 Bit
 
 

I am not sure how to install the display drivers by themselves. I tried to by installing catalyst download manager and installing through the driver install file where it extracted to. It did not seem to change anything. I have also looked up more on the issue and have heard it could either be a problem with the current version of ccc or a problem with a faulty gpu.
My System SpecsSystem Spec
.


03 Sep 2012   #4

Windows 7 Home Premium 64 Bit
 
 

I also seem to notice it only happens when in an internet browser... At least from what I remember. Whether I'm alt-tabbing from a game into a browser or just have a browser up.
My System SpecsSystem Spec
03 Sep 2012   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64Bit
 
 

Do this:
  • Click on the Start .
  • Type Device Manager in the Search box.
  • Expand the items under Display Adapters.
  • Post a screenshot of it.
Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
03 Sep 2012   #6

Windows 7 Home Premium 64 Bit
 
 

Not sure if you mean with or without catalyst, this is with.
My System SpecsSystem Spec
03 Sep 2012   #7

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64Bit
 
 

Thanks for the snip.

What browser are you usually using?
My System SpecsSystem Spec
03 Sep 2012   #8

Windows 7 Home Premium 64 Bit
 
 

I was using firefox, but it always crashed, so I'm using chrome now.
My System SpecsSystem Spec
03 Sep 2012   #9

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64Bit
 
 

Is Chrome stable? Any lags/crashes?
Do you have the latest versions of adobe flash player IE & Non IE installed?

If not, get them from here:
http://www.filehippo.com/download_flashplayer_ie/
Scroll down a little and you'll see all the versions/os.

Do this on firefox:

[1]Click on the firefox tab
[2]Click on Options Options
[3]Go to the Advanced tab
[4]Unselect Use hardware accelerations when available
[5]Restart firefox. See if the problem goes.

Post back.
My System SpecsSystem Spec
03 Sep 2012   #10

Windows 7 Home Premium 64 Bit
 
 

It seems to work now. I have been going to different, pages, testing video and ran a web browser bench mark to stress it. Also, I have the latest flash player.
My System SpecsSystem Spec
Reply

 atikmpag.sys Causing BSOD




Thread Tools



Similar help and support threads for2: atikmpag.sys Causing BSOD
Thread Forum
Full Screen applications causing Atikmpag.sys BSOD - HD Radeon 5970 BSOD Help and Support
BSOD ATIkmpag.sys BSOD Help and Support
BSOD about atikmpag.sys BSOD Help and Support
BSOD 116 atikmpag.sys BSOD Help and Support
BSOD atikmpag.sys BSOD Help and Support
Atikmpag.sys BSOD BSOD Help and Support
ATIKMPAG.sys BSOD BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33