Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Boot or repair - NETIO.SYS missing/corrupt

03 Oct 2012   #1
rgrommel

Windows 7 Home Premium 64bit
 
 
Can't Boot or repair - NETIO.SYS missing/corrupt

I returned home today to find my computer off and not able to boot. My wife said all she had done was web browsing and then sleeping the computer. At this time the computer tried to Auto-repair the startup but would cyclically fail (indicating an issue with NETIO.SYS). I performed the following steps:

1. Did a scandisk with repair options that recovered some files on the boot SSD (all future scans have been clean)
2. ran bootsect /nt60 SYS /mbr bootsect with a few more options including ALL
3. Tried to use windows Automatic Startup Repair and still had cyclic failures and got worried that perhaps there was a virus.
4. Re-flashed the BIOS with an updated BIOS
5. Ran Avira from a boot CD, scanned for viruses, and only things that turned up were a java virus in a random file or patch. Seemed unrelated to any of the problems.
6. Ran bootrec to restore the MBR
7. All throughout this process tried the windows Startup Repair with no luck

Now instead of automatically going the Startup Repair it tries immediately displays a Windows failed to start problem. With NETIO.SYS and a status of 0xc000098 (Windows failed to load because a required file is missing, or corrupt). I don't have a recent enough system restore point to recover from. I am desperately trying not to do a full re-install to preserve installed program data. Startup Repair from DVD of course still fails with a detailed signature of: StartupRepairOffline - AutoFailover (sig5) - CorruptFile (sig7).

System info:
MB: Asus P6T SE
OS: Windows 7 Home Premium - 64bit
HD: Intel 80GB SSD for boot, secondary 1.5TB data drive

Any thoughts?

Thanks,
Robert


My System SpecsSystem Spec
.
03 Oct 2012   #2
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Welcome aboard, Robert.
Can you post it following the Blue Screen of Death (BSOD) Posting Instructions so that we may obtain the necessary information to help you here?
My System SpecsSystem Spec
03 Oct 2012   #3
rgrommel

Windows 7 Home Premium 64bit
 
 

The computer is not getting to a BSOD. It's not loading enough of the OS on boot to get a memory dump, and since I can't start the OS in safe mode or any other way I cannot install or run SF_Diagnostic_Tool. I'd love to give more useful information, but I'm not sure how. The only thing I can do is get to a command prompt through the 'Repair your computer' option of the Windows 7 Install DVD. Any thoughts?
My System SpecsSystem Spec
.

03 Oct 2012   #4
x BlueRobot

 

Clean Reinstall - Factory OEM Windows 7

Seems like the only option to me :/

Hope this helps,

Harry
My System SpecsSystem Spec
03 Oct 2012   #5
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Quote   Quote: Originally Posted by rgrommel View Post
T The only thing I can do is get to a command prompt through the 'Repair your computer' option of the Windows 7 Install DVD. Any thoughts?
Good news. There's hope.

Follow the both and let us know the results. There should be something positive.
My System SpecsSystem Spec
03 Oct 2012   #6
rgrommel

Windows 7 Home Premium 64bit
 
 

Thanks for the help so far.

Well I still have hope. SFC /SCANNOW seemed like it could help, but it unfortunately will not run. I have to run from the Command Prompt via booting off the Windows 7 Install Disc. I am running:
> SFC /scannow /offbootdir=e:\ /offwindir=c:\windows

It starts saying: Beginning system scan. This process will take some time.
Then in a few seconds it fails with the following message: Windows Resource Protection could not perform the requested operation.

Windows Defender Offline is failing with an Application Error in OfflineScannerShell.exe. (it was failing the same way earlier too btw)
My System SpecsSystem Spec
03 Oct 2012   #7
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

In this situation, I would suggest you to copy your user data elsewhere other than C drive. Preferably externally.
Copy & Paste - in Windows Recovery Console

Then perform a clean install.
Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec
04 Oct 2012   #8
x BlueRobot

 

Quote   Quote: Originally Posted by Arc View Post
In this situation, I would suggest you to copy your user data elsewhere other than C drive. Preferably externally.
Copy & Paste - in Windows Recovery Console

Then perform a clean install.
Clean Reinstall - Factory OEM Windows 7
I agree with you Arc (:
My System SpecsSystem Spec
07 Sep 2013   #9
pmshah

windows 7
 
 

2 days ago I started having the same problem with x64 Win 7 Ultimate. I would get the netio.sys BSOD within 5 to 10 minutes of booting.

I have 3 different versions of Windows installed on my pc and depending on the need I boot into the required one with boot manager. Only Win 8 would run without netio.sys BSOD. Then I read somewhere about IDM and various flavours of antivirus. Then I realised that I had upgraded IDM from version 6.17.5 to 6.17.8 on 2 of my other installations. I managed to revert to the older version and rebooted the system. Lo and behold no more problems.

Just thought my experience might come in handy for some person having similar problems.
My System SpecsSystem Spec
07 Sep 2013   #10
x BlueRobot

 

Please start your own thread here - BSOD Help and Support - Windows 7 Help Forums
My System SpecsSystem Spec
Reply

 Can't Boot or repair - NETIO.SYS missing/corrupt




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
winload.efi missing or corrupt error when trying to use startup repair
Hi, this is my first thread post. This morning my laptop worked fine and I was browsing around the net when my desktop decided that it was high time it froze. So I did a hard reset as I have done many times before on many different computers. Only when I rebooted, my system shut itself down...
BSOD Help and Support
Corrupt partition, can't boot, Startup Repair loop, tried chkdsk
Recently, my computer had a few files that were "corrupted and unreadable" and upon restarting or powering on the PC, it would run chkdsk before booting to Windows. It failed a few times, but once I luckily managed to get it to boot after running Startup Repair for the first time. This was when I...
BSOD Help and Support
Boot corrupt and unreadable, repair/re-install of Windows fails
It's my daughter's computer. A little e-Machine, 250G HD, Windows 7 32-bit on it. Out of nowhere her computer wouldn't boot up. I can get it to try to boot using the Windows disk, it gets so far, and then the repair fails saying: The file or directory C:/Boot is corrupt and unreadable. Please...
Hardware & Devices
sp1 w7 update,boot error ntkrlstaforce.exe corrupt,startup repair fail
dell inspiron 1525 w7 ultimate 32bit after sp1 install the file c>windows>system32>ntkrlstaforce.exe is curropted i tried everything\ system restore tried to find the file in back up image of the windows startup repaire tried to get the file from other windows machines tried some doc...
BSOD Help and Support
Win 7 boot files missing or corrupt
I have an Advent Roma 2001 configured, in PC World style, with a "recovery partition" alongside the system partition and, after resolving a hard disk problem, I found that the machine would not start/boot Windows 7. clearly some necessary files are missing or corrupted, but the normal system...
Performance & Maintenance
windows 7 boot loader missing/corrupt
I recently Uninstalled my Ubuntu 9.10 partition from my 500gb IDE hard drive, and thought nothing of formatting the partition and setting it up as a new windows drive. But, out of my own forgetfulness, i forgot that in rder to dual boot windows 7 with ubuntu, you Have to install the GRUB boot...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App