Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird Pixels that lead to random BSoD's


28 Nov 2012   #1

Windows 7 Ultimate x64
 
 
Weird Pixels that lead to random BSoD's

Hello, I have had this issue for a couple months now and I still cannot figure out the cause. I believe it to be hardware related but cannot get error returns from any program I've tested with, so is it software...?

I can play games that run direct x in full screen and never see an issue, never encounter a crash or BSoD, never see artifacts.

If I browse the net I can usually create the issue over some time, using a program such as premiere pro usually causes the issue and BSoD within 20-30 mins especially when rendering. If using vmware machines I can make the issue happen after some time as well. If I continue browsing the net when the issues begin to happen my browser will start to crash for no apparent reason as well. Windows Explorer will also crash randomly once it gets bad enough.

After I began to encounter issues I took the laptop apart and cleaned it out very well, how ever there was very little dust inside it and no vents were even partially clogged. I did do a re paste about 3 weeks ago both cpu and gpu.

Here is system specs:
ASUS G73JH-X2 Laptop
CPU i7-720QM Clarksfield
16GB 4GB*4 - PC3-10600 DDR3 SDRAM - CMSO8GX3M2A1333C9
ATI Mobility Radeon HD 5870 [ASUS] - 1GB DDR5
Hard Drive - Seagate ST9500420AS - 7200 RPM

I have Installed the Latest Bios on the Motherboard, Video Card, Hard drive

I have tried doing a system restore to factory settings, a full format and clean install using a windows 7 disk and all ends up with same issues, which is why I believe it to be a hardware issue. (Sorry I did not make backups of the dump files prior to the formats)

I have ran Memtest86 for over 3 hours, 3 full cycles. Prime95 for 2+ hours. Many hours of other various test programs such as BurnInTest. None have ever failed or returned an error message.

I have also enabled a full dump on BSoD following directions from the sticky, hopefully next time that happens I can supply that as well.

Attachment 243473

Thank You.


My System SpecsSystem Spec
.

28 Nov 2012   #2

Windows 8 Professional x64
 
 

Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

BAD_POOL_HEADER (19)
The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arguments:
Arg1: 0000000000000003, the pool freelist is corrupt.
Arg2: fffff8a00a1a76e0, the pool entry being checked.
Arg3: fffff8a00a1a76e0, the read back flink freelist value (should be the same as 2).
Arg4: 0a1a0b00fffff8a0, the read back blink freelist value (should be the same as 2).

Debugging Details:
------------------


BUGCHECK_STR:  0x19_3

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

PROCESS_NAME:  vmware-vmx.exe

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff8000320b70f to fffff800030e0fc0

STACK_TEXT:  
fffff880`09fe95c8 fffff800`0320b70f : 00000000`00000019 00000000`00000003 fffff8a0`0a1a76e0 fffff8a0`0a1a76e0 : nt!KeBugCheckEx
fffff880`09fe95d0 fffff800`0320d1a1 : fffffa80`0e4cd940 fffff8a0`09dff370 00000000`00000000 fffff8a0`09dff305 : nt!ExDeferredFreePool+0xcbb
fffff880`09fe9660 fffff880`068d01b1 : fffff8a0`01b03460 00000000`00000000 fffff8a0`4b677844 00000000`00000799 : nt!ExFreePoolWithTag+0x411
fffff880`09fe9710 fffff880`068cf65f : fffff8a0`18a24000 00000000`00000000 fffffa80`00000000 00000000`00000000 : dxgkrnl!DXGDEVICE::DestroyAllocations+0x72d
fffff880`09fe9800 fffff880`068cfa03 : fffff8a0`18a24000 fffff8a0`18a24000 00000000`00000001 00000000`00000000 : dxgkrnl!DXGDEVICE::ProcessTerminationList+0xa3
fffff880`09fe9850 fffff880`068d379c : fffff8a0`09adb800 fffff880`09fe9ca0 fffffa80`0f5ec000 fffff880`0689a3af : dxgkrnl!DXGDEVICE::TerminateAllocations+0x1db
fffff880`09fe98a0 fffff880`068d5e57 : fffff8a0`18a24000 fffff880`09fe99b0 00000000`00000001 00000000`00000001 : dxgkrnl!DXGDEVICE::DestroyAllocation+0x448
fffff880`09fe9930 fffff960`002203ea : 00000000`00000000 fffffa80`17ec4680 00000000`00000020 00000000`c0002740 : dxgkrnl!DxgkDestroyAllocation+0x9bf
fffff880`09fe9bf0 fffff800`030e0253 : fffffa80`17ec4680 00000000`ffffffff 00000000`00000000 fffffa80`18be1830 : win32k!NtGdiDdDDIDestroyAllocation+0x12
fffff880`09fe9c20 000007fe`fdf34a4a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`42aef778 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x000007fe`fdf34a4a


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt!ExDeferredFreePool+cbb
fffff800`0320b70f cc              int     3

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt!ExDeferredFreePool+cbb

FOLLOWUP_NAME:  Pool_corruption

IMAGE_NAME:  Pool_Corruption

DEBUG_FLR_IMAGE_TIMESTAMP:  0

MODULE_NAME: Pool_Corruption

FAILURE_BUCKET_ID:  X64_0x19_3_nt!ExDeferredFreePool+cbb

BUCKET_ID:  X64_0x19_3_nt!ExDeferredFreePool+cbb

Followup: Pool_corruption
---------
vmware-vmx.exe is causing BSOD

Please uninstall vmware and see if the error persists
My System SpecsSystem Spec
28 Nov 2012   #3

Windows 7 Ultimate x64
 
 

Quote:
vmware-vmx.exe is causing BSOD

Please uninstall vmware and see if the error persists

I will try that, how ever many many other times vmware is not present when the BSoD happens, it just happened to be that specific time.
My System SpecsSystem Spec
.


28 Nov 2012   #4

Windows 8 Professional x64
 
 

Please run memtest for 7-8 passes.

Also

Driver Verifier - Enable and Disable
My System SpecsSystem Spec
28 Nov 2012   #5

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by bagavan View Post
Please run memtest for 7-8 passes.

Also

Driver Verifier - Enable and Disable
Going to run memtest while I sleep for the next 8 hrs or so. I will take a picture of the results and post. I also have the verifier enabled now and will report back any dumps. Thank you


Edit well after rebooting the system locks up soon as I get a mouse pointer, booting to safemode to try and remove it till I get word on what to do next.
My System SpecsSystem Spec
28 Nov 2012   #6

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Yep, you want everything that doesn't say Microsoft, Unknown, or Macrovision.
I got to looking on that thread and followed this guys recommendation and the system did boot. Now what should I be looking for? The system feels very sluggish as well.
My System SpecsSystem Spec
28 Nov 2012   #7

Windows 7 Ultimate x64
 
 

ok after running Verifier for ~45 minutes the system locked up, did not blue screen I let it sit there for a few minutes before shutting it off. Turned it back on received a BSoD about IO on a driver took a few pictures and have attached pictures with the dump, also upon going back to safe mode, disabling Verifier (for that was only way I could boot back up tried 2 times with same BSoD) once I was back to a desktop working on zipping up the files the system BSoD'd again this time with very few applications open and such so may help a lot. I have attached that dump as well.

I do have a full dump of the latest BSoD if there is anything I can do with it to give you more information I would be glad to investigate into that. Thank you.

Attachment 243486
Attachment 243487

I am going to shutdown now and run memtest while I sleep, Will check this post as soon as I wake up. Thanks again.
My System SpecsSystem Spec
30 Nov 2012   #8

Windows 7 Ultimate x64
 
 

Sorry for the delayed response been super busy and well found out one set of the ram I just purchased the day I created this thread was bad so i returned that and got a replacement ran memtest86 all was good (I believe my old ram is still good for after a lot of memtest86 it never showed defective so it will be nice to have as spare, i like the 16gb I have now makes huge difference in vmware) then after beating my head off the wall for basically 2 days straight following all recommendations, I then decided to kind of venture off on my own and downgraded vbios, motherboard bios to stock, used a 2nd hard drive installed fresh copy of windows, installed only sp1, went and installed video drivers, opened browser and started to notice something that I could finally make happen every time. It can be seen here in this video Weird Blocks on mouse over links and text - YouTube. I did a search for archived video drivers and came to notice someone with a different model 5xxx series ati card said they had issues (never stated specifics) on a 12.6 driver and reverted back to 12.4 well I had nothing to loose so went and uninstalled my current driver which was the latest driver 12.10, ran ati crap cleaner, and installed 12.4 series driver and bam no more black block(could this be the resolution to my weird pixels as well? lets hope so), so now I have re updated the vbios and motherboard bios to current versions and in almost 24 hrs no bsod, no weird pixels, seams all is good now lets just hope it stays this way. Thanks for all the help and being inspirational for me to finally dig though this and resolve the issue.

The site I found the drivers on was An archive of AMD Mobility Catalyst Windows 7 x64 drivers – PCR's notepad

Thanks again.

I wont mark this as solved yet due to I don't believe 24 hrs is really a good test, but when I have a week of up time I will definitely return and mark as solved, or return with more dumps
My System SpecsSystem Spec
10 Dec 2012   #9

Windows 7 Ultimate x64
 
 

Going to mark this issue as solved. 0 Issues since my last post.
My System SpecsSystem Spec
Reply

 Weird Pixels that lead to random BSoD's




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:01 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33