Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error 1723 - Unable to install anything with a .msi installer


17 Dec 2012   #1

Windows 8.1
 
 
Error 1723 - Unable to install anything with a .msi installer

Hi, I hope this is is in the right thread, I already posted in software, but was unable to find the solution, I have also posted on the microsoft forum, with no luck.

Basically, I am unable to install anything with .msi (windows installer package), I will get error messages like:

'There is a problem with this windows installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor'

OR

'Installation directory must be on a local hard drive' (Even though it is).

When it does give me an error code it is always 1723


Its not with any specific software I'm having trouble with. For example I tried installing Acrobat, Quicktime, Rhinoceros (3d software) and T-splines (plugin for Rhinoceros)....all of which got an error and had msi installers, so I think its safe to assume its not the software, but a problem with my computer. I have checked all the installers on another computer and they work.

Things I've tried so far
sfc /scannow
Microsoft fix it tool
Checked the status of windows installer in Services (It was running)
The only thing I have come close to is using 'run as admin' with quicktime as it was the only program which allowed that option as an msi. This actually worked and was able to override the DLL error somehow and install quicktime.


Any help is really appreciated.

My System SpecsSystem Spec
.

17 Dec 2012   #2
Arc

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64 Bit SP 1
 
 

I am guessing that it is the problem of windows installer. For windows 7, it is the installer version 5, and that is not available to download. It is built in windows 7.

Run SFC /SCANNOW Command - System File Checker

If it fails, try Repair Install.
My System SpecsSystem Spec
19 Dec 2012   #3

Windows 8.1
 
 

Ok cool thanks for the reply . I think I'm gonna have to use the repair since sfc/scannow didn't work. I'll report back when I've done so
My System SpecsSystem Spec
.


26 Dec 2012   #4

Windows 8.1
 
 

I did repair install, it worked! Thanks!
My System SpecsSystem Spec
26 Dec 2012   #5
Arc

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64 Bit SP 1
 
 

Quote   Quote: Originally Posted by Robwan View Post
I did repair install, it worked! Thanks!
Nice to know
My System SpecsSystem Spec
27 Dec 2012   #6

Windows 8.1
 
 

Ok the error is back, damn it, exact same one, 1723.

I was unable to quite catch what caused it though, as I wasn't exactly monitoring my activities.

However something I recently did was a cclean, I did the registry also.

I also went into the files $INPLACE.~TR and $WINDOWS.~Q and looked around (didn't delete anything though). As I was curious what they where, (I'm assuming they're something to do with the upgrade).

I haven't installed anything new either.

Should I be worried about virus/rootkit etc?

I'm currently performing another upgrade (I tried system restore and it failed) as it should fix the problem as it did last time, but I'm sure it won't last again. I'm kinda stuck what to do, I'm trying to avoid a fresh install lol

Thanks again for your help
My System SpecsSystem Spec
27 Dec 2012   #7

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

cclean did probably cause it!! Can you do a system restore to a date/time prior to running cclean?
My System SpecsSystem Spec
27 Dec 2012   #8

Windows 8.1
 
 

Hi thanks for reply

Yea i tried that, I was actually able to do a restore all the way back to putting my windows product key in (from the repair install) but the error was still there.

I'm working on my laptop instead now while my pc does another repair install using the iso.

What's confusing me, is that if it is ccleaner, then why only on my pc will it create the problem? I have Win 7 Home and 7 Ultimate on two other laptops which i use ccleaner on and have no problems.

Do you think this thread is anything to be concerned with Windows Installer is not functioning properly/Error 1723 when - Microsoft Community

Its someone with the same problem, and there is mention of a virus, however this is only virus related answer i have seen in while searching the net about error 1723 (most people all seem to have the error with Java install/uninstall)

Hopefully this second repair will fix it again, if it doesn't...I'll be totally confused
My System SpecsSystem Spec
27 Dec 2012   #9

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

I think ccleaner did it... but I am not sure. Did you more cleanup things?
My System SpecsSystem Spec
27 Dec 2012   #10

Windows 8.1
 
 

No I just used ccleaner.

After I did the repair install yesterday, I did all the windows updates then checked to see if a .msi file worked and it did no problem. Only today i went to do a cclean and then tried to install a .msi afterwards...which was reallllly stupid, I should have tested a .msi right before and after cclean to pinpoint it.

The second repair install has just finished now, and .msi files once again work, hooray. However I don't know whether its worth trying a cclean, if it does screw it up then its good and bad as we have pinpointed the problem, but it means I'll have to do a third repair install; I am curious though. To test it i might make a backup image with macrium before hand, as I've always wanted to restore an image just for the experience of doing so.

Any ideas on what you think it could be? I checked my ccleaner settings on my pc and they seem to be the same as on laptop. I'm kind of expecting the problem to come back.

One thing that might be a clue maybe.

After the upgrade finished and my desktop loaded, I was greeted with the notification
"Setup has detected that .NET Framework 4 needs to be repaired. Do not restart your computer until the repair is complete."
Maybe this is was needed repairing? I don't know, but it took about 10-15mins to repair for me. (this happened on both repair installs i did)

Thanks again
My System SpecsSystem Spec
Reply

 Error 1723 - Unable to install anything with a .msi installer




Thread Tools



Similar help and support threads for2: Error 1723 - Unable to install anything with a .msi installer
Thread Forum
Solved Unable To install SP1, error 0x800b0100 Windows Updates & Activation
Error in every installer I tried to install. Software
Unable to install windows installer 4.5 error 0x8007000d Installation & Setup
Unable to install SP1, error 800F0818 Windows Updates & Activation
Unable to Install Anything, Error says I need to be Admin Software
Java error help 1723 Software
Unable to install, no error message. Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33