Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: laptop crashes when connected wirelessly; stable when wired

01 Sep 2013   #1
stevieray

windows 7 x64 Home Premium
 
 
laptop crashes when connected wirelessly; stable when wired

The patient: Compaq Presario F700NR, Win7 x86

The symptoms: Crashes quickly when connected to internet wirelessly. Usually goes straight to boot, but sometimes (about 1 in 10) gives me a bluescreen.

Seems to be stable when the wireless network card (Atheros AR5007) is disabled or removed and it is connected thru ethernet cable.

Attempted fixes: Updated drivers. Rolled back drivers. Replaced wireless card. Repair installed OS. Clean installed OS.

Curiously, after the clean install of Window 7, three devices came up in device manager as "unknown devices". They turned out to be the Ricoh Memory Stick Host Controller, PCI IDE Controller, and the wireless network card. I had installed Windows 7 on this laptop twice before and never saw that either of those times.

I ran all of the minidumps thru the debugger. got a bunch of driver IRQL not less than or equal to errors, with a hardware error or two thrown in as well.

I think I've got a hardware problem masquerading as a driver issue... perhaps the pci bus is shot, but I'd like to see what the experts think.

Here is the zip:


My System SpecsSystem Spec
.
02 Sep 2013   #2
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Hello stevieray.

The BSOD is caused by Atheros driver.
Code:
BugCheck D1, {30, 2, 0, 8e45f8a5}

Unable to load image \SystemRoot\system32\DRIVERS\athr.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for athr.sys
*** ERROR: Module load completed but symbols could not be loaded for athr.sys
Probably caused by : athr.sys ( athr+428a5 )

Followup: MachineOwner
---------
And the driver is too old.
Code:
8e41d000 8e52d000   athr     T (no symbols)           
    Loaded symbol image file: athr.sys
    Image path: \SystemRoot\system32\DRIVERS\athr.sys
    Image name: athr.sys
    Timestamp:        Tue Jun 09 23:34:52 2009 (4A2EA444)
    CheckSum:         0011A043
    ImageSize:        00110000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
I can understand why you have disabled it.

DESCRIPTIONFILESTARTED
Atheros Extensible Wireless LAN device driver c:\windows\system32\drivers\athr.sys No

You need to update this driver, rather disabling. Get it from Drivers for Atheros AR5007 and Windows 7
  • Version: 10.0.0.251
  • Release: 2013-05-27
Apply it ..... let us know the results.

My System SpecsSystem Spec
02 Sep 2013   #3
stevieray

windows 7 x64 Home Premium
 
 

Wow... I can't believe it worked! I tried newer drivers from HP, from cnet, from softpedia... none of them worked. I kept seeing links to that site, but I didn't trust it; it looked kind of sketchy to me, so I skipped it. Oh well... sometimes life is like that.

I wonder why the driver from 2009 doesn't work anymore. That is the driver that came on the Win7 disc when I did the clean installation a few weeks ago. It worked fine back when I first installed seven on this machine in 2010. Another mystery for another day.

Thanks arc!
My System SpecsSystem Spec
.

02 Sep 2013   #4
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

You are welcome mate

The link I provided is the official website to download drivers for Atheros devices, the only trustworthy link. Older drivers fail to work. That is why there are updates. Dont take it as a mystery, its the regular phenomena. Keep your drivers up-to-date, but get the drivers from the official site only.
My System SpecsSystem Spec
02 Sep 2013   #5
stevieray

windows 7 x64 Home Premium
 
 

But it says "The Unofficial Atheros Czech Drivers Site" right there at the top of the page. That's why I avoided it.
My System SpecsSystem Spec
02 Sep 2013   #6
derekimo

Microsoft Community Contributor Award Recipient

 
 

Quote   Quote: Originally Posted by stevieray View Post
But it says "The Unofficial Atheros Czech Drivers Site" right there at the top of the page. That's why I avoided it.
QUALCOMM bought Atheros,

Qualcomm Atheros - Wikipedia, the free encyclopedia

Probably why it is technically Unofficial
My System SpecsSystem Spec
02 Sep 2013   #7
stevieray

windows 7 x64 Home Premium
 
 

Quote   Quote: Originally Posted by derekimo View Post
Quote   Quote: Originally Posted by stevieray View Post
But it says "The Unofficial Atheros Czech Drivers Site" right there at the top of the page. That's why I avoided it.
QUALCOMM bought Atheros,

Qualcomm Atheros - Wikipedia, the free encyclopedia

Probably why it is technically Unofficial
Well... now I know.

The debugger kept telling me it was the driver, but after I spent many hours trying driver after driver, only to watch each and every one of them crash and burn, I figured it had to be something else. Fortunately, I kind of like futzing around with computers, or else I'd be pissed at the wasted time.

The saddest part of all this? No matter what driver I put in there Windows Device Manager was pleased as punch with it. It always told me I had the best and brightest of all earthly drivers installed... even when I rolled back to one from 2007.
My System SpecsSystem Spec
02 Sep 2013   #8
derekimo

Microsoft Community Contributor Award Recipient

 
 

It does look like a shady site.

I guess it was happy till it started using it.
My System SpecsSystem Spec
03 Sep 2013   #9
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Still Atheros updates all its drivers there, other than Killer Gaming
My System SpecsSystem Spec
Reply

 laptop crashes when connected wirelessly; stable when wired




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Laptop crashes with black screen when connected to AC power
Hello all, I am using a dell studio xps 1645 with ati mobility radeon HD5730 inbuilt. Problem i have been facing past few weeks is that my laptop screen is going black and is crashing a few minutes after booting up when i connect to ac power. I did a few diagnostic tests. It is working...
Graphic Cards
Connecting Dell Laptop to TV With Desktop Connected Wirelessly
Hey guys! I hope I'm posting this in the right sub, but here goes nothing. We have Airplay setup on the desktops which are connected to the TVs, so clients can come into our conference rooms, and connect their iPads, iPhones or whatever to the TVs in the conference rooms. This works great,...
Music, Pictures & Video
Connected Wirelessly No Internet Access
Hi there! I have searched through many forums and taken more steps than I can count to try and resolve this issue. I have to computers connected to the same wireless network and one will not access the internet. This has been an intermittent problem and has usually been resolved by removing the...
Network & Sharing
Cannot get on the internet - wired or wirelessly
I have a Sony Vaio with windows 7 OS (64bit), I have installed and ran several differnet antivirus and malware programs and found nothing. I ran a full virus Scan (Kasperksy anti-virus 2012) and no issues found, I tried to do a System Restore to earlier date (it failed), I can see that i have an...
Network & Sharing
Connect a laptop wirelessly to a wired LAN with no router
What are my options for connecting a laptop wirelessly to a workstation that is connected to a wired LAN and has no router? Essentially, I want to add wireless connectivity to the workstation so that the laptop can connect to the wired LAN via the workstation.
Network & Sharing
Sharing: XP can see 7, but 7 canít see XP wirelessly, 7 wired sees XP
I beat my head against the wall 2 hours last night surfing for this answer so I thought today on my lunch break that I would let this bird fly… thanks for any help. My XP computer is wired to the router, the 7 laptop is wireless. Both can surf the web today, no problem. However, XP can see 7...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App