Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ntoskrnl.exe BSOD randomly

15 Nov 2013   #41
x BlueRobot

 

If it doesn't crash in Safe Mode, then it's usually just a driver issue, however, looking at the most recent bugcheck it seem that the working set free list is corrupt is most likely caused by hardware.

Code:
BugCheck 1A, {5003, c0802000, 6c1, 6c3d80}

Probably caused by : memory_corruption ( nt!MiAllocateWsle+6f )
Code:
0: kd> !wsle 2

Working Set @ c0802000
    FirstFree      6c1  FirstDynamic        6
    LastEntry      701  NextSlot            6  LastInitialized      8bd
    NonDirect      1f4  HashTable           0  HashTableSize          0

Reading the WSLE data .....Unable to get Wsle table block - address c0803108 - count 512 - page 0x100
With the second bit flag set with the extension, the free WSLEs shoud also be displayed, but since this data structure has become corrupt then this data may not be displayed.

Code:
0: kd> dt nt!_MMWSLE c0802000
   +0x000 u1               : <unnamed-tag>
Code:
0: kd> .trap a75d2d34
ErrCode = 00000006
eax=01470020 ebx=01470020 ecx=000037f1 edx=0000004c esi=76dbeef7 edi=014a1fa0
eip=76f19c9c esp=00f0f194 ebp=00f0f198 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010202
001b:76f19c9c ??              ???
Interestingly, the trap frame which was caused because of an invalid assembly instruction. The call stack doesn't reveal much, because the instruction was possibly made in User-Mode.

We could try running Driver Verifier again, but with the Special Pool option enabled too. Select Individual Settings, and enable all the options, apart from Low Resources Simulation.

Run Driver Verifier to scan for any corrupted drivers which may be causing problems, this program works by running various stress tests on drivers, in order to produce a BSOD which will locate the driver; run for least 24 hours:
information   Information



My System SpecsSystem Spec
.
15 Nov 2013   #42
moieu

Windows 7 Home Premium 64 bit
 
 

Alright I ran driver verifier, found asacpi.sys was the cause, and looked up how to fix it. A fix was to rename it to asacpi.bak and it would make a new one on startup, and that helped, I ran the new asacpi.sys file and it was fine. But after about 2 hrs from that I got another blue screen but it didn't post a dump file. Also instead of the usual text at the bottom half where it says its posting a dump, I got about 7 or 8 weird characters that I had no clue what were for. Also all my other drivers are running fine. I ran driver verifier without problems.
EDIT: Ran driver verifier on ALL my drivers, hidclass.sys was giving a blue screen. Posting the dump file for you to look at.
My System SpecsSystem Spec
15 Nov 2013   #43
x BlueRobot

 

Don't enable Driver Verifer for Windows drivers.

Code:
BugCheck C9, {220, 985e2a8c, bc308ed8, 8d317e98}

*** WARNING: Unable to verify timestamp for LGVirHid.sys
*** ERROR: Module load completed but symbols could not be loaded for LGVirHid.sys
Probably caused by : HIDCLASS.SYS ( HIDCLASS!HidpMajorHandler+0 )
This bugcheck indicates that a driver has completed a IRP_MJ_SYSTEM_CONTROL request without the correct ProviderID.

Code:
2: kd> !irp bc308ed8
Irp is active with 5 stacks 4 is current (= 0xbc308fb4)
 No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  
     cmd  flg cl Device   File     Completion-Context
 [  0, 0]   0  2 00000000 00000000 00000000-00000000    

			Args: 00000000 00000000 00000000 c00000bb
 [  0, 0]   0  0 00000000 00000000 00000000-00000000    

			Args: 00000000 00000000 00000000 00000000
 [ 17,ff]   0  2 8e7b6bf8 00000000 00000000-00000000    
	      8e7b6bf8: Could not read device object or _DEVICE_OBJECT not found

			Args: 8d317e98 00000000 00000000 00000000
>[ 17,ff]   0 e0 8e7b6bf8 00000000 82d74d3a-bc308fd8 Success Error Cancel 
	      8e7b6bf8: Could not read device object or _DEVICE_OBJECT not found
	nt!IovpInternalCompletionTrap
			Args: 8d317e98 00000000 00000000 00000000
 [ 17,ff]   0 e0 8e7b6aa8 00000000 82d73c25-8819d9c0 Success Error Cancel 
	      8e7b6aa8: Could not read device object or _DEVICE_OBJECT not found
	nt!ViIrpSynchronousCompletionRoutine
			Args: 8d317e98 00000000 00000000 00000000
Code:
2: kd> lmvm LGVirHid
start    end        module name
b0c41000 b0c43000   LGVirHid T (no symbols)           
    Loaded symbol image file: LGVirHid.sys
    Image path: \SystemRoot\system32\drivers\LGVirHid.sys
    Image name: LGVirHid.sys
    Timestamp:        Tue Nov 24 01:36:26 2009 (4B0B389A)
    CheckSum:         00010C56
    ImageSize:        00002000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Your Logitech Gamepanel Virtual HID Device Driver seems to be causing problems, please update the driver from here - Logitech Support - Downloads, Manuals, FAQs & More

Check the support pages for any Logitech equipment you have.
My System SpecsSystem Spec
.

15 Nov 2013   #44
moieu

Windows 7 Home Premium 64 bit
 
 

Alright well I wasn't getting blue screens, but windows was freezing again. This is what I got from Event Viewer. Also I tried to run startup repair and it said it was unable to repair the problem. I don't know how to get that dump file, if there is one anyways. Also my bad about the windows files, I clicked on select all drivers, because I thought it might be a problem with a windows driver. Also, I just reinstalled logitech gaming software for my mouse and headset, and right after that I got a computer freeze.
My System SpecsSystem Spec
16 Nov 2013   #45
x BlueRobot

 

That error seems to be largely network based from what I've found on Technet and MSDN. Have you tried a different browser? It might also be related to Outlook if you have the Outlook client installed.
My System SpecsSystem Spec
18 Nov 2013   #46
moieu

Windows 7 Home Premium 64 bit
 
 

I don't know what I did but it's fixed I think. Haven't had any blue screens in 3 days.
My System SpecsSystem Spec
18 Nov 2013   #47
x BlueRobot

 

Okay, that's great news, leave the thread open for a few more days and then mark it has solved if you feel your issue has been resolved
My System SpecsSystem Spec
22 Nov 2013   #48
moieu

Windows 7 Home Premium 64 bit
 
 

Just got another blue screen. I don't know if this helps, but it happened about 2 minutes after I plugged my phone into my usb charger connected to my pc. The charger is actually for my headset, and it has a split were you can plug another usb into. It's kinda confusing but think of it as this, it plus into my computer, then has another usb slot coming from it, then a charger for my headset, that also fits for my phone.
My System SpecsSystem Spec
22 Nov 2013   #49
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Quote   Quote: Originally Posted by moieu View Post
Just got another blue screen. I don't know if this helps, but it happened about 2 minutes after I plugged my phone into my usb charger connected to my pc. The charger is actually for my headset, and it has a split were you can plug another usb into. It's kinda confusing but think of it as this, it plus into my computer, then has another usb slot coming from it, then a charger for my headset, that also fits for my phone.
Do you need to charge the phone via the charger mate most stuff will have a direct USB cable that will avoid using the charger.

The other point to me is that the machine doesn't like the phone or it's software.
Blue will be able to help you with the other stuff mate as I am pretty hopeless with that
My System SpecsSystem Spec
22 Nov 2013   #50
moieu

Windows 7 Home Premium 64 bit
 
 

Well I just split the two. My phone is now charging on a separate cable and my headset is using it's own too. And I haven't had any bsods.
My System SpecsSystem Spec
Reply

 ntoskrnl.exe BSOD randomly




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ntoskrnl.exe BSOD Randomly every few days
Hi, I recently built my PC(one month roughly). About a couple weeks after I built it I got 2 BSODs in a row in the same day, I ignored it thinking it was a one off. And for a while that seemed to be the case. I got another BSOD however a few days later. Then for 1-2weeks the BSODs went dormant...
BSOD Help and Support
BSOD Randomly, ntoskrnl.exe
Hello there; I`ve just assembled a custom PC with kinda high end specs and apparently something is wrong with my computer because I`m having completely random blue screens. First one happened after i installed deamon tools lite, while trying to shutdown my computer. Then i tought it happened...
BSOD Help and Support
BSOD randomly cause:: ntoskrnl.exe
Hello guys, I have been getting BSOD where the PC locks up and will require a hard reboot. I am attaching all the dmp files from the day it started. I have windows 7pro 64bit yesterday I went through the other posts on here to find a solution and ran a memtest and HDD test and they both...
BSOD Help and Support
BSOD Randomly Caused by ntoskrnl.exe
So my Windows 7 Ultimate started bugging out of me a couple days ago. Problem first started right after an windows update I believe, and originally presented as no desktop loading after log on, only a black screen with a cursor. Restored, ran chkdsk and repair and they problem disappeared but now...
BSOD Help and Support
BSOD with ntoskrnl.exe after POST, randomly when using.
Hello. I have a Gateway M2624u laptop that I'm trying to fix for a friend. She stated that it was slow, so I reinstalled the OS (Vista Home Premium x64). It was working fine for the two nights I had it, but she then said it started blue screening as soon as it loaded Vista's loading screen. It's...
BSOD Help and Support
BSOD randomly, ntoskrnl.exe, W7 x64
Hi, i have randomly bsods when surfing web or play games. Windows after fresh install. Ran memtest86+ (3passes, no errors) Please help ...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App