Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ntoskrnl.exe BSOD randomly

22 Nov 2013   #51
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Quote   Quote: Originally Posted by moieu View Post
Well I just split the two. My phone is now charging on a separate cable and my headset is using it's own too. And I haven't had any bsods.
Good stuff if it stays that way then maybe it is that the machine doesn't like both through one USB port - who knows as long as it works thats the main thing.


My System SpecsSystem Spec
.
23 Nov 2013   #52
x BlueRobot

 

Quote   Quote: Originally Posted by moieu View Post
Well I just split the two. My phone is now charging on a separate cable and my headset is using it's own too. And I haven't had any bsods.
That's good to know
My System SpecsSystem Spec
23 Nov 2013   #53
x BlueRobot

 

Just for the sake of debugging, here's my analysis:

Code:
BugCheck 1000008E, {c0000005, 82a87189, a16d6ca4, 0}

Probably caused by : invalid_control_transfer
Code:
a16d6ca4 -- (.trap 0xffffffffa16d6ca4)
ErrCode = 00000002
eax=855b2400 ebx=97cf4a1c ecx=00000000 edx=00000000 esi=00000008 edi=00000028
eip=82a87189 esp=a16d6d18 ebp=a16d6d24 iopl=0         nv up ei pl zr na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010246
nt!ExReleaseResourceAndLeavePriorityRegion+0xc:
82a87189 888b0200008d    mov     byte ptr [ebx-72FFFFFEh],cl ds:0023:24cf4a1e=??
The exception being introduced here is a NMI (or Non-Maskable Interrupt), and is a very high priority interrupt used for crashes.

The nt!ExReleaseResourceAndLeavePriorityRegion (undocumented) is used to release a executive resource, and leave a priority region. The priority region in this case, may have been a critical section.

Code:
1: kd> u win32k!NtUserCallOneParam+0x43
win32k!NtUserCallOneParam+0x43:
97cf4a5f e8a3ecfeff      call    win32k!UserSessionSwitchLeaveCrit (97ce3707) <-- Problem here
97cf4a64 8bc7            mov     eax,edi
97cf4a66 5f              pop     edi
97cf4a67 5e              pop     esi
97cf4a68 5d              pop     ebp
97cf4a69 c20800          ret     8
97cf4a6c 90              nop
97cf4a6d 90              nop
The problem happens when attempting to call a certain function, and this call fails.
My System SpecsSystem Spec
.

27 Nov 2013   #54
moieu

Windows 7 Home Premium 64 bit
 
 

Alright, still getting bsods... I've tried everything. Its still usbfilter.sys, I ran driver verifier to check. But even after updating it it's still the cause. I'm also not able to do anything past boot now cause it says winload.exe is missing or corrupt. It did this earlier and then after awhile went away. I need serious help because I'm going to get kicked out of my classes if I can't submit work... also, I was trying to fix it by myself and found a thread were a program had fixed the issue, it disabled the USB filter system file, but now my keyboard and mouse won't work at all.
My System SpecsSystem Spec
28 Nov 2013   #55
moieu

Windows 7 Home Premium 64 bit
 
 

Ok so I reset my computere to factory settings again. It's couldn't find another way to use my keyboard and mouse after boot, and I finally got the winload.exe error to go away. It just went away, after awhile. After resetting my computer I installed all the updates, and I didn't get a blue screen, but I got that thing where my computer tower stays on, but everything connected to it shuts off. My monitor went to standby mode. I guess that's kind of like a blue screen, although I got no dmp file for it. If I get any blue screens I will be posting the dmp files for them as they come.
My System SpecsSystem Spec
28 Nov 2013   #56
moieu

Windows 7 Home Premium 64 bit
 
 

Alright for some reason I can't edit my previous posts, but I had a bsod and there was no dump file, then I decided to use driver verifier to see which one it was, it was usbfilter.sys I'm attaching the two bsods I got from driver verifier in hopes that you have a fix. Keep in mind the last time I installed the amd update from my computer's website it didn't fix the usbfilter.sys bsods I was getting.
My System SpecsSystem Spec
29 Nov 2013   #57
x BlueRobot

 

Code:
3: kd> lmvm usbfilter
start             end                 module name
fffff880`043c9000 fffff880`043d6000   usbfilter T (no symbols)           
    Loaded symbol image file: usbfilter.sys
    Image path: \SystemRoot\system32\DRIVERS\usbfilter.sys
    Image name: usbfilter.sys
    Timestamp:        Tue Dec 22 08:26:22 2009 (4B3082AE)
    CheckSum:         0000DFD8
    ImageSize:        0000D000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Where did you update the driver last time? Try the AMD website, since this driver usually belongs to your chipset. Do you have a non-USB keyboard and mouse?

Support & Drivers

Code:
BugCheck D5, {fffff98008d84df0, 0, fffff880043cd1aa, 0}

Could not read faulting driver name
Probably caused by : usbfilter.sys ( usbfilter+41aa )
The driver caused a invalid page fault, since the pool page was no longer allocated to the driver's own address space. It was freed.
My System SpecsSystem Spec
29 Nov 2013   #58
moieu

Windows 7 Home Premium 64 bit
 
 

I originally downloaded it from my computer's website. I have an Asus cm1630, and they had the driver there. But it didn't seem to fix the problem. I'll download it from this website and see if it does. I have no clue on which one to install from this website you linked me, I'm using a nvidia graphics card, so it doesn't tell me which amd one I have installed.

EDIT: Ran driver verifier with usbfilter.sys checked, no bsod on startup, but then after like 10 minutes I got one. But it didn't post a dmp file, so I don't have one to show for it. Will be posting them as they come though.
My System SpecsSystem Spec
29 Nov 2013   #59
moieu

Windows 7 Home Premium 64 bit
 
 

Just got a bsod, it said tcpip.sys, I looked it up but I don't understand what could've caused it. Could you look into it for me?
EDIT: Another two bsods since the last time I posted. Here they are.
My System SpecsSystem Spec
29 Nov 2013   #60
x BlueRobot

 

Did you use the AMD automatic driver installation?
My System SpecsSystem Spec
Reply

 ntoskrnl.exe BSOD randomly




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ntoskrnl.exe BSOD Randomly every few days
Hi, I recently built my PC(one month roughly). About a couple weeks after I built it I got 2 BSODs in a row in the same day, I ignored it thinking it was a one off. And for a while that seemed to be the case. I got another BSOD however a few days later. Then for 1-2weeks the BSODs went dormant...
BSOD Help and Support
BSOD Randomly, ntoskrnl.exe
Hello there; I`ve just assembled a custom PC with kinda high end specs and apparently something is wrong with my computer because I`m having completely random blue screens. First one happened after i installed deamon tools lite, while trying to shutdown my computer. Then i tought it happened...
BSOD Help and Support
BSOD randomly cause:: ntoskrnl.exe
Hello guys, I have been getting BSOD where the PC locks up and will require a hard reboot. I am attaching all the dmp files from the day it started. I have windows 7pro 64bit yesterday I went through the other posts on here to find a solution and ran a memtest and HDD test and they both...
BSOD Help and Support
BSOD Randomly Caused by ntoskrnl.exe
So my Windows 7 Ultimate started bugging out of me a couple days ago. Problem first started right after an windows update I believe, and originally presented as no desktop loading after log on, only a black screen with a cursor. Restored, ran chkdsk and repair and they problem disappeared but now...
BSOD Help and Support
BSOD with ntoskrnl.exe after POST, randomly when using.
Hello. I have a Gateway M2624u laptop that I'm trying to fix for a friend. She stated that it was slow, so I reinstalled the OS (Vista Home Premium x64). It was working fine for the two nights I had it, but she then said it started blue screening as soon as it loaded Vista's loading screen. It's...
BSOD Help and Support
BSOD randomly, ntoskrnl.exe, W7 x64
Hi, i have randomly bsods when surfing web or play games. Windows after fresh install. Ran memtest86+ (3passes, no errors) Please help ...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App