Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Several BSODs recent install of MS OneDrive; USB ext. HDs fail

04 Jun 2014   #1
lite1

Windows 7 Pro 64-bit
 
 
Several BSODs recent install of MS OneDrive; USB ext. HDs fail

Please see my final post for how this was resolved.

Have had several BSODs in last few days, sometimes when I have walked away from laptop so not sure what I might have done to trigger things. Two of most recent referred to nusb3xhc.sys
Other symptoms: I have 3 WesternDigital 500GB ext. USB 2.0 HDs none of which are being recognized even when plugging directly in to laptop USB port rather than USB hub I usually use. Same USB port will show a small thumb drive. USB 3.0 laptop port still works, and I backed up my data this morning; browser bookmarks, etc. While the WD HDs are all older, it is very odd to me that they none of them are recognized, meaning they never show up in WE and the tray icon for USB never shows them as I typically click on the latter to eject an ext. USB HD.

Recent changes to laptop:
1) 6.1.2014 installed MS OneDrive (and also on tablet). version 17.0.4041.0512
2) Control Panel add/remove programs shows that Dropbox installed version 2.8.2 just before OneDrive

3) Subsequent to above I did routine Windows update of Important items with no problems. However for several years since about IE 9 or perhaps 10, I have been unable to get IE to install and work, and have been using Chrome for years. I mention this to give fuller picture, but doubt that it is related to current issue.

4) Aside from typical routine updates e.g. Java, Bitdefender antivirus I have not intentionally installed any other software recently.

============
I have barely begun using MS OneDrive so am happy to uninstall it, or go to restore point prior to its installation. BSOD prior to this might have occurred 1 or 2x per year.

I'm pretty good at following directions if they are complete e.g. need full path if you want me to find something on my HD.

Thanks for your knowledge, skill, and help.


My System SpecsSystem Spec
.
04 Jun 2014   #2
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Hi lite1.

The Renesas/NEC USB3 driver is continuously failing.
Code:
*** WARNING: Unable to verify timestamp for nusb3xhc.sys
*** ERROR: Module load completed but symbols could not be loaded for nusb3xhc.sys
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {ffffffffc0000005, fffff880052650a9, fffff88003bc43a8, fffff88003bc3c00}

Probably caused by : nusb3xhc.sys ( nusb3xhc+2c0a9 )

Followup: MachineOwner
---------
And It is old enough.
Code:
fffff880`05200000 fffff880`05230000   nusb3xhc T (no symbols)           
    Loaded symbol image file: nusb3xhc.sys
    Image path: \SystemRoot\system32\DRIVERS\nusb3xhc.sys
    Image name: nusb3xhc.sys
    Timestamp:        Fri Jan 22 08:52:21 2010 (4B5919ED)
    CheckSum:         00030E44
    ImageSize:        00030000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Lenovo seems to not have a proper update to it. You may need to get it from a third party source like this one.

Let us know the result.
My System SpecsSystem Spec
04 Jun 2014   #3
lite1

Windows 7 Pro 64-bit
 
 

@Arc Please provide some more details so I do this correctly.
Device Manager shows
NEC USB 3.0 Host Controller AND also ... Root Hub
both with seemingly the same outdated driver.
Do I need to update both of these? I imagine "yes".

=============
Intel website (https://downloadcenter.intel.com/Sea...as%20usb%203.0) shows 4 drivers, and also firmware update:
I have downloaded the 4/10/2012 driver version 2.1.28.1

Firmware is shown as 5/9/2013 4.0.2.1; 2.0.2.0 Do I need to download and install this?
I have one USB 3.0 port on the back of the Lenovo laptop, BUT the Intel notes indicate that this firmware
is for "This download record provides firmware updates for the back panel and front panel USB 3.0 ports (blue connectors) on the Intel® Desktop Boards DX79SR and DX79TO." and describes them as having multiple USB 3.0 ports on the front and/or back, SO I don't think I have the correct firmware, if indeed I need firmware update as well.
My System SpecsSystem Spec
.

04 Jun 2014   #4
lite1

Windows 7 Pro 64-bit
 
 
No real success yet

Update ... The 3 Western Digital ext. USB 2.0 HDs are still not recognized, AND oddly as was the case prior to driver update a small thumb drive does work and shows up in Windows Explorer. And as was the case previously my USB 3.0 Iomega drive works in the USB 3.0 port.

What I have done so far ... downloaded and installed from Intel driver website referred to in prior post. The NEC USB 3.0 Host Controller AND also ... Root Hub as shown via Device Manager now show driver 2.1.28.1 with date of 4/10/2012 so driver update seemingly is fine. HOWEVER they now start with the word "Renesas" rather than "NEC"

There are now in Device Manager two entries that were not there previously:
Renesas Electronics USB 2.0 Hub showing same driver as for the USB 3.0

What should I do now? Thanks.


Added:
I went to Lenovo website and looked up my machine type and it claims that the driver version 1.0.19.0 is up to date and that it is an NEC device. I did a Google search on NEC and nusb3xhc.sys and found on an HP website info about the driver below that is slightly older than the Renesas driver that I seemingly installed. BUT at least the driver below is specifically related to NEC.
Should I be uninstalling what I have already done? If so how can I do this as in Device Manager the button "Rollback driver" is greyed out.

Description

This package provides the NEC Electronics USB 3.0 Host Controller Driver for the supported notebook models and operating systems. The driver enables USB 3.0 devices.
Release details

Released:2011-09-16
File name:
sp54479.exe [1/1, 7.0M]
Version2.0.32.0
Compatibility:
Microsoft Windows 7 (32-bit)
Microsoft Windows 7 (64-bit)
My System SpecsSystem Spec
05 Jun 2014   #5
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

I'm pretty sure NEC are now part of Renesas so any Renesas drivers will supersede NEC ones, I had the same problem when I bought a Renesas USB 3.0 PCI-e card. Do you have the Renesas driver installed at the moment? Apologies for asking that but I'm at work at the moment and have one eye on my job.
My System SpecsSystem Spec
05 Jun 2014   #6
lite1

Windows 7 Pro 64-bit
 
 

@Boozad Thanks, yes currently Renesas driver is installed, still same problem.

I don't really know computer hardware that well, but my hunch is that USB 2.0 ports are not getting proper power. A mouse works, also a thumb drive, but even though Western Digital ext. HDs have a power brick they fail in USB 2.0 port.

My tentative work around (to get my data - backups etc. - from the WDs) is that I have a port replicator attached to USB 2.0 port. Plugging WDs into the port replicator now does have them recognized by laptop. This is NOT good solution, but OK work around.


Quote   Quote: Originally Posted by lite1 View Post
Update ...
What I have done so far ... downloaded and installed from Intel driver website referred to in prior post. The NEC USB 3.0 Host Controller AND also ... Root Hub as shown via Device Manager now show driver 2.1.28.1 with date of 4/10/2012 so driver update seemingly is fine. HOWEVER they now start with the word "Renesas" rather than "NEC"
Added by edit: You are correct, per wikipedia Renesas and NEC merged in 2010. Lenovo Thinkpad website for my laptop indicates that the original driver with earlier date 1/22/2010 is still current. No repsonse to my query on Thinkpad forums.
My System SpecsSystem Spec
05 Jun 2014   #7
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

It may be that a firmware update is required for the root hub. I need to spend a bit of time looking into this but it will be tonight at the earliest.
My System SpecsSystem Spec
05 Jun 2014   #8
lite1

Windows 7 Pro 64-bit
 
 

@Boozad again thanks. My earlier post referenced firmware, but I have done nothing about that so will await any further response from you after work.

Quote   Quote: Originally Posted by lite1 View Post
=============
Intel website (https://downloadcenter.intel.com/Sea...as%20usb%203.0) shows 4 drivers, and also firmware update:
I have downloaded the 4/10/2012 driver version 2.1.28.1

Firmware is shown as 5/9/2013 4.0.2.1; 2.0.2.0 Do I need to download and install this?
I have one USB 3.0 port on the back of the Lenovo laptop, BUT the Intel notes indicate that this firmware
is for "This download record provides firmware updates for the back panel and front panel USB 3.0 ports (blue connectors) on the Intel® Desktop Boards DX79SR and DX79TO." and describes them as having multiple USB 3.0 ports on the front and/or back, SO I don't think I have the correct firmware on Intel website, if indeed I need firmware update as well.
My System SpecsSystem Spec
05 Jun 2014   #9
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Right, that Intel page just won't fully load for me at work so I can't see 100% what's on there yet, but it looks as though that's the firmware update you'll need. Let me verify that later though first before you go ahead. One thing I did notice is that you were in the 'Desktop Boards' section, can you let me know how you got there, as you have a Thinkpad it may be an issue.
My System SpecsSystem Spec
05 Jun 2014   #10
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hiyya B I downloaded it ok but am not knowing what I am looking for but if it is the driver for Renesas it is https://downloadcenter.intel.com/Det...*&DownloadType=

John
My System SpecsSystem Spec
Reply

 Several BSODs recent install of MS OneDrive; USB ext. HDs fail




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Getting various BSODs, most recent is 0x000000f4
Hello, so I had a problem described in this thread: http://www.sevenforums.com/backup-restore/351394-system-restore-not-working-after-bsod-3.html but it was succesfully solved. Basically my computer (Sony Vaio vpcsb4m9e) crashed with a BSOD and it was hard to get Windows working again. Before I...
BSOD Help and Support
Recent BSODs
OEM Windows 7 Home Premium 64bit. System is approximately 1.3 years old and the OS has not been reinstalled since the initial install (mainly cause it is on an SSD). I have recently had some BSODs while gaming that claim to be due to a hardware error. My computer is normally overclocked,...
BSOD Help and Support
Win 7 crash - SP1 fail - repair install fail
I am really stuck. My installation of Win 7 Ultimate has a problem. It will not install SP1, occasionally dies with the BSOD, sfc shows corrupt files that it cannot repair, start up repair from the repair disk cannot repair problems, and a repair install from the OEM disk terminates before it...
BSOD Help and Support
Recent BSODs
I've recently started having a lot of seemingly random BSODs over the past couple of weeks and I can't think of any recent hardware or software changes that could have caused it. I have attached the details as instructed. I have a full copy of Windows 7 Professional 64-bit System details...
BSOD Help and Support
Recent BSODs
Hello everyone, I'm getting recent BSODs , and I'd like to resolve this issue. I'm running Windows 7 Home Premium 64bit, upgraded from Vista. I got a BSOD from Bad Company 2's singleplayer, 2 from its multiplayer and today one from Assassin's Creed 2. After Bad Company 2's BSODs I upgraded my...
BSOD Help and Support
recent BSODs
Recently I've been getting a STOP 0x0000001E KMODE_EXCEPTION_NOT_HANDLED Error Message and have no idea how to diagnose it or what to look for. Also, My computer has started to shut down completely without even displaying a STOP Error Message and during start up it gets stuck on the black...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App