Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD when installing AMD graphics driver atikmdag.sys BSOD

14 Oct 2014   #1
nick7969

Windows 8.1 64 bit
 
 
BSOD when installing AMD graphics driver atikmdag.sys BSOD

I've tried formatting windows 8 and also tried installing drivers seperately for both cards. Nothing has worked so far for me. I am trying to run these cards in crossfire. Both are 7950. As soon as it gets to the part where it installs the display driver, the screen goes black the first time, shortly thereafter the screen goes black second time and suddenly I get a bsod with atikmdag.sys. I've attached my bsod log below. Thank You.


My System SpecsSystem Spec
.
14 Oct 2014   #2
nick7969

Windows 8.1 64 bit
 
 

I have tried using display uninstaller, uninstalling amd install manager but none of these have worked so far. I have tried amd catalyst 14.4 and 14.9.
My System SpecsSystem Spec
14 Oct 2014   #3
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Hi Nick.

If you dont use crossfire and apply a single card only, does it behave the same? Try it and let us know.
____________________________________________
Code:
*** WARNING: Unable to verify timestamp for atikmdag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmdag.sys
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {ffffffffc0000005, fffff801a7643195, ffffd0011a713858, ffffd0011a713060}

Probably caused by : atikmdag.sys ( atikmdag+41195 )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
happening.
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff801a7643195, The address that the exception occurred at
Arg3: ffffd0011a713858, Exception Record Address
Arg4: ffffd0011a713060, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP: 
atikmdag+41195
fffff801`a7643195 8179084c49434d  cmp     dword ptr [rcx+8],4D43494Ch

EXCEPTION_RECORD:  ffffd0011a713858 -- (.exr 0xffffd0011a713858)
ExceptionAddress: fffff801a7643195 (atikmdag+0x0000000000041195)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

CONTEXT:  ffffd0011a713060 -- (.cxr 0xffffd0011a713060;r)
rax=fffff801a763ad20 rbx=ffffd0011a713b20 rcx=c2f6108df5a8799a
rdx=ffffd0011a713b20 rsi=0000000000000100 rdi=ffffd0011a713c08
rip=fffff801a7643195 rsp=ffffd0011a713a98 rbp=ffffd0011a713b51
 r8=0000000000000000  r9=0000000000000005 r10=0000000000000070
r11=fffff801a77e1e93 r12=fffff801a77ec8f0 r13=0000000000000000
r14=ffffd0011a713c80 r15=0000000000000d28
iopl=0         nv up ei ng nz na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
atikmdag+0x41195:
fffff801`a7643195 8179084c49434d  cmp     dword ptr [rcx+8],4D43494Ch ds:002b:c2f6108d`f5a879a2=????????
Last set context:
rax=fffff801a763ad20 rbx=ffffd0011a713b20 rcx=c2f6108df5a8799a
rdx=ffffd0011a713b20 rsi=0000000000000100 rdi=ffffd0011a713c08
rip=fffff801a7643195 rsp=ffffd0011a713a98 rbp=ffffd0011a713b51
 r8=0000000000000000  r9=0000000000000005 r10=0000000000000070
r11=fffff801a77e1e93 r12=fffff801a77ec8f0 r13=0000000000000000
r14=ffffd0011a713c80 r15=0000000000000d28
iopl=0         nv up ei ng nz na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
atikmdag+0x41195:
fffff801`a7643195 8179084c49434d  cmp     dword ptr [rcx+8],4D43494Ch ds:002b:c2f6108d`f5a879a2=????????
Resetting default scope

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  ffffffffffffffff

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80343dcb138
unable to get nt!MmNonPagedPoolStart
unable to get nt!MmSizeOfNonPagedPoolInBytes
 ffffffffffffffff 

FOLLOWUP_IP: 
atikmdag+41195
fffff801`a7643195 8179084c49434d  cmp     dword ptr [rcx+8],4D43494Ch

BUGCHECK_STR:  AV

ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre

LAST_CONTROL_TRANSFER:  from fffff801a763ad48 to fffff801a7643195

STACK_TEXT:  
ffffd001`1a713a98 fffff801`a763ad48 : 00000000`00000001 ffffd001`1a713b60 ffffe000`fe317000 00000000`424c5050 : atikmdag+0x41195
ffffd001`1a713aa0 00000000`00000001 : ffffd001`1a713b60 ffffe000`fe317000 00000000`424c5050 00000000`00003a98 : atikmdag+0x38d48
ffffd001`1a713aa8 ffffd001`1a713b60 : ffffe000`fe317000 00000000`424c5050 00000000`00003a98 00000000`00000044 : 0x1
ffffd001`1a713ab0 ffffe000`fe317000 : 00000000`424c5050 00000000`00003a98 00000000`00000044 00000000`00000044 : 0xffffd001`1a713b60
ffffd001`1a713ab8 00000000`424c5050 : 00000000`00003a98 00000000`00000044 00000000`00000044 00000000`00000001 : 0xffffe000`fe317000
ffffd001`1a713ac0 00000000`00003a98 : 00000000`00000044 00000000`00000044 00000000`00000001 ffffd001`1a713c00 : 0x424c5050
ffffd001`1a713ac8 00000000`00000044 : 00000000`00000044 00000000`00000001 ffffd001`1a713c00 fffff801`a8179f73 : 0x3a98
ffffd001`1a713ad0 00000000`00000044 : 00000000`00000001 ffffd001`1a713c00 fffff801`a8179f73 00000000`000004b3 : 0x44
ffffd001`1a713ad8 00000000`00000001 : ffffd001`1a713c00 fffff801`a8179f73 00000000`000004b3 00000000`00002710 : 0x44
ffffd001`1a713ae0 ffffd001`1a713c00 : fffff801`a8179f73 00000000`000004b3 00000000`00002710 00000000`00000001 : 0x1
ffffd001`1a713ae8 fffff801`a8179f73 : 00000000`000004b3 00000000`00002710 00000000`00000001 00000000`000007ff : 0xffffd001`1a713c00
ffffd001`1a713af0 00000000`000004b3 : 00000000`00002710 00000000`00000001 00000000`000007ff ffffd001`1a713bd8 : atikmdag+0xb77f73
ffffd001`1a713af8 00000000`00002710 : 00000000`00000001 00000000`000007ff ffffd001`1a713bd8 fffff801`a763d71b : 0x4b3
ffffd001`1a713b00 00000000`00000001 : 00000000`000007ff ffffd001`1a713bd8 fffff801`a763d71b 0000003f`00000060 : 0x2710
ffffd001`1a713b08 00000000`000007ff : ffffd001`1a713bd8 fffff801`a763d71b 0000003f`00000060 00000000`00000000 : 0x1
ffffd001`1a713b10 ffffd001`1a713bd8 : fffff801`a763d71b 0000003f`00000060 00000000`00000000 ffffd001`1a713c80 : 0x7ff
ffffd001`1a713b18 fffff801`a763d71b : 0000003f`00000060 00000000`00000000 ffffd001`1a713c80 00000000`00000100 : 0xffffd001`1a713bd8
ffffd001`1a713b20 0000003f`00000060 : 00000000`00000000 ffffd001`1a713c80 00000000`00000100 ffffd001`1a713c08 : atikmdag+0x3b71b
ffffd001`1a713b28 00000000`00000000 : ffffd001`1a713c80 00000000`00000100 ffffd001`1a713c08 ffffd001`1a713c00 : 0x0000003f`00000060


SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  atikmdag+41195

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: atikmdag

IMAGE_NAME:  atikmdag.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  54176654

STACK_COMMAND:  .cxr 0xffffd0011a713060 ; kb

FAILURE_BUCKET_ID:  AV_atikmdag+41195

BUCKET_ID:  AV_atikmdag+41195

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:av_atikmdag+41195

FAILURE_ID_HASH:  {8240ca91-b767-935f-390c-e6e9623a62a7}

Followup: MachineOwner
---------

1: kd> lmvm atikmdag
start             end                 module name
fffff801`a7602000 fffff801`a866c000   atikmdag T (no symbols)           
    Loaded symbol image file: atikmdag.sys
    Image path: \SystemRoot\system32\DRIVERS\atikmdag.sys
    Image name: atikmdag.sys
    Timestamp:        Tue Sep 16 03:51:08 2014 (54176654)
    CheckSum:         00FFED07
    ImageSize:        0106A000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
My System SpecsSystem Spec
.

14 Oct 2014   #4
nick7969

Windows 8.1 64 bit
 
 

When doing driver installation for single card, it does not cause bsod. The installation works fine. What I have noticed is, when I have my powercolor in slot 1 my display device is named R9 series in device manager. When I install the sapphire on slot 2 alone, the name remains 7900. So I don't know what is causing this. Could be the bridge?
My System SpecsSystem Spec
15 Oct 2014   #5
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Quote   Quote: Originally Posted by nick7969 View Post
When doing driver installation for single card, it does not cause bsod. The installation works fine. What I have noticed is, when I have my powercolor in slot 1 my display device is named R9 series in device manager. When I install the sapphire on slot 2 alone, the name remains 7900. So I don't know what is causing this. Could be the bridge?
The chance is there, obviously. I will ask our hardware experts to have a look at your issue.

In the mean time, you complete your System Specs with detailed information about your PSU and cooler. It will help our hardware experts to have a better idea about your system.
See your system specs and fill it up here.
My System SpecsSystem Spec
15 Oct 2014   #6
nick7969

Windows 8.1 64 bit
 
 

Thank you. I uploaded my psu, cooler and cooling section.
My System SpecsSystem Spec
15 Oct 2014   #7
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

nick7969, look at the specs unless you know them. The core clock and boost clock on both need to be the same as well as the Vram. Is that the case?

Also, please look in BIOS and give us the values of the +12V, +5V and +3.3V

If I understand you, your Motherboard is reading the cards as different models. I'm not sure why, but maybe the Tech Support for that card could tell you why.
My System SpecsSystem Spec
15 Oct 2014   #8
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Read here and see if you may find something to help AMD CrossFire? FAQ
My System SpecsSystem Spec
15 Oct 2014   #9
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Thanks a great lot, Steve.
My System SpecsSystem Spec
15 Oct 2014   #10
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Don't thank me yet. We haven't solved it, so far.
My System SpecsSystem Spec
Reply

 BSOD when installing AMD graphics driver atikmdag.sys BSOD




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD after installing AMD Radeon HD 7970M graphics driver
I found an older thread here with the exact same problem on your forums but a solution had not been found then. I was playing a video game when my laptop crashed. I restarted it and got BSOD. On other attempts I would get to the Windows loading screen but it would then result in a blank black...
BSOD Help and Support
Graphics card related BSOD on startup - atikmdag.sys, dxgkrn1.sys
I have a Toshiba Satellite S50D-A that was given to me last August. It came with Win8 and between compatibility issues with my older software and Win8.1 turning it into a bread-warmer (running hot and largely useless) in December I downgraded it to Windows 7 Home Premium 64-Bit, making use of the...
BSOD Help and Support
BSOD caused by the following module: atikmdag.sys (atikmdag+0x19C6D)
I hope anybody can help me....i already have the latest drivers but i still get BSOD's
BSOD Help and Support
BSOD while installing Graphics driver for EVGA GeForce GTX 550 Ti
I have an EVGA GeForce GTX 550 Ti, wanted to update the driver, and it kept giving me a BSOD. When I play games it never gives me a BSOD. I've attached the dump to this thread. Could someone help me figure out what the problem is? A while ago, I had a RAM problem, but I bought new RAM and it was...
BSOD Help and Support
BSOD after idling, error 0x1000007e driver atikmdag.sys
Recently upgraded my computer and did a clean install of windows 7. Current system specs are: i5 3570k noctua nh-u12p se2 cooler gigabyte z77x-ud3h 16gb samsung 30 nm 1600 ram silverstone strider plus 850w psu samsung 830 256gb ssd 2x640gb caviar black raid 0
BSOD Help and Support
BSOD When (un)installing ATI Graphics Driver
Ok. I'm trying to upgrade my ATI Catalyst Driver to the latest version. When I try to do so, the installer causes a BSOD when on "Detecting Graphics Hardware...". The code is 0x0000001E, with no driver stated. I've also tried to uninstall the graphics driver through the Add/Remove Programs and...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App