Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD on startup (Ha20x22k.sys)

24 Oct 2014   #1
bimbim18

Florida
 
 
BSOD on startup (Ha20x22k.sys)

Power outage the other night (not sure if it's related)
On startup (during windows splash screen) constant BSOD referencing driver Ha20x22k.sys
(crappy pic from phone here Click This )

After scouring the web seems its a creative driver. I uninstalled and reinstalled anything related to Creative or Creative labs as well as my video drivers. even went into the system32 folder and manually deleted the driver. BSOD still returns. Removing the sound card allows my PC to run fine (as right now) but no matter what I do re-installing sound card (Fatal1ty X-fi Titanium pro) leads to immediate return of BSOD

used a reg cleaner, while it cleaned my dirty registry no help for the problem.

Any help would be greatly appreciated.


My System SpecsSystem Spec
.
24 Oct 2014   #2
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

My System SpecsSystem Spec
24 Oct 2014   #3
bimbim18

Florida
 
 

hmm crashed while i was updating some drivers and running the DM Log collector. here you go. I will be away from my PC for a bit (going out of town for a night). Thank you
My System SpecsSystem Spec
.

24 Oct 2014   #4
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Your logs are empty, can you run the tool again and upload new logs.
My System SpecsSystem Spec
24 Oct 2014   #5
bimbim18

Florida
 
 

OK, I opened this one it's not empty like the last one. Sorry about that.

By the way several more BSODs updating more drivers. Mostly concerned with the ones pertaining to the Ha20x22k.sys though.
My System SpecsSystem Spec
24 Oct 2014   #6
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

1: Bitdefender is causing issues.

Code:
fffff880`035ee1b8  fffff880`0137b55fUnable to load image \SystemRoot\system32\DRIVERS\gzflt.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for gzflt.sys
*** ERROR: Module load completed but symbols could not be loaded for gzflt.sys
 gzflt+0xb55f
Uninstall BitDefender and install MS Security Essentials and MalwareBytes.

Note   Note
Make sure you uncheck the 'Enable Free Trial' box when installing MalwareBytes.




2: Your Intel USB3.0 hub driver is causing issues. It's old and needs updating.

Code:
*** WARNING: Unable to verify timestamp for iusb3hub.sys
*** ERROR: Module load completed but symbols could not be loaded for iusb3hub.sys

3: kd> lmvm iusb3hub
start             end                 module name
fffff880`05eb6000 fffff880`05f15000   iusb3hub T (no symbols)           
    Loaded symbol image file: iusb3hub.sys
    Image path: \SystemRoot\system32\DRIVERS\iusb3hub.sys
    Image name: iusb3hub.sys
    Timestamp:        Fri Dec 21 14:40:46 2012 (50D474EE)
    CheckSum:         00062CFB
    ImageSize:        0005F000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Check for an updated version here.

3: This is the one you wanted to know about. This is your Creative Audio driver.

Code:
fffff880`035f4b38  fffff880`046c7000Unable to load image \SystemRoot\system32\drivers\ctaud2k.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ctaud2k.sys
*** ERROR: Module load completed but symbols could not be loaded for ctaud2k.sys
 ctaud2k

2: kd> lmvm ctaud2k
start             end                 module name
fffff880`046c7000 fffff880`04770700   ctaud2k  T (no symbols)           
    Loaded symbol image file: ctaud2k.sys
    Image path: \SystemRoot\system32\drivers\ctaud2k.sys
    Image name: ctaud2k.sys
    Timestamp:        Tue Dec 18 12:02:52 2012 (50D05B6C)
    CheckSum:         000BB00A
    ImageSize:        000A9700
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
And this is Creative Technology Audigy

Code:
2: kd> lmvm ha20x22k
start             end                 module name
fffff880`06c16000 fffff880`06da4000   ha20x22k T (no symbols)           
    Loaded symbol image file: ha20x22k.sys
    Image path: \SystemRoot\system32\drivers\ha20x22k.sys
    Image name: ha20x22k.sys
    Timestamp:        Tue Dec 18 12:00:49 2012 (50D05AF1)
    CheckSum:         0018DD03
    ImageSize:        0018E000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
They need updating. Check for updates here.
My System SpecsSystem Spec
24 Oct 2014   #7
bimbim18

Florida
 
 

#3 Hmm I installed the newest drivers available. That's what installed(fresh uninstall, reinstall, update).

Iirc my usb3.0 causes bsod on install.

When I get home tomorrow I'll try your recommendations. Thanks
My System SpecsSystem Spec
25 Oct 2014   #8
bimbim18

Florida
 
 

Is there a source to download only that driver? Creative only has a package, which is where I got that same driver from in the first place.
My System SpecsSystem Spec
25 Oct 2014   #9
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

I've no idea sorry mate. Is it a soundcard I take it?
My System SpecsSystem Spec
26 Oct 2014   #10
bimbim18

Florida
 
 

yes it is. Ran Malwarebytes. trying to update some of my USB drivers (they have always given me problems since I bought this mobo.) If i can get a few to stick ill move back to sound card drivers. Getting late and time is limited so i may not have time till tomorrow. I'll keep you updated as I find time to fiddle with this more. Thanks for the constant feedback.
My System SpecsSystem Spec
Reply

 BSOD on startup (Ha20x22k.sys)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD during windows startup; can't safe mode; startup repair can't fix
Consistent BSOD during Windows startup for both normal mode and safe mode. BSOD problem started shortly after buggy installations of Microsoft Visual C++ 2005 x64, Microsoft .Net Framework 1.1, and AMD Catalyst Drivers 13.9; and turning off Microsoft .Net Framework 3.5.1. Startup Repair is...
BSOD Help and Support
Brief BSOD on Startup, Startup Recovery Hangs
I have Win 7 Home and in the last couple of days I have been trying to do a backup onto an external drive. The problem comes in when I attempt to start my laptop so that I can begin the backup process, the screen flickers a BSOD, says startup failed and do I want to run Startup Recovery. If I say...
BSOD Help and Support
BSOD on startup, unknown error, startup repair running too long
As the title suggests, my Acer Aspire has been running startup repair for over 20 hours following a BSOD yesterday. I'm not sure if it's worth the wait so maybe you all can shed some light. Yesterday I was stressfully trying to search for something (using Chrome) and the website I was on froze;...
BSOD Help and Support
BSOD on Startup - Startup Reapir not working
On Startup, after POST, I get this BSOD: STOP: c000021a {Fatal System Error} The verification of a knownDLL failed. system process terminated unexpectedly with a status of 0xc000012f (0x00360bf0 0x00000000). The system has shut down. Upon Reboot, I am advised to go to the startup repair....
BSOD Help and Support
BSOD at startup, cant repair startup
i had a bsod 3 days ago with no reason when its at Welcome screen and my startup items are not loaded at all(all drivers programs etc.). i tried to reboot and my pc gone wild. it cant even see welcome screen cuz of bsods. also i am having black screens when booting up. sometimes its just freezes...
BSOD Help and Support
BSOD on startup , error 0x000000f4 . startup takes half an hour
so everything was fine when my laptop started to become very slow and i used to get the BSOD very often so i decided to recover the system to the initial state . i did that and everything was fine , then i updated the windows 7 service pack 1 and finished the installation and rebooted my computer ,...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App