Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSODs for a year and a half, does this look like bad RAM?

17 Feb 2015   #1
RayzTheRoof

Windows 7 Professional 64-bit
 
 
BSODs for a year and a half, does this look like bad RAM?

For the past year and a half I have been getting crashes about once a month, while doing basically anything from gaming to browsing the interwebs with Chrome. The crash was always a generic hardware failure message, and I tested everything and all tests came back clean. Memtest specifically even reported no errors after the recommended (from a guide here somewhere) number of passes.

But within the past month I have gotten two new types of BSODs. About a week ago I got a "Page_Fault_In_Nonpaged_Area" BOSD. and just now I got one that said "IRQL_NOT_LESS_OR_EQUAL", but using WinDbg reported this (not sure of it's a memory issue, because it says code corruption at first... though I am not sure of any of this because I don't know how to read these things properly anyway, and I uploaded the past 4 minidumps I got):

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800034fb100
0000000000000008

CURRENT_IRQL: 2

FAULTING_IP:
nt!KiInsertQueue+12b
fffff800`032c429b 48894108 mov qword ptr [rcx+8],rax

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: CODE_CORRUPTION

BUGCHECK_STR: 0xA

PROCESS_NAME: chrome.exe

TRAP_FRAME: fffff8800e08b800 -- (.trap 0xfffff8800e08b800)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa80123ab260 rbx=0000000000000000 rcx=0000000000000000
rdx=fffffa800ddbee70 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800032c429b rsp=fffff8800e08b990 rbp=0000000001ff4b00
r8=0000000000000000 r9=0000000000000000 r10=fffff80003448980
r11=00000000001f0003 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei ng nz na pe nc
nt!KiInsertQueue+0x12b:
fffff800`032c429b 48894108 mov qword ptr [rcx+8],rax ds:54c0:00000000`00000008=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER: from fffff800032c1469 to fffff800032c1ec0

STACK_TEXT:
fffff880`0e08b6b8 fffff800`032c1469 : 00000000`0000000a 00000000`00000008 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0e08b6c0 fffff800`032c00e0 : fffff880`0e08ba88 00000000`0015e9f8 00000000`00000001 fffffa80`1256c080 : nt!KiBugCheckDispatch+0x69
fffff880`0e08b800 fffff800`032c429b : 00000000`00000000 fffff800`032cbf3c fffffa80`133854e0 fffffa80`125ea060 : nt!KiPageFault+0x260
fffff880`0e08b990 fffff800`03555dcc : fffffa80`00000000 fffffa80`0ddbee70 00000000`01ff4b00 00000000`00000000 : nt!KiInsertQueue+0x12b
fffff880`0e08ba10 fffff800`032c1153 : fffffa80`125a2b50 fffff880`0e08bb60 00000000`0015e0f8 fffff800`035bb664 : nt!NtSetIoCompletion+0x9c
fffff880`0e08ba70 00000000`77a0291a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0015e0d8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77a0291a


STACK_COMMAND: kb

CHKIMG_EXTENSION: !chkimg -lo 50 -d !nt
fffff800032c49c2 - nt!SwapContext_PatchXSave+2
[ 01:21 ]
fffff800032c4aa6 - nt!SwapContext_PatchXRstor+2 (+0xe4)
[ 09:29 ]
fffff800032c4c62 - nt!EnlightenedSwapContext_PatchXSave+2 (+0x1bc)
[ 01:21 ]
fffff800032c4d48 - nt!EnlightenedSwapContext_PatchXRstor+2 (+0xe6)
[ 09:29 ]
4 errors : !nt (fffff800032c49c2-fffff800032c4d48)

MODULE_NAME: memory_corruption

IMAGE_NAME: memory_corruption

FOLLOWUP_NAME: memory_corruption

DEBUG_FLR_IMAGE_TIMESTAMP: 0

MEMORY_CORRUPTOR: ONE_BIT_LARGE

FAILURE_BUCKET_ID: X64_MEMORY_CORRUPTION_ONE_BIT_LARGE

BUCKET_ID: X64_MEMORY_CORRUPTION_ONE_BIT_LARGE

Followup: memory_corruption


My System SpecsSystem Spec
.
17 Feb 2015   #2
RayzTheRoof

Windows 7 Professional 64-bit
 
 

To add, the past two errors seem to be page file related. The page file isn't on my boot SSD but rather on one of my HDDs. Could a bad HDD also be the cause?
My System SpecsSystem Spec
Reply

 BSODs for a year and a half, does this look like bad RAM?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Multiple different BSODs over a span of roughly a year and a half.
Hello all, I've been receiving intermittent BSODs for a long time now and I'm running out of ideas on what to try to get it fixed. I've reinstalled windows, I've replaced RAM, I've replaced my GPU and tried using other forums to get to the bottom of the issue to no avail. If you want to see...
BSOD Help and Support
Is the Intel 530 SSD worth buying for a two and half year old laptop?
I keep reading it's mediocre in performance compared to many others and i can't afford the 700 series, right now i just have a 5400 rpm hard drive that came with the laptop. I know Samsung is popular as well , is it superior to the Intel? Thanks folks
Hardware & Devices
ntoskrnl.exe, ntfs.sys, etc. - Having BSODs for a year and a half
Hi, I hope someone can help. I have been getting BSODs here and there ever since I put this computer together in August 2010. It's become intolerable and I am just so sick of it... I am running full retail Home Premium x64 on this platform: MSI 890GXM-G65 mainboard AMD Phenom II X4 BE 965...
BSOD Help and Support
Consistent BSODs for over a year.
Hi All, I built this computer in December 2009. Since its creation I have been getting consistent BSODs. BSODs occur randomly. Sometimes they occur a few minutes after starting a game (Mass Effect, SC2, etc). Sometimes the computer will be idling, and I will come back to it to find "Windows...
BSOD Help and Support
Unable to install/play Half-Life Game of the Year Edition
Hi, I bought Half-Life Game of the Year Edition on CD and I can't to re-install or even play Half-Life Game of the Year Edition at all. I ripped it to an .iso and all my friends are able to install and play using the .iso, everyone except me for some reason. We all have Windows 7, cleaning...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App