Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Random BSOD over past 6 months. Error 0x000000d1 ntoskrnl.exe+74ec0

01 Mar 2015   #1
Defaultsound

Windows 7 64 bit
 
 
Random BSOD over past 6 months. Error 0x000000d1 ntoskrnl.exe+74ec0

Hello all,

Over the past 6 months or so I have been getting random BSODs with no obvious symptoms of what is causing them.

They started happening last September after I got back from the Summer. To begin with I tried to diagnose the problem following various guides to try and work out what could be causing them. I did the following:
  • Memtest
  • Reg check
  • Driver Verifier
  • Updated Drivers
  • Checked for any physical damage on hardware
  • Tried restoring

No matter what I did I could not either fix the problem or find the cause of the problem. The main reason for this was the "ntoskrnl.exe+XXXXX" would appear each time on each crash, and searching online I could not find a definitive reason or answer to the crashes.

So I decided in the meantime to live with the possible chance that I would BSOD every now and then. For the most part this was fine as they became less frequent.

Then came today. I've had 3 BSOD in one day and now its starting to irritate me. Knowing that my previous efforts to try and find a solution were to no results, I just don't know what to do. I'm getting the point that I might just rip out all my hardware and start fresh, but that won't be for another 3 months or so.

So here are the .dmps from September till now. Looking at them in BlueScreenView the Caused Driver and Address are all different, there are some common patterns such as the "Qualcomm Atheros Driver" I did update this but ended up making the problem worse, as it made my Ethernet cut out completely. Therefore I rolled back the driver.

If anyone has any ideas or can diagnose the problem better that would be grand.

My last thoughts are to what the problem might be could be involving my antivirus - BullGuard. To my memory that was the last Program I installed before I went away for the summer. Since switching to BullGuard I have noticed a lot more problems, but that could just be coincidence.
Attachment 351194


My System SpecsSystem Spec
.
02 Mar 2015   #2
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Update Atheros LAN driver from http://www.gigabyte.in/products/prod...px?pid=4144#dl
Code:
BugCheck D1, {28, 2, 0, fffff880018fc360}

*** WARNING: Unable to verify timestamp for L1C62x64.sys
*** ERROR: Module load completed but symbols could not be loaded for L1C62x64.sys
Probably caused by : L1C62x64.sys ( L1C62x64+6a5f )

Followup: MachineOwner
---------
Code:
    Image name: L1C62x64.sys
    Timestamp:        Wed Apr 25 10:37:17 2012 (4F978685)
One more thing is there .... Agnitum Firewall. I dont know what is it, but as it is contributing to the BOSDs, it should be uninstalled. Probably it is branded as Outpost.
Code:
fffff880`03319e68  fffff880`04d84738Unable to load image \SystemRoot\system32\DRIVERS\afwcore.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for afwcore.sys
*** ERROR: Module load completed but symbols could not be loaded for afwcore.sys
 afwcore+0x59738
Code:
fffff880`03319d48  fffff880`04d1d000Unable to load image \SystemRoot\system32\DRIVERS\afw.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for afw.sys
*** ERROR: Module load completed but symbols could not be loaded for afw.sys
 afw
Let us know the situation after doing these two.
My System SpecsSystem Spec
02 Mar 2015   #3
Defaultsound

Windows 7 64 bit
 
 

Hi,

Thanks for the reply, I will try what you suggest.

I looked into the Agnitum Firewall and turns out its part of BullGuard..

Quote:
The Agnitum driver is part of the BullGuard Firewall. Use the tool attached to this post in order to remove any BullGuard leftovers before reinstall.
Note: if you are asked to reboot your PC after using the Uninst tool, please do so.
Agnitum's firewall - Free Antivirus Forum

Not sure what to do.. mhmm Maybe time to change Anti Virus? Would make sense since before BullGuard I had no issues. Personally I haven't liked BullGuard one bit.
My System SpecsSystem Spec
.

03 Mar 2015   #4
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

You may part your job into two parts. First update the driver and see how it works.

If BSODs continue, uninstall BullGuard.
My System SpecsSystem Spec
Reply

 Random BSOD over past 6 months. Error 0x000000d1 ntoskrnl.exe+74ec0




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD: ntoskrnl.exe+74ec0: error 0x000000c5 [DRIVER_CORRUPTED_EXPOOL]
Hi, sorry, not sure what I am doing to generate this error. I have recently had problems where the network connection fails and I cannot connect to any sites. I cannot bring up the task manager and when I try to restart the system just freezes. I can close my open programs and save. This...
BSOD Help and Support
BSOD 0x000000FC & 0x00000050 ntoskrnl.exe (74ec0 & 76e80)+ Win32k.sys
Greetings Seven Forums. I've been encountering constant BSODs consisting of page fault in nonpaged area and attempted execute of non executable memory! I have run memtest for 24 hours without errors. Additionally, I am running on no overclocks. Chkdsk found no errors in my hard drive, a Western...
BSOD Help and Support
BSOD STOP: ntoskrnl.exe+74ec0: error 0x0000007F
I have a Lenovo Z570 (i5-2450m + 6GB ram + NVidia gt520m) + Windows 7 Ultimate I get BSOD when I try to watch a youtube video in Firefox. I have to say that this laptop has a physical switch to turn on and of Nvidia. Otherwise it uses Intel HD Grapics. During the BSOD Nvidia was disabled. ...
BSOD Help and Support
BSOD ntoskrnl.exe+74ec0 and 76e80
Hi, I'm new to this all, but am having a problem with BSOD's and it is driving me bonkers! If anyone is willing to help me out it would be greatly appreciated! here is the log info, hopefully I did this right! Thanks
BSOD Help and Support
BSOD for the past several months, Error 0x0000001E
Since about 7 months back I've been experiencing a BSOD on my Toshiba Satellite C655D-S5529 laptop. It would happen upon logging into my account and would only stop if I booted up in safe mode. Other people use the computer too so I can't be quite sure what may have caused it but since this week it...
BSOD Help and Support
random BSOD, restarts for the past 2 months
Hey everybody, I've been getting system crashes and restarts for the past two months. It seems to be completely random and I never use any programs that are too intensive - at most photoshop. In the first day it happened, it restarted 5 times within half an hour. This was helped by me doing a...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App