Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: w7 64 randomly hangs


17 Nov 2009   #1

Windows 7 Ultimate 64
 
 
w7 64 randomly hangs

I have done a clean install on my Sony Vaio VGN-FZ31S and Windows 7 64 is working great. Unfortunately the computer crashes around twice a day with a total freeze where nothing works anymore. The probem occurs at random. The system just hangs completely and the soundcard makes a terrible noise. Sometimes it gives a blue screen and restarts automatically.

Is there any way to pinpoint what is causing the issue?

Any suggestions are appreciated.


My System SpecsSystem Spec
.

17 Nov 2009   #2

Windows 7 Ultimate x64 (Retail)
 
 

You should take a look in the "event viewer" (start, search, type "event viewer" & hit return), expand the application tab and look for error messages. That may provide some clues as to what is causing the problem.

You may also want to run the system file checker which scans for corrupt system files and attempts to repair any it finds. Open a command prompt with administrative privileges and type "sfc /scannow" without the quotes and hit enter and wait for it complete which takes a few minutes. At the end, it should indicate whether any system files were corrupt and whether they were repaired.

You may also want to try doing a repair install which leaves your programs, data and most settings intact.

The above links are to tutorials on this site which explain these things in greater detail with step by step instructions.
My System SpecsSystem Spec
17 Nov 2009   #3

Windows 7 Ultimate x86-64
 
 

You can also post the .dmp file from the screens. Look in C:\Windows or in a folder entitled minidump.
My System SpecsSystem Spec
.


17 Nov 2009   #4

Windows 7 Ultimate (64)
 
 

If the sound card is playing weird stuff while the machine locks up it's an indication of an address or irq conflict with that device. You may want to go to device manager and see if you can manually change either...


Quote   Quote: Originally Posted by dickreuter View Post
I have done a clean install on my Sony Vaio VGN-FZ31S and Windows 7 64 is working great. Unfortunately the computer crashes around twice a day with a total freeze where nothing works anymore. The probem occurs at random. The system just hangs completely and the soundcard makes a terrible noise. Sometimes it gives a blue screen and restarts automatically.

Is there any way to pinpoint what is causing the issue?

Any suggestions are appreciated.
My System SpecsSystem Spec
22 Nov 2009   #5

Windows 7 Ultimate 64
 
 

My guess is that most probably there is a connection to the video driver as it always occurs when I'm watching a movie. I couldn't find anything useful in the event viewer. The .dmp file is over 300MB. Any suggestions how I can analyse it?

thanks
My System SpecsSystem Spec
25 Nov 2009   #6

Windows 7 Ultimate x86-64
 
 

My System SpecsSystem Spec
21 Dec 2009   #7

Windows 7 Ultimate 64
 
 

Attached my dump files. Any advice is appreciated.
My System SpecsSystem Spec
21 Dec 2009   #8

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by dickreuter View Post
Attached my dump files. Any advice is appreciated.
DR
Hi and welcome there are several causes for these dmps. I suspect since thay all deal with memory you may have either a mem problem or heat problem. this specific one porbably was caused by the TI driver
info abt it here ti21sony.sys Windows process - What is it?

I would
download memtestx86 and run it for several hours
run a system file check to verify and repair your system files


Hope this helps


Ken J+

Code:
                  
111609-32807-01.dmp    11/16/2009 10:47:06 AM    PAGE_FAULT_IN_NONPAGED_AREA    0x00000050    fffffa80`a3fac982    00000000`00000001    fffff880`05e91507    00000000`00000005    klif.sys    klif.sys+16608                    
111609-38937-01.dmp    11/16/2009 10:43:22 AM    PAGE_FAULT_IN_NONPAGED_AREA    0x00000050    fffffa80`a7d08d82    00000000`00000001    fffff880`04122507    00000000`00000005    CLASSPNP.SYS    CLASSPNP.SYS+1b110                    
111609-47985-01.dmp    11/16/2009 10:40:04 AM    PAGE_FAULT_IN_NONPAGED_AREA    0x00000050    fffffa80`a83acac2    00000000`00000001    fffff880`092bb507    00000000`00000005    klif.sys    klif.sys+431a0                    
120609-29203-01.dmp    12/6/2009 3:27:58 AM    SYSTEM_SERVICE_EXCEPTION    0x0000003b    00000000`c0000046    fffff800`032a57f8    fffff880`0c34f0a0    00000000`00000000    ntoskrnl.exe    ntoskrnl.exe+71f00                    
121309-42525-01.dmp    12/13/2009 2:50:04 AM    BUGCODE_USB_DRIVER    0x000000fe    00000000`00000008    00000000`00000006    00000000`00000006    fffffa80`062e9640    usbhub.sys    usbhub.sys+17fa                    
122009-22401-01.dmp    12/20/2009 9:12:16 AM        0x00000124    00000000`00000000    fffffa80`04ef08f8    00000000`00000000    00000000`00000000    ntoskrnl.exe    ntoskrnl.exe+4a63cc                    
122109-1010761-01.dmp    12/21/2009 6:44:30 AM        0x00000124    00000000`00000000    fffffa80`04e1d8f8    00000000`00000000    00000000`00000000    ntoskrnl.exe    ntoskrnl.exe+4a63cc
Code:
Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\K\Desktop\111609-47985-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*d:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 7 Kernel Version 7600 MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`02a5f000 PsLoadedModuleList = 0xfffff800`02c9ce50
Debug session time: Mon Nov 16 05:38:37.310 2009 (GMT-5)
System Uptime: 0 days 14:04:40.339
Loading Kernel Symbols
...............................................................
................................................................
............................................
Loading User Symbols
Loading unloaded module list
...................
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffffa80a83acac2, 1, fffff880092bb507, 5}

Unable to load image \SystemRoot\system32\drivers\ti21sony.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ti21sony.sys
*** ERROR: Module load completed but symbols could not be loaded for ti21sony.sys

Could not read faulting driver name
Probably caused by : ti21sony.sys ( ti21sony+7507 )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: fffffa80a83acac2, memory referenced.
Arg2: 0000000000000001, value 0 = read operation, 1 = write operation.
Arg3: fffff880092bb507, If non-zero, the instruction address which referenced the bad memory
    address.
Arg4: 0000000000000005, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80002d070e0
 fffffa80a83acac2 

FAULTING_IP: 
ti21sony+7507
fffff880`092bb507 806002f5        and     byte ptr [rax+2],0F5h

MM_INTERNAL_CODE:  5

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  Password .exe

CURRENT_IRQL:  0

TRAP_FRAME:  fffff88007eaafd0 -- (.trap 0xfffff88007eaafd0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa80a83acac0 rbx=0000000000000000 rcx=0000000000000005
rdx=fffff880092dbdc0 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880092bb507 rsp=fffff88007eab160 rbp=0000000000000000
 r8=00000000000000ec  r9=fffff88007eab2a0 r10=0000000000000000
r11=fffff88007eab550 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
ti21sony+0x7507:
fffff880`092bb507 806002f5        and     byte ptr [rax+2],0F5h ds:aa50:fffffa80`a83acac2=??
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002b4eb91 to fffff80002ad0f00

STACK_TEXT:  
fffff880`07eaae68 fffff800`02b4eb91 : 00000000`00000050 fffffa80`a83acac2 00000000`00000001 fffff880`07eaafd0 : nt!KeBugCheckEx
fffff880`07eaae70 fffff800`02acefee : 00000000`00000001 00000000`00000012 00000000`c0000000 00000000`00000001 : nt! ?? ::FNODOBFM::`string'+0x40f5b
fffff880`07eaafd0 fffff880`092bb507 : fffffa80`06ece300 fffff880`092dbdc0 00000000`000000ec fffff880`07eab2a0 : nt!KiPageFault+0x16e
fffff880`07eab160 fffffa80`06ece300 : fffff880`092dbdc0 00000000`000000ec fffff880`07eab2a0 0000462f`bd43fa27 : ti21sony+0x7507
fffff880`07eab168 fffff880`092dbdc0 : 00000000`000000ec fffff880`07eab2a0 0000462f`bd43fa27 fffff880`0119e667 : 0xfffffa80`06ece300
fffff880`07eab170 00000000`000000ec : fffff880`07eab2a0 0000462f`bd43fa27 fffff880`0119e667 00000000`00000000 : ti21sony+0x27dc0
fffff880`07eab178 fffff880`07eab2a0 : 0000462f`bd43fa27 fffff880`0119e667 00000000`00000000 00000000`00000000 : 0xec
fffff880`07eab180 0000462f`bd43fa27 : fffff880`0119e667 00000000`00000000 00000000`00000000 fffff880`07eab2a0 : 0xfffff880`07eab2a0
fffff880`07eab188 fffff880`0119e667 : 00000000`00000000 00000000`00000000 fffff880`07eab2a0 00000000`00000000 : 0x462f`bd43fa27
fffff880`07eab190 fffff880`0119e52d : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000001 : fltmgr!FltpGetFileName+0x127
fffff880`07eab1e0 00000000`00000001 : fffff880`07eab328 fffff880`0117d32e ffff0000`0ef410c7 fffffa80`087234f0 : fltmgr!FltpGetOpenedFileName+0x1d
fffff880`07eab210 fffff880`07eab328 : fffff880`0117d32e ffff0000`0ef410c7 fffffa80`087234f0 fffffa80`087627f0 : 0x1
fffff880`07eab218 fffff880`0117d32e : ffff0000`0ef410c7 fffffa80`087234f0 fffffa80`087627f0 00000000`00000005 : 0xfffff880`07eab328
fffff880`07eab220 fffff880`092b76be : fffff880`07eab398 fffff880`092d7100 00000000`00000000 00000000`0000000e : fltmgr!FltpGetStreamListCtrl+0x8e
fffff880`07eab280 fffff880`07eab398 : fffff880`092d7100 00000000`00000000 00000000`0000000e fffffa80`087627f0 : ti21sony+0x36be
fffff880`07eab288 fffff880`092d7100 : 00000000`00000000 00000000`0000000e fffffa80`087627f0 fffff880`0117e000 : 0xfffff880`07eab398
fffff880`07eab290 00000000`00000000 : 00000000`0000000e fffffa80`087627f0 fffff880`0117e000 00000000`000007ff : ti21sony+0x23100


STACK_COMMAND:  kb

FOLLOWUP_IP: 
ti21sony+7507
fffff880`092bb507 806002f5        and     byte ptr [rax+2],0F5h

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  ti21sony+7507

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ti21sony

IMAGE_NAME:  ti21sony.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  462cfac9

FAILURE_BUCKET_ID:  X64_0x50_ti21sony+7507

BUCKET_ID:  X64_0x50_ti21sony+7507

Followup: MachineOwner
---------
My System SpecsSystem Spec
12 Feb 2010   #9

Windows 7 Ultimate 64
 
 

I made the tests and it's definitely not a memory problem and also it's not a heat problem because the errors occur also when the cooler is running very low.

Do I really have to buy a mac? I've been trying to fix this for several weeks now and Windows 7 64 seems just to be completely unstable. I give it until the endo the month and then I'll say goodbye to Microsoft for good. Any advice is appreciated.
My System SpecsSystem Spec
14 Feb 2010   #10

Windows 7 Ultimate x86-64
 
 

Quote   Quote: Originally Posted by dickreuter View Post
I made the tests and it's definitely not a memory problem and also it's not a heat problem because the errors occur also when the cooler is running very low.

Do I really have to buy a mac? I've been trying to fix this for several weeks now and Windows 7 64 seems just to be completely unstable. I give it until the endo the month and then I'll say goodbye to Microsoft for good. Any advice is appreciated.
Can you go through the troublehshooting guide in my sig? That may isolate the issue and present a solution.
My System SpecsSystem Spec
Reply

 w7 64 randomly hangs




Thread Tools



Similar help and support threads for2: w7 64 randomly hangs
Thread Forum
Windows Explorer Hangs Randomly General Discussion
Computer hangs and becomes irresponsive randomly BSOD Help and Support
Mouse Hangs randomly Hardware & Devices
Windows 7 randomly hangs Performance & Maintenance
Windows 7 hangs up randomly BSOD Help and Support
Windows 7 randomly crashs or hangs BSOD Help and Support
System hangs/locks randomly BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:46 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33