Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 100+ Explorer.exe Processes Running

15 Dec 2009   #1
iameric

Windows 7 Ultimate 64 bit
 
 
100+ Explorer.exe Processes Running

For starters this is my first post, so hello. I'm glad to see there's such a large Windows 7 forum. I've been enjoying everything so far.



I have an

OS: Windows 7 Ultimate 64-bit
CPU: Intel I7 920
RAM: 12GB DDR3 1600 RAM
GFX: ATI 4890



After a few days of up time I notice a bit of lag, when I look at my processes Explorer.exe is running 100+ times.



There's only 6 applications (including background) running + 5 gadgets. A few gadgets are system monitors and the RAM load is at 5GB (38%) and one of the cores is just sitting at ~90.



Any ideas on what could be causing this. It's good after a restart but after a while it starts back up.

Thanks in advance for the help.


My System SpecsSystem Spec
.
16 Dec 2009   #2
Jonathan_King

Windows 7 Professional x64
 
 

Welcome!
While researching your problem, I came across this thread. Hope it helps.
~Jonathan
My System SpecsSystem Spec
16 Dec 2009   #3
Uber Philf

W7 RTM Ultimate x64
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Welcome!
While researching your problem, I came across this thread. Hope it helps.
~Jonathan
Hmm, not really logical, unless you got 100+ folders open?
My System SpecsSystem Spec
.

16 Dec 2009   #4
Jonathan_King

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Uber Philf View Post
Quote   Quote: Originally Posted by Jonathan_King View Post
Welcome!
While researching your problem, I came across this thread. Hope it helps.
~Jonathan
Hmm, not really logical, unless you got 100+ folders open?
True...
Okay, nevermind my post.
My System SpecsSystem Spec
16 Dec 2009   #5
Uber Philf

W7 RTM Ultimate x64
 
 

What AV are you running?
My System SpecsSystem Spec
16 Dec 2009   #6
iameric

Windows 7 Ultimate 64 bit
 
 

AVG Free.

I just ran Malwarebytes and found 'zbot' trojan... not good but I don't think that was the culprit.
My System SpecsSystem Spec
16 Dec 2009   #7
Uber Philf

W7 RTM Ultimate x64
 
 

Hmm, how long has this "mass explorer production" been going for?
My System SpecsSystem Spec
16 Dec 2009   #8
Jonathan_King

Windows 7 Professional x64
 
 

AVG has been known to cause problems. Try uninstalling it and installing Microsoft Security Essentials.
My System SpecsSystem Spec
17 Dec 2009   #9
iameric

Windows 7 Ultimate 64 bit
 
 

Uber - I just started noticing them this week.

Jonathan_King - Thank you. How do you all like MSE?
My System SpecsSystem Spec
17 Dec 2009   #10
TGSoldier

 
 

Nod32
Malwarebytes
Superantispyware
My System SpecsSystem Spec
Reply

 100+ Explorer.exe Processes Running




Thread Tools




Similar help and support threads
Thread Forum
How many processes should ideally be running?
Hi, right now on my system I have these things running Google Chrome 3 PDFs in Adobe Reader Call of Duty 4 Digsby Free Download Manager Steam As of now, I have 120 processes running. Is this normal for Windows 7 or in order to get ideal performance, there should be less running?
Performance & Maintenance
Do I need or can I scale down these running processes
Hi, I have just run Task Manager to see what is currently running on my PC and the desktop windows manager seems to be using quite a bit of memory. Is it best to scale this down somewhat and are there any other processes which can be disabled ? Andy
Performance & Maintenance
what is csrss.exe running in my user processes?
is this safe or what?? csrss.exe
General Discussion
2 explorer.exe processes running
Hi guys :) i have got 2 explorer.exe processes running on my system!!! as far as i can remember it happened after i installed tune up utilities 2011 (but not sure about this) can it be some kind of virus/malware?? am using MSE and comodo firewall i have Unchecked “Launch folder windows...
General Discussion
16+ svchost.exe processes running
I have recently noticed that my computer is running from 16 to 18 different processes of svchost at once, and without running any programs uses 30% of my RAM. http://i453.photobucket.com/albums/qq260/manypopes/svchost.png?t=1287308628 That screenshot was taken when running nothing but Opera....
Performance & Maintenance
# of processes you have running
Just curious as to how many you have running.? seems to be constant subject on many forums/ blogs etc. i have 34. right place to post ? cheers
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App