Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New installation Windows 7 keeps hanging

07 Jan 2010   #1

windows 7
New installation Windows 7 keeps hanging

Hi all,

First time poster on this forum but Im hoping someone can help.

I recently built a new PC for myself, all seemed to be going well until I put windows 7 on then the fun began.

The problem I am experiencing is that the OS will hang at start up which is any point from when the cursor can be seen on the screen right up until the desktop is almost loaded.
It only seems to happen if I leave the PC off for a few hours then turn it on, it hangs, turn it off then turn it on again and its fine.
Windows realises there is an issue with start up but cant resolve it so thats not much help either.

I have a feeling that it may be hardware related

For the life of me I dont know why, Im pretty sure all the hardware is compatible (could be wrong though) and only bought all this kit last weekend so can return any of it if not suitable.

Right now there is only windows 7 and the MOBO drivers disk installed along with the latest updates from Microsot and the MOBO Bios is right up to date.

Please see my list of kit below, would really appreciate any guidance or help as I cant see what the probem is.

Asus M4A785TD-M EVO, AMD 785G Chipset, DDR3, AM3, mATX
320GB Hitachi Deskstar SATA2 16MB HDT725032GLA360
TP-Link Super G & eXtended Range 108M Wireless PCI Adaptor
Arianet S001 HTPC Media Centre case - Black - mATX with 450W PSU
LiteOn 4x Internal BD-ROM Blu-Ray - bare drive with software
G.SKILL DDR3 1600 PC12800 4GB (2GB x 2)
AMD Phenom II X2 Dual Core 545 3.00GHz (Socket AM3)

My System SpecsSystem Spec

07 Jan 2010   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

My System SpecsSystem Spec
07 Jan 2010   #3

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

If you feel that it is hardware related.

Go to device manager to checke drivers.
Type memory diagnositic in search and take the test
Go to event viewer and look for errors
Check the performance monitor.
Go to task manager to make sure that all memory is recognized and being utilized.

To make sure it is not software
Go to cmd in an administrator account and typ
sfc /scannow
You can also run a repair install with the windows DVD. Boot from the DVD and select repair.
My System SpecsSystem Spec

07 Jan 2010   #4

Windows 7 Ult, Windows 8.1 Pro,

It's sounds like your having a cold boot issue of some type. Sometimes these problems are related the power supply. In your case I'd say that could easily be the problem. I would say that your correct about it being a hardware problem.

Your power supply looks a bit weak for your system. I certainly wouldn't attempt to run your board with a 450 watt power supply. The reviews are showing a much higher output PSU than one your using. I would go with something closer to 750 watts for your system depending on the GPU that you are running.
My System SpecsSystem Spec
07 Jan 2010   #5
Night Hawk

W7 Ultimate x64, W10 Pro x64 dual boot - Second remote tower W7 Pro x64

Welcome to the Se7en Forums! fyrestar

richc46 maybe onto something there if you saw a bad install of Windows where you can elect an upgrade repair install choosing the upgrade option when running the installer while booted in Windows. You may also be facing a device driver issue like for video causing Windows to hang.

When running into initial locks at startup one option upon a restart is to press the F8 key at the end of the post tests to bring up the boot option menu. Select the "Last configuration known to work" option there to see Windows perfotm a workaround of it's own to reach the desktop.

That can help a bit more then the system file checker at times as seen here with the recent 7 install on a new drive where Windows simlpy hung at the logo screen on startup. since then no further startup problems have been seen.
My System SpecsSystem Spec
07 Jan 2010   #6


If it is a startup issue as suspected (I'd go with PSU also), then it should reveal itself at moment of Startup in Performance event log found here: Control Panel\All Control Panel Items\Performance Information and Tools\Advanced Tools.

Google the likely error in full to study it's source, or post it back here in full.
My System SpecsSystem Spec
07 Jan 2010   #7
Night Hawk

W7 Ultimate x64, W10 Pro x64 dual boot - Second remote tower W7 Pro x64

One thing to add to that would be the last option seen at the bottom once you are in the Advanced Tools section there. You can use the System diagnostics tool to generate a system health report.

(that tv tuner card again! )
My System SpecsSystem Spec
07 Jan 2010   #8

Microsoft Community Contributor Award Recipient

Windows 7 SP1, Home Premium, 64-bit

I'd agree that the single most likely hardware issue would be the PSU.

It sounds intermittent and could be a short of some kind.

Do you have access to another PSU you can swap in temporarily?

Recheck your manuals to ensure that all connections on the mobo were done properly.

Here is a general guide to troubleshooting a non-booting system. It doesn't exactly apply to you, but may give you some insight.

Remove/disconnect everything but:

1) Motherboard connected to power supply.
2) CPU plugged into the motherboard (with heat sink and fan connected)
3) Power connected to the power supply and Power supply switch connected.

Disconnect all add-in cards, and drive cables. Disconnect power cables from back of drives.

Power up the system.

Does the computer beep at you? (due to lack of memory)

If it doesn't... one of three things is bad:

a) CPU
b) Motherboard
c) power supply

IF so, Add memory.


Does computer beep at you again? (due to lack of video card)

Add Video card, connect monitor to system.


Do you see video on monitor?

Add Hard Drive.


Basically; add components (critical to trivial) to see if/when it stops working. That may give you an idea if that component is toast.

If it still doesn't react, pull the motherboard from the case and lay it on a non-conductive surface like cardboard or wood, next to the case (you still need the power supply, and while you don't technically need the power switch, that's easiest.) If it does boot in this configuration, there was a short in the case. Look around for loose metal and re-assemble.

The power supply is a dumb device. If the circuitry works enough to give it an "on" signal, that doesn't mean that the motherboard is doing its appropriate voltage regulation and actually powering up all of its components.
My System SpecsSystem Spec
07 Jan 2010   #9
Night Hawk

W7 Ultimate x64, W10 Pro x64 dual boot - Second remote tower W7 Pro x64

Another thing to try would be reseating the video card as well as memory to insure those are down fully in their slots. Since video problems software or hardware related can often cause locks something may be lifted up and need to be reseated down fully.
My System SpecsSystem Spec
07 Jan 2010   #10

Win 7 Ultimate 32bit

Honestly,, you need to run full system diags.

This could any of the above or none of them....

You need to run Mem Tests (they should run for no less than 4 to 6 hours)
HDD Tests
Video Tests
Any Mobo diags you can find for that mobo

And yes, the PSU could be faulty. you should take it to a shop that can test it.
It is also possible that it is not enough power, but some people put too much power in their systems.
It all depends on what you have installed... in the system above,, personally,, I would drop anything less than 550W, and I would go with a better name,, Corsair, Antec, In-Win, etc.

Power is a strange and wonderfully nightmarish thing. It can present you with problems that aren't really problems. but replacing the PSU fixes everything.
My System SpecsSystem Spec

 New installation Windows 7 keeps hanging

Thread Tools

Similar help and support threads
Thread Forum
windows 7 installation hanging
I was sent a link to download a copy of windows 7 enterprise to see if we want to go down that route. I built a new system to put it on around an i5 760 CPU. The installation goes fine till the system reboots. The installation hangs with a message "windows is updating the registery" I tried leaving...
Installation & Setup
Windows 7 installation hanging on Intel SSD X25-M
I'm really trying to gauge opinion on this problem. For a few months I was using Windows 7 just fine on an Intel X25-M SSD drive. I had the Intel Rapid Storage Technology software installed, as well as Intel's SSD Toolbox. Then I decided to try the Windows Server 2008 R2 trial. After using...
Installation & Setup
Windows 7 Hanging on Installation
Let me start by listing the specs for this rig: MOTHERBOARD: ASUS P5QL-VM DO CPU: INTEL PENTIUM DUAL CORE E5200 2.5GHZ (not overclocked) MEMORY: 2 GB Kingston KVR800DR PSU: Rosewill RD600N-2DB-SL-BK DVD BURNER: ASUS DRW-2014LT1 (have tried a different dvd burner also)
Installation & Setup
PC hanging up after installation of Windows 7 Ultimate
Hi, I have a problem on hand with Windows 7 Ultimate. After installing the genuine pack of Windows 7 Ultimate my desktop PC performs very badly after sometime. Though the performance is good initially I find my PC slowing down with slow videos and music, hanging up every now and then. Also the...
PC hanging up after installation of Windows
Hi, after installing the genuine pack of Windows 7 Ultimate 32 bit version my desktop PC performance slows down after sometime with slow videos and music, hanging up every now and then. Also the CPU and RAM meter given by Windows 7 ultimate shows RAM usage at 70-80% and processor at 100%. PC...
Hardware & Devices
Windows 7 installation hanging..
at completion reboot stage. I successfully set up a dual boot XP Pro / Windows 7 RC 7100 on my new PC.. (Gigabyte P45-UD3R, E6750, 4GB RAM) only after updating the BIOS.. but I wanted to re-install so I formatted both the C: (XP) and D: (W7) using Acronis Disk Director, re-installed XP with no...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:56.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App