Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Another different BSOD during gameplay: Bad Company 2


11 Mar 2010   #1

Windows 7 Ultimate 64bit OEM
 
 
Another different BSOD during gameplay: Bad Company 2

This BSOD always happen, only when I'm playing Bad Company 2 Multiplayer,

Playing Singleplayer never happen, only Multiplayer.

heres the dump information,

Symbol search path is: SRV*C:\WinDDK\websymbols*Symbol information
Executable search path is:
Windows 7 Kernel Version 7600 MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`02c19000 PsLoadedModuleList = 0xfffff800`02e56e50
Debug session time: Mon Mar 8 15:52:07.020 2010 (UTC - 4:00)
System Uptime: 0 days 0:00:08.144
Loading Kernel Symbols
......................................................
Loading User Symbols
Mini Kernel Dump does not contain unloaded driver list
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 124, {0, fffffa80065ae8f8, 0, 0}

Probably caused by : hardware

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

WHEA_UNCORRECTABLE_ERROR (124)
A fatal hardware error has occurred. Parameter 1 identifies the type of error
source that reported the error. Parameter 2 holds the address of the
WHEA_ERROR_RECORD structure that describes the error conditon.
Arguments:
Arg1: 0000000000000000, Machine Check Exception
Arg2: fffffa80065ae8f8, Address of the WHEA_ERROR_RECORD structure.
Arg3: 0000000000000000, High order 32-bits of the MCi_STATUS value.
Arg4: 0000000000000000, Low order 32-bits of the MCi_STATUS value.

Debugging Details:
------------------


BUGCHECK_STR: 0x124_GenuineIntel

CUSTOMER_CRASH_COUNT: 1

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

PROCESS_NAME: System

CURRENT_IRQL: 0

STACK_TEXT:
fffff880`033776f0 fffff800`02ed3a89 : fffffa80`065ae8d0 fffffa80`05528b60 fffffa80`00000005 00000000`00000001 : nt!WheapCreateLiveTriageDump+0x6c
fffff880`03377c10 fffff800`02db5547 : fffffa80`065ae8d0 fffff800`02e2e5f8 fffffa80`05528b60 00000002`00000005 : nt!WheapCreateTriageDumpFromPreviousSession+0x49
fffff880`03377c40 fffff800`02d1db95 : fffff800`02e90360 fffffa80`06540b88 fffffa80`06540b80 fffffa80`05528b60 : nt!WheapProcessWorkQueueItem+0x57
fffff880`03377c80 fffff800`02c98161 : fffff880`00daee00 fffff800`02d1db70 fffffa80`05528b60 33593359`3c933c93 : nt!WheapWorkQueueWorkerRoutine+0x25
fffff880`03377cb0 fffff800`02f2e166 : fe0cfe0c`19c319c3 fffffa80`05528b60 00000000`00000080 fffffa80`055099e0 : nt!ExpWorkerThread+0x111
fffff880`03377d40 fffff800`02c69486 : fffff880`0316a180 fffffa80`05528b60 fffff880`031750c0 63796379`5c5a5c5a : nt!PspSystemThreadStartup+0x5a
fffff880`03377d80 00000000`00000000 : fffff880`03378000 fffff880`03372000 fffff880`04137540 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND: kb

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: hardware

IMAGE_NAME: hardware

DEBUG_FLR_IMAGE_TIMESTAMP: 0

FAILURE_BUCKET_ID: X64_0x124_GenuineIntel_PROCESSOR_MAE_PRV

BUCKET_ID: X64_0x124_GenuineIntel_PROCESSOR_MAE_PRV

Followup: MachineOwner
---------




This information seems related to my processor, but my computer never BSOD before, only in Bad company 2 Multiplayer,
Did tests like prime 95 for longer than a day, no crashs no errors, seems stable,
No overheats, No overclocked, just BSOD,

Does anyone know what's the problem?

Note: During BSOD, i got a message
BSOD. "A clock interrupt was not received on a secondary processor"

Spec:
Intel i7 920 (Bloomfield)
3x2gb Kingstone HyperX DDR3
Asus P6T Deluxe V2
ATI Radeon 4770
Computer usage: 6 months
OS: Windows 7 64bit Ultimate OEM
BSOD counts since new: Never until play Bad Company 2 Multiplayer.


My System SpecsSystem Spec
.

11 Mar 2010   #2

Windows 7 Professional x64
 
 

Hardware can mean a lot of things, but have you checked your RAM? Download a copy of Memtest86 and burn the ISO to a CD using ImgBurn. Boot from the CD, and run at least 5 passes.
My System SpecsSystem Spec
12 Mar 2010   #3

Windows 7 Ultimate 64bit OEM
 
 

Just do memtest86 v4.0 today, 6 passes without any errors.
My System SpecsSystem Spec
.


12 Mar 2010   #4

Windows 7 Professional x64
 
 

My System SpecsSystem Spec
17 Apr 2010   #5

Windows 7 Ultimate 64bit OEM
 
 

Thanks for help,

I just solve my problem,

It was my onboard sound problem, BSOD happens if I play bad company 2 with onboard sound enabled,

I tried completely uninstalled my sound driver, use windows driver instead, the problem still remain,

I disabled my onboard sound from BIOS, playing bad company 2 without sound, no more BSOD since then, (if i turn it back on, BSOD happens again)

I just got my new creative x-fi elite pro sound card last week, playing bad company 2 with it no problem so far, as long as I disabled my onboard sound in BIOS,

no more BSOD in past weeks, onboard sound was the cause, only happens to Bad company 2
My System SpecsSystem Spec
17 Apr 2010   #6

Windows 7 Professional x64
 
 

At least we know the cause now. Good diagnosing!

Let us know if you need anything else.
My System SpecsSystem Spec
17 Apr 2010   #7

Windows 7 Enterprise
 
 

Quote   Quote: Originally Posted by squall0833 View Post
Thanks for help,

I just solve my problem,

It was my onboard sound problem, BSOD happens if I play bad company 2 with onboard sound enabled,

I tried completely uninstalled my sound driver, use windows driver instead, the problem still remain,

I disabled my onboard sound from BIOS, playing bad company 2 without sound, no more BSOD since then, (if i turn it back on, BSOD happens again)

I just got my new creative x-fi elite pro sound card last week, playing bad company 2 with it no problem so far, as long as I disabled my onboard sound in BIOS,

no more BSOD in past weeks, onboard sound was the cause, only happens to Bad company 2
I have the exact same problem.

All games installed on this computer work flawlessly, but when my brother goes online to play 'Battlefield Bad Company 2', the game sometimes crashes/freezes and BSOD's.

I just don't understand what changes might affect the game to freeze when playing on-line.

I've used all my internet data for the month so the connection has been throttled. I also have some unexpected connection drop-outs so I actually thought that this may be the cause of the problem.

Why would additional on-line sounds cause the game to crash/freeze?

If this really is the problem to BFBC2-on-line, can somebody give me, or at least try to suggest a microscopical explanation to why exactly this causes the game to BSOD?

Is there anybody else having the exact same problem?

Thanks
My System SpecsSystem Spec
07 Jun 2010   #8

windows 7
 
 

I had the same problem with my Windows 7 64 bit installation and Battlefield 2 where the game would cause the computer to freeze completely with a fast repeating buzzing sound. I had no problems at first with Windows 7 but then one day I enabled the US landscape theme and set it to automatically change the desktop background image every 5 or 10 minutes. This is when the freezing during game play started to occur.

The solution, I simply changed the them back to the default windows 7 aero them with the windows logo in the middle. Ever since, no more freezing. I played BF2 for an hour straight with no problems, where as before I couldn't last for more than 10 minutes before I had to hard reboot my system. It took me a while to figure this out so I hope this helps.
My System SpecsSystem Spec
Reply

 Another different BSOD during gameplay: Bad Company 2




Thread Tools



Similar help and support threads for2: Another different BSOD during gameplay: Bad Company 2
Thread Forum
BSOD during gameplay BSOD Help and Support
Solved BSOD During gameplay and once during idle BSOD Help and Support
Random BSOD during gameplay 124/D1 BSOD Help and Support
bsod after 5 min of gameplay BSOD Help and Support
Solved BSOD - Usually after about 30 minutes of Gameplay BSOD Help and Support
Solved Random BSOD's during gameplay BSOD Help and Support
new rig crashing during gameplay BSOD BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:08 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33