Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird Mouse Icon Error

15 Mar 2010   #1

Windows 7 Ultimate 64-bit
 
 
Weird Mouse Icon Error

Hey,

I've been having this problem with my mouse icon where it changes into this odd vertical icon composed of 8 or so little images of just the top of the original mouse icon. Also, around when this happens, if the mouse icon needs to change to the "I" icon used for text, it begins to flicker and has 2 bars above it.

I've searched around and I've found some people who had a problem where the mouse randomly became enlarged but that was fixed with an ATI HD4800 series hotfix for the 9.12 driver, but the driver I'm using is version 10.2 which is the most up to date. It's not a major problem, mostly aesthetic really, but I'm worried that it might be a symptom of a larger problem, i.e. my graphics card slowly dying.

I noticed that the problem occurs (at least recently) when I'm moving the mouse from one monitor to the other (I have a dual monitor setup). The monitors have different resolutions. My primary is 1280x768 and my secondary is 1440x900.

Any thoughts that anyone could provide would be really appreciated. It's not a huge concern but I figure it's better to be safe than sorry.

Thanks,
Spacefreak

My System SpecsSystem Spec
.

15 Mar 2010   #2

Windows 7
 
 

Welcome to the forums, us new fellows need to stick together ^.^,

Could you provide a screen shot to get a better understanding of what you are talking about?

It sounds like to me a very rare flaw in the way the graphics card is displaying the mouse, should be fixable however.
My System SpecsSystem Spec
15 Mar 2010   #3

Windows 7 Ultimate 64-bit
 
 

Haha thanks, though to be honest I hope to not be here too often, or at least in the troubleshooting section.

Unfortunately, the problem isn't reproducible, so I can't post a screen shot right now, but when it happens again I'll be sure to post a shot.
My System SpecsSystem Spec
.


16 Mar 2010   #4

Windows 7 Ultimate 64-bit
 
 

I finally got the error to come up but apparently PrintScreen doesn't take the image of the mouse, which is brilliant yet terribly inconvenient in this case. I just took some pictures with my phone, which has surprisingly high resolution. Here's the link to a few images:

ImageShack Album - 3 images

The pictures are of the error propagating in three ways: normal arrow icon, blue spinning disc icon, and the icon that should usually be the "I" mouse icon for text. Sorry if the images are a bit choppy but that was the best I could do until the error went away. Interestingly, the error went away when I moved the mouse over to my other monitor and back to my first.
My System SpecsSystem Spec
16 Mar 2010   #5

Windows 7
 
 

Are you sure there isn't another driver released, possible another hot patch, for your card? the beta drivers are more reliable than you think, possibly check that out. However, this is if you are curios enough to do it, what happens if you downgrade the driver to 9.12? if the problem goes away for a while, upgrade back up to see if it happens again.

In my years working with drivers I have never came to an occurrence where a patch became needed for a reason, twice. It would be interesting to find if this is the case.
My System SpecsSystem Spec
16 Mar 2010   #6

Windows 7 Ultimate 64-bit
 
 

Haha I liked your idea and went to download the 9.12 driver and the hotfix, but I happened upon another hotfix for my current driver. Surprisingly, it corrects some error with alien vs. predator game as well as the same problem people were having before which is the enlarging of the mouse...

So apparently they didn't fix the problem in the updated drivers, which I don't quite understand and like you said is rather interesting. But hey, I'm not a computer programmer so I suppose I can't say anything.

I'll try installing the hotfix and seeing if the problem goes away and report back. Thanks for the tip!
My System SpecsSystem Spec
16 Mar 2010   #7

Windows 7
 
 

Quote   Quote: Originally Posted by Spacefreak View Post
I'll try installing the hotfix and seeing if the problem goes away and report back. Thanks for the tip!
No problem ^.^, I hope it fixes it!

(I also find it really interesting how it is put in a hot fix with a random thing like an "alien vs predator glitch", kind of amusing, but two birds one stone i suppose)
My System SpecsSystem Spec
17 Mar 2010   #8

Windows 7 Ultimate 64-bit
 
 

Bahhh, it didn't work. I still had the same mouse icon error and it happened while I was playing Battlefield: Bad Company 2. Though it definitely went away when I moved the mouse from one monitor to the other.

I looked some more online and I haven't found anyone else with the same problem on other forums. It's been happening much more recently as in within the past week or so. The only major change that I've made is updating my graphics driver to 10.2. I'll try and go back to 9.12 and see how that goes.

I remember having the problem before and I think the first time I noticed it was when I was playing Rise of Nations. I'm really at a loss as to what the problem could be if it's not the graphics driver. My mouse isn't anything particularly fancy and my cursor is just the standard Windows 7 cursor.
My System SpecsSystem Spec
19 Mar 2010   #9

Windows 7 Ultimate 64-bit
 
 

So I rolled back my graphics drivers from 10.2 to 10.1 two days ago, and I haven't experienced the problem since. So it seems like it's just a problem with the new 10.2 drivers. I'll just use 10.1 until 10.3 comes out and see if it's been resolved in that one. Thanks for the help!
My System SpecsSystem Spec
19 Mar 2010   #10

Windows 7 Ultimate 64-bit
 
 

Sigh... I spoke too soon. I had the problem again. I looked on the ATI forums and found a bunch of people there who are having the same problem and that hasn't been fixed since November, so... I'm not too optimistic.

Haha, I'll just have to hope that ATI gets it fixed soon. Thanks again
My System SpecsSystem Spec
Reply

 Weird Mouse Icon Error




Thread Tools



Similar help and support threads for2: Weird Mouse Icon Error
Thread Forum
Weird mouse cursor General Discussion
Mouse freezes, followed by system lag and mouse icon turns fuzzy *pics BSOD Help and Support
My mouse is acting weird General Discussion
Weird mouse lag problem. Hardware & Devices
Weird system error after weird BSOD BSOD Help and Support
Weird bug with mouse sensitivity Hardware & Devices
My mouse is weird. Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:55 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33