Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System 32 Problem

06 Jun 2010   #1
Lewis137

Windows 7 Home Premium
 
 
System 32 Problem

Hello everyone, as my last request for help on this forum was successful, I have come to you guys again before taking any action myself. I was re theming my computer, which involves replacing some system 32 files. I have the old ones backed up and have done this several times. This last recent time that i went to replace my Shell32.dll file it would say that it copied, but didn't. I tried several times and finally gave up. I then tried reconverting my backup Shell32.dll to the original. It still did nothing. Without even thinking whatsoever, I decided I was going to restart my computer to fix the problem. When I attempted to log back into my computer I get TONS of errors of programs and applications not being able to start up because "Shell32.dll" is missing. Including explorer.exe. So now i have a computer with a gray background and a mouse that i can move around. I am able to start it up in safe mode with command prompt but i have no idea what to do from there. Is there any way to fix this myself using command prompt? Or am I going to have to reinstall windows or something like that? Sorry for the what probably seem like stupid questions to you guys, not experienced with Windows problems like this. All help with be appreciated, thank you in advance.


My System SpecsSystem Spec
.

06 Jun 2010   #2
baarod

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by Lewis137 View Post
Hello everyone, as my last request for help on this forum was successful, I have come to you guys again before taking any action myself. I was re theming my computer, which involves replacing some system 32 files. I have the old ones backed up and have done this several times. This last recent time that i went to replace my Shell32.dll file it would say that it copied, but didn't. I tried several times and finally gave up. I then tried reconverting my backup Shell32.dll to the original. It still did nothing. Without even thinking whatsoever, I decided I was going to restart my computer to fix the problem. When I attempted to log back into my computer I get TONS of errors of programs and applications not being able to start up because "Shell32.dll" is missing. Including explorer.exe. So now i have a computer with a gray background and a mouse that i can move around. I am able to start it up in safe mode with command prompt but i have no idea what to do from there. Is there any way to fix this myself using command prompt? Or am I going to have to reinstall windows or something like that? Sorry for the what probably seem like stupid questions to you guys, not experienced with Windows problems like this. All help with be appreciated, thank you in advance.
While your computer is booting up and before the loading Windows screen appears press F8 repeatedly. This should bring up a text mode menu allowing you to restore from a previous system restore point.
My System SpecsSystem Spec
06 Jun 2010   #3
Tews

64-bit Windows 8.1 Pro
 
 

From your command prompt enter sfc /scannow ... though it may be necessary to do a repair install ... Let us know if this works..
My System SpecsSystem Spec
.


06 Jun 2010   #4
Lewis137

Windows 7 Home Premium
 
 

System Restore is in progress right now, thank you guys so much for the quick response time. If the system restore fails, i will try the command prompt option next.
My System SpecsSystem Spec
06 Jun 2010   #5
Lewis137

Windows 7 Home Premium
 
 

The system restore was successful! Thank you guys sooooo much. Definitely the last time I do any theming. Lol.
My System SpecsSystem Spec
06 Jun 2010   #6
Tews

64-bit Windows 8.1 Pro
 
 

Glad you sorted everything out!
My System SpecsSystem Spec
Reply

 System 32 Problem




Thread Tools





Similar help and support threads
Thread Forum
5.1 audio system problem
Hi, first off all sorry for my bad english. A couple a days i've bought an audio card Asus Xonar DGX. I own a Logitech Z506 and my sound is not 5.1 . I hope u guys could help me...i installed the driver and my center and rear speker don't work. only 2 or 3 speakers work. Cheers
Sound & Audio
Advanced System Optimizer, System Protector, Start up problem
Hello guys, I have this program in my computer called "Advanced System Optimizer" and it has a program called "System Protector" and I just want to disable it forever or at least not to show at my system start up, every time I turn on my computer it comes up and it is really annoying. There is...
Software
wtf system problem!!
hi everyone i have a pc that i asembled about an yr. ago with the following config: Asus M4A87TD USB3 AMD Phenom X6 1050T MSi n480GTX GPU Coolermaster GX650 psu Gskill trident 2x2GB 1600 Hz WD Caviar balck 1tb + caviar green 1tb
BSOD Help and Support
Another System 32 Problem
I joined this forum hoping for some answers to my two questions. First, you should now I'm on Windows 7 home premium, and norton security is the worst thing ever. Norton kept bugging me for money, so I decided to remove it from my computer. Once I did though, norton decided to take a bunch of...
General Discussion
think there may be a problem with my system for BitLocker?
I am wondering if you think there may be a problem with my system. I have it set currently dual boot, XP 32 bit on one partition, and Win7 Ultimate 64 Bit on the other partition, Partition boot manager was installed using the win7 setup. I am interested in setting up bitlocker. I am interested...
System Security
Problem with Word 2003 after system repair and system restore ?
Office Version:Office 2003 Operating System:Windows 7 http://i4.social.answers.microsoft.com/Forums/resources/images/trans.gif?cver=2.13.0068.4 After a number of issues regarding my HP OfficeJet 7410 All-In-One problems (absolutely no help from HP by the way)...I decided to try a "System...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App