Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Booting Issue (TestDisk / PartedMagic)

03 Jul 2010   #11

Windows 7 Ultimate

Just wondering, would you recommend doing the Startup Repair, or bootsector.exe fix MBR first. I only ask because I had potentially overwrote the MFT.

edit: btw, at the risk of being pure annoying, just wanted to say thanks again.

My System SpecsSystem Spec
03 Jul 2010   #12

Microsoft Community Contributor Award Recipient


Startup Repair
Note: You may need to do startup repair 3 to 4 times.[/QUOTE]


Make sure Windows 7 partition is active.Partition - Mark as Active

Type in command line
Try this:
bootrec /fixboot
bootrec /fixmbr
bootrec /rebuildbcd
My System SpecsSystem Spec
03 Jul 2010   #13

Windows 7 Ultimate

Still not allowing me to access Startup Repair (via console which fails to appear or at Windows Startup). When trying to set the partition as the active one, after DISKPART the command prompt displays the initial info, than won't allow any typing, freezes. Same happens if I just type in "DISKPART>list disk" no listing just a frozen command prompt.

Been running rebuildbcd, any it also appears frozen.

edit: I ran "bcd edit" and got the following and found that:

Windows Boot Manager device was set a C:


Windows Boot Loader device was set a D:

would changing this to C, potentially help, or is this just my data partition loading at the same time?
My System SpecsSystem Spec

04 Jul 2010   #14

Windows 7 Ultimate

Here's an update:

Original problem was that I was receiving an unmountable boot volume error with a BSOD. After taking a stab at a few solutions the situation is now this. Upon being able to enter the recovery console the only Windows 7 installation showing up on the list is the system recovery reserve. I can access the command prompt, but cannot perform all commands, for example upon entering "diskpart" and than "list disk" the prompt does nothing.

I noticed the system reserve portion of the HDD was set as "boot." I used a bootable OS (PartedMagic) to set the "boot" partition to the C: the system partition. I also redirected Windows Load Manager / Boot Manager to "C:" for "default ospartition" etc.

Rebooting I found a new error "bootmgr not found" so I copied the boot files from the system reserved recovery porition of the HDD to the system porition. Now following the windows loading bar, I receive a blank screen, and cannot access the recovery console via the installation disc. Anyone have any suggestions? ANY advice is extremely appreciated!
My System SpecsSystem Spec
04 Jul 2010   #15

Windows 7 Ultimate

Sorry for the shameless bump (even though there is some shame) just hoping someone may stumble across it and think of a suggestion.

Thanks theog for the help so far, you helped me make some progress.
My System SpecsSystem Spec
11 Dec 2011   #16

Windows 7 Home Premium 64bit

I am just reporting a similar incident from which i was able to recover.

It started as i was stepping through the recovery disk i had made with the Windows 7 facilities toward re-imaging from an image i had stored in an external drive (Scorpio Blue) using (again) the Windows 7 facilities. I was not quite ready to execute, so i cancelled out of the dialogue process toward a re-image. After that, when i rebooted, i got error message:

"bootmgr not found"

So i used my recently-made restore/repair disk to repair and after one or two tries, was successful in getting Windows to boot normally.
That's one issue. The other thing that happened was after i re-imaged my C: drive, the external HD gained an additional partition called 'System Reserve', which was about 62 MB free of 99 MB. It appeared empty when opened, but would store and show a text file if i wanted. Besides that, i could not see/find the 299 GB partition anymore on the external HD. My battery ran out of power, so i resumed troubleshooting in the morning with power, and this time was able to find the temporarily lost partition on the external HD. It was gone, and now it was back.
I've survived, and am pretty impressed with the backup facilities in Windows 7 (Home Premium), but thought i would just report this to give someone/anyone a heads up in case there is something here that needs to be addressed among Microsoft troubleshooters.

My System SpecsSystem Spec

 Booting Issue (TestDisk / PartedMagic)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Recover a flash drive turned RAW Partition Wizard and TestDisk.
Of late a lot of interest has been generated in using the Partition Recovey Wizard of MiniTools Partition Wizard (PW). Venerable gregrocker brought out a new feature – extending a partition with even non-adjacent space - in the MiniTools Partition Wizard (PW) here:...
How to run PartedMagic as A Bootable DVD on 64-bit AMD Turion
I have been trying to run PartedMagic from Ultimate Boot CD (UBCD) as a bootable DVD from ISO. It works fine on my 32-bit Intel Core 2 Duo, but doesn't work on my AMD Turion II P540 Dual-core processor. I am running Windows 7-64 bit SP1 on this computer now. When I try to run PartedMagic from the...
Usb Booting Issue
Got a computer that will not boot to Usb even though the bios has the "boot to usb hdd" selection in the boot up menu. Got another almost identical 2nd computer setup and have no issue booting to the same LaCie cloned to that computer. Just setup an HP Omni 27-1054 pc cloned to the Lacie and it...
Hardware & Devices
Issue booting Win 7, booting directly into XP & no boot manager
Hi, I just got a ASUS G75V series and updated it to windows 7 professional with Intel core i7. I was able to work with it and everything was fine until I had to install XP because some softwares are not compatible with Win 7 x64. I have Win 7 on drive C: and windows xp on drive E: which in...
Installation & Setup
booting issue
This is my first time using a forum so if its not in the right area my apologies. My issue is my laptop when turned on does standard startup says loading windows then blue screens, it then turns back on as if to go through startup again but brings up a menu saying start windows normally or go to...
BSOD Help and Support
Anyone famliar with testdisk utility? hard drive problem.
my external harddrive seems to have crapped out on me. I'ts just one data partiotion.I go to computer/manage- disk manager and it takes like 5 minutes to even show the drive. Windows can't access the external harddrive. It was saying I had to format it and was being reported as raw. I'm running...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:13.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App